ODBC - Varchar(max) RRS feed

  • Question

  • We have some legacy VB6 applications that connect to Azure SQL using the ODBC 13 Driver and around noon CST yesterday, all of a sudden any reads on varchar(max) columns resulted in garbage looking data. Tried upgrading to ODBC 17, no difference. The only thing that worked was changing varchar(max) to varchar(8000).

    This has been working for months, and just suddenly stopped mid-day yesterday. Did something change?

    Friday, December 21, 2018 6:29 PM

All replies

  • Hi Britishcanuck,

    Do you have an Azure Support Plan? If not, I can have a one-time incident ticket created for you to have this issue investigated. Please send your Azure subscription GUID to AzCommunity at Microsoft.com and I will send back instructions to have this issue investigated.

    There are rolling updates to the service so it is possible that updates were made. Are you aware of any changes made on your side? 



    Friday, December 21, 2018 10:03 PM
  • I received your message, instructions will be sent shortly. Thanks! Please emphasize unannounced service updates in your incident ticket. Ask for Release Notes! Azure SQL Data Warehouse is now including Release Notes with their documentation. Azure SQL Database services should be doing the same. Thank you!
    Saturday, December 22, 2018 12:19 AM