none
IMAP Search with UTF-8

All replies

  • Hi Saaj,

    Base on my search, it is supported UTF-8 charset for IMAP search .

    Best regards,


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Niko Cheng
    TechNet Community Support

    Wednesday, May 27, 2015 8:29 AM
    Moderator
  • Thanks Niko.

    Do you have any links to sites which mention that utf-8 is supported for IMAP search? Please share them if you do.

    I'm running a trial version of Exchange 2013 and we're trying to do an IMAP search passing the charset as UTF-8 and its failing but when I pass US-ASCII as the charset it responds.

    I'm not sure if UTF-8 support has to be manually enabled on the Exchange server. Any information regarding UTF-8 support for IMAP search would be helpful.  

    Regards,

    Saaj

    Wednesday, May 27, 2015 10:48 AM
  • Hi 

    I am also having the same problem. When I execute the following command with telnet againts our Exchange 2013 mail server:

    UID SEARCH CHARSET UTF-8 BODY "some text"

    I get the following response:

    NO [BADCHARSET (US-ASCII)] The specified charset is not supported.

    But if I execute the following command:

    UID SEARCH BODY "some text"

    I get the following response

    OK SEARCH completed.

    Is there a way to enable UTF-8 character set support for the IMAP4 SEARCH command in Exchange 2013?

    Thanks

    Andy

    Tuesday, September 29, 2015 3:41 PM