locked
Migration of Equipment Reservation site collection gives "resource not available" after migration RRS feed

  • Question

  • I am trying to migrate a site collection based on Fab-40 template "Room Equipment Reservation" from a MOSS 2007 farm (CU Aug 2010) to another MOSS farm (same patchlevel, RER template also installed). I tried stsadm with backup/restore.

    After recovering I discovered that whenever I make a new entry in the reservation list got the error"The resource you are trying to reserve is not available at the time you specified". After some searching I found "http://social.technet.microsoft.com/Forums/en-US/sharepointcollaboration/thread/8178056f-57fc-4bac-8ffe-d7f68342f195/". The solution suggested there (create resources again) is not an option since the a lot of reservations have been made and I don't want to create those entries manually. Can I restore this site without using the system account? I tried to add my user account (I used the system account for migration) as a local admin on the web front end and farm administrator in MOSS, but when I tried to use stsadm I got access denied. Anybody any ideas how to migrate a Room Equipment Reservation based site collection  to a new farm? Any help is appreciated.

     

     

    Tuesday, June 14, 2011 2:05 PM

Answers

  • Thank you for your answer. I could not check it, because we resolved it by using Metalogix SharePoint Site Migration Manager 4. With SSMM4 we copied the site collection including all rights and workflows, and that worked. For people that has a similar issue: in SSMM connect to the source webapp (not the site collection) and copy from there the site collection to the target webapp.

    This issue is solved.


    Tuesday, June 21, 2011 7:03 AM

All replies

  • Hi William,

    Base on my reseach, in order to reserve a resource, the resource must be existing in the Reservations list. The resource must have Status(Hide field) as Active, have Start date, but don't have end date.
    Actually, when add a new resource, a backgroup workflow will run, and the workflow will the the related resource to Reservations with the data I mentioned.

    In case the workflow is not running, the resources are not updated to Reservations. This caused the issue you met.

    To fix the issue, please follow these steps:

    1. Open the site in SharePoint Designer(SPD)
    2. Open the workflow Setup, and open the XML file Setup.xoml.wfconfig.xml
    3. Add the following configuration to the XML file

      StartManually="true"

      The final XML
      ......
          <Association
              ListID="<list id>"
              TaskListID="<Task list id>"
              StartOnCreate="true"
              StartManually="true"
          >
      ...
    4. Publish the workflow
    5. Now, go to Resources list, start the workflow on each resource manually

    After that, we will be able to reserve a resource again.

    If you have any more questions, please feel free to ask.

    Thanks,
    Jinchun Chen


    Jin Chen - MSFT
    Friday, June 17, 2011 7:05 AM
    Moderator
  • Thank you for your answer. I could not check it, because we resolved it by using Metalogix SharePoint Site Migration Manager 4. With SSMM4 we copied the site collection including all rights and workflows, and that worked. For people that has a similar issue: in SSMM connect to the source webapp (not the site collection) and copy from there the site collection to the target webapp.

    This issue is solved.


    Tuesday, June 21, 2011 7:03 AM
  • Please confirm that your company has no commercial relationship with Metalogix (Re-seller of Metalogix products etc.) and that you do not work for them.

    I find it odd that you asked on the 14th of June for a general solution yet by the 21st of June you already had bought and used a Metalogix product. That's certainly an order process that is much faster than any I have seen and yet if you already had the Metalogix product available, why did you ask for a general solution?

    Apologies for my suspicions but I've seen this kind of product adverts before (if that indeed is what it is) - i.e. a question solved amazingly by a product a few days later (and here you didn't even bother trying out the free solution offered by the MS support person here only three days after you posted your question).

     

    Moderator pre-SP 2010


    SP 2010 "FAQ" (mainly useful links): http://wssv4faq.mindsharp.com/default.aspx
    WSS3/MOSS FAQ (FAQ and Links) http://wssv3faq.mindsharp.com/default.aspx
    Both also have links to extensive book lists and to (free) on-line chapters
    Tuesday, June 21, 2011 7:32 AM
  • Sorry I did not return to this topic earlier. No, I am not a reseller of this product or work for them. That tool was bought for a totally different project, where it is causing havoc and nightmares. It helped here though. I mentioned my solution without any commercial intentions.
    Wednesday, August 17, 2011 6:55 PM