locked
How to block an external email address from sending email to Exchange 2007 Organization? RRS feed

  • Question

  • Hi,

    We have an Exchange 2007 organization. To block an email address (it's a googlegroups address, by the way) I enabled sender filtering on my Edge Servers and entered that email address. But the emails from that address keep coming through. I have a few other email addresses added to sender filtering and it is working fine for those but for that particular address i don't know why. Could someone please suggest how to make it work for that particular (googlegroups) address?

    Thanks in advance

    P.S. Sorry about multiple posts
    Sunday, October 11, 2009 8:23 AM

All replies

  • I have created a Transport rule on my Edge servers. On the Conditions page, i selected when the From address contains the specific words (entered my yahoo email address for test purposes) and from users Outside the organization . On the Actions page, i selected reject the message with the status code . It worked fine but i'll have to wait and check if it will work for that email address.

    Regards
    • Marked as answer by Undying Lament Saturday, October 17, 2009 7:47 AM
    • Unmarked as answer by Undying Lament Saturday, October 24, 2009 7:24 AM
    Sunday, October 11, 2009 9:06 AM
  • HI

    Yes according to your configuration its works now verify by right click the message and check in detailed option in outlook 2007 or 2003 .and evulate all internal ip's as well public ip's.

    http://searchexchange.techtarget.com/generic/0,295582,sid43_gci1262402,00.html#

    Regards
    Syed Arsalan ,


    syed.arsalan
    Sunday, October 11, 2009 12:20 PM
  • UPDATE:

    Hi,

    I just checked the message tracking log on my edge servers and found that emails from the culprit address are still coming through. I'm really annoyed by this. I don't know why the sender filtering and transport rule are failing to work for that particular email address (they are working for other emails).
    Saturday, October 24, 2009 7:25 AM
  • Sounds like you need to double check that the From address that you are using is an exact match to the one on the Email's in question. You also might want to consider blocking on something other than the From address, since it's a googlegroup do they use the group name in the subject or something alone those lines.

    Thanks

    Will


    Will Shepherd - MCSE/MCITP/MCTS (Windows 2008,Exchange 2007,OCS 2007)
    Saturday, October 24, 2009 3:30 PM