locked
Selecting a KPI from the cube results in an error: "An item with the same key has already been added". RRS feed

  • Question

  • Hi,

    Yesterday Ive been creating some KPI's and scorecards with PerformancePoint and I even had some colleagues working with it as well. We started out well and created some decent scorecards (WITH imported KPI's from the analysis server).

    Later that afternoon my Datasource starts acting up (could not connect anymore, etc) but this was only for a small period of time, some problems with the server I assume. After this was over, everything worked as normal and all created scorecards could be refreshed without problems. But when we tried to create a new scorecard and during the wizard try to select an existing KPI from the cube on the analysis server, we get a message saying something like "An error has occured. Contact your administrator if this error persists. There may be additional information in the application log.". Naturally I checked the application log, which gives a few errors for the PP, mostly saying "An item with the same key has already been added".

    Where does this problem come from? And more important, how can I fix it? (I tested the connection which is good, I can use the KPI's I imported earlier and generate the older scorecards, I just cant create a new one when I want to import KPI's. I also checked my rights on the cube and theyre fine, account and cube are still there).
    • Edited by ckumark Friday, June 26, 2009 5:46 PM Fixing thread title bug
    Friday, June 19, 2009 1:49 PM

All replies

  • does this happen when you create a new dashboard and then import KPI's again?
    Friday, June 19, 2009 2:25 PM
  • It only happens when I add a new scorecard. The process is:
    * Add a new scorecard
    * Wizard starts
    * Name scorecard, grant everyone permission and hit next
    * Select a datasource and hit next
    * Select "KPI Source" -> "Import SQL Server Analysis Services KPI" and hit next
    * now the pop-up with the error shows up instead of the normal list of KPI's from the cube...

    The weird thing about the duplicate key is that I never reached a stage where I save anything yet, so there is nothing that can cause the duplicate key error I think?...
    Friday, June 19, 2009 2:31 PM
  • Hi,
    Was this ever fixed? - we have the exact same problem.
    Rgds,
    Jens
    Wednesday, March 17, 2010 9:08 AM