none
Public folder - message size limits and sub folders RRS feed

  • Question

  • We have Exchange 2010, Public folders are still on Exchagne 2007 while we work on migrating them over to 2010.

    I need to setup permissions so users cannot place email messages over say 3mb in the public folders.  I can set this on the main folder for 2012 Emails however subfolders are not getting the limitations set on the parent.

    is there a way to push this so all existing folders and any new folders and subfolders get these limitations? 

     

    Tuesday, January 24, 2012 10:44 PM

Answers

  • Using the following command sets the folder \Root Public Folder\Subfolder to a 3MB item limit and sets all folders below it the same.
    Get-PublicFolder -Identity "\Root Public Folder\Subfolder" -Recurse | Set-PublicFolder -MaxItemSize 3MB 
    

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    • Edited by Ed CrowleyMVP, Moderator Wednesday, January 25, 2012 1:18 AM
    • Marked as answer by Ron HRC Wednesday, January 25, 2012 7:14 PM
    • Unmarked as answer by Ron HRC Friday, February 3, 2012 2:46 PM
    • Marked as answer by Ron HRC Friday, February 3, 2012 9:56 PM
    Wednesday, January 25, 2012 1:17 AM
    Moderator

All replies

  • Using the following command sets the folder \Root Public Folder\Subfolder to a 3MB item limit and sets all folders below it the same.
    Get-PublicFolder -Identity "\Root Public Folder\Subfolder" -Recurse | Set-PublicFolder -MaxItemSize 3MB 
    

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    • Edited by Ed CrowleyMVP, Moderator Wednesday, January 25, 2012 1:18 AM
    • Marked as answer by Ron HRC Wednesday, January 25, 2012 7:14 PM
    • Unmarked as answer by Ron HRC Friday, February 3, 2012 2:46 PM
    • Marked as answer by Ron HRC Friday, February 3, 2012 9:56 PM
    Wednesday, January 25, 2012 1:17 AM
    Moderator
  • Ed, Thanks for the reply I think were getting closer

    So I needed to run

           Get-PublicFolder -Identity "\Root Public Folder\Subfolder" -Recurse | Set-PublicFolder -UseDatabaseQuotaDefaults $false

    First to allow the parameter to be set.

    After I did this is did set the folder and subfolder correctly with the 3MB limit

    However, when I created a new folder under the Subfolder it did not get the 3MB limit and went back to use the database quota defaults.  Is there a way to get this to default to 3MB for all new folders and subfolders?

    Thanks

    Wednesday, January 25, 2012 1:39 PM
  • Apparently not.  You could put the command in a .ps1 file and schedule it to run from time to time.
    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Wednesday, January 25, 2012 5:20 PM
    Moderator
  • Thank you Ed

    I will look at either changing this at the Public Folder database level or running it as a .ps1 file throughout the day.

     

    Wednesday, January 25, 2012 7:15 PM
  • Yesterday I set Storage Limits -> Maximum item size (MB) to the Public Folder database

    I have it set to 1MB (really trying to restrict and stop the usage of public folders)

    the change was applied, I waited 2 hours and tried copying a 5MB email into the public folders and it copyed it there just fine

    I used the Public Folder Management Console and verified that the User database quota defaults was checked and it is....

    so how do I get this to quota to actually be enforced?

    Thank for helping!

    Friday, February 3, 2012 2:16 PM
  • A better way to restrict the use of public folders is to change rights.  Take away everyone's ability to write to them, granting them read access only.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Friday, February 3, 2012 4:47 PM
    Moderator