none
MDT 2013 - All User Exit scripts fail with - "Unable to parse the user exit script file: Invalid character (1032)" RRS feed

  • Question

  • While attempting to implement the computer naming UserExit script technique found here:

    blog.primaryschooltech.co.uk/2013/02/mdt-naming-trick-show-machines-existing.html

    and here:

    social.technet.microsoft.com/Forums/en-US/a59e16f9-16e3-44cf-9e33-85bf6c16ecfe/mdt-and-computer-name?forum=mdt

    I found the scripts failing to run with the error "Unable to parse the user exit script file:  Invalid character (1032)".

    After much troubleshooting I discovered I am unable to execute any script via the UserExit script option in CustomSettings.ini.  All scripts fail with the exact same error regardless of content or deployment share. 

    Has anyone else seen this?

    Thursday, June 19, 2014 10:47 PM

Answers

All replies

  • According to this site, unicode character 1032 looks like a backtick (`).

    Check your script to see if this character is present. Since it looks a lot like the vbscript single quote character used for comments (') it might be difficult to spot.

    Friday, June 20, 2014 1:50 PM
  • I too thought the 1032 error pointed to a particular character, but I tried replacing all punctuation and special characters; retyping the entire script; and plugging in my own scripts.  Doesn't matter what script I use, they all fail with the same error.  Even a simple wscript.echo throws the 1032 error.

         

    Friday, June 20, 2014 3:07 PM
  • Open the file in notepad and save the file with the Encoding type set to ANSI.

    Keith Garner - Principal Consultant [owner] - http://DeploymentLive.com

    Tuesday, June 24, 2014 7:02 PM
    Moderator
  • I had already tried that with no success. I'm starting to think my MDT implementation is simply broken. I've since moved everything into SCCM (with MDT integration) and am now beyond this issue. Thanks for your input.
    Wednesday, June 25, 2014 12:25 AM