locked
User Changed her name and it is not showing up in "Welcome user" in the main site RRS feed

  • Question

  • the users name was changed in AD and "Welcome Cynthia newsame" is working not working in the main site "Welcome Cynthia oldname"

    I have run migrate user on the account and have run sync as well.  Can someone help me resolve this.

    Jim

    Monday, October 31, 2011 4:55 PM

Answers

  • There's a profile sync job that runs periodically to update the profile information.  Check out the following article...

    User Information List not Synchronised with User Profiles

    HTH

    - M


    Michael Mukalian | Jan 2010 - Dec 2010 MVP SharePoint Services | MCTS: MOSS 2007 Configuration | http://www.mukalian.com/blog
    Monday, October 31, 2011 6:48 PM
  • Hi,

    There is a hidden fact about these jobs. These jobs do not update details of all users it only do it for the active users.

    An active user is classified as the user who has carried out any change in the site ever. You can check this by viewing the column IsActiveUser in userinfo table in content database. To resolve these try following steps:

    1. Ask the user to carry out any changes in the site.

    2. If the first one is not possible then go to any user group and resolve the new name. Like add oldname, Cynthia in the user box and resolve this will update her data in the userinfo table.

    3. If the above ways do not work then try removing her from any site collection and add her again.

    I hope this will help you out.

     


    Thanks, Rahul Rashu
    Monday, October 31, 2011 8:13 PM

All replies

  • I find the users mysite under her old name but when I try to go to that address I get that it is not found but the user can go to the MYSite from her home page.

    I thought both "welcomes" took their information from the profile in Saharepoint so I looked at the profile and it showed up under the new user name.  Can someone elaborated on how this get populated.    

    Thanks

    Monday, October 31, 2011 5:20 PM
  • There's a profile sync job that runs periodically to update the profile information.  Check out the following article...

    User Information List not Synchronised with User Profiles

    HTH

    - M


    Michael Mukalian | Jan 2010 - Dec 2010 MVP SharePoint Services | MCTS: MOSS 2007 Configuration | http://www.mukalian.com/blog
    Monday, October 31, 2011 6:48 PM
  • Hi,

    There is a hidden fact about these jobs. These jobs do not update details of all users it only do it for the active users.

    An active user is classified as the user who has carried out any change in the site ever. You can check this by viewing the column IsActiveUser in userinfo table in content database. To resolve these try following steps:

    1. Ask the user to carry out any changes in the site.

    2. If the first one is not possible then go to any user group and resolve the new name. Like add oldname, Cynthia in the user box and resolve this will update her data in the userinfo table.

    3. If the above ways do not work then try removing her from any site collection and add her again.

    I hope this will help you out.

     


    Thanks, Rahul Rashu
    Monday, October 31, 2011 8:13 PM
  • Hi,

     

    I agree with Michael and Rashu.Rahul.

     

    In sharepoint 2010, user profile information is stored at two places, UserInfo table in content database and UserProfile table in User Profile database.

     

    The User Profile Services Application database is kept up to date with the profile information in the User Directory services via an incremental profile timer import job.

     

    A SharePoint Server 2010 timer job replicates the profile information in the User Profile Services Application database in the individual content database’s UserInfo table. This timer runs every hour and copies properties, such as picture and department.

     

    In addition, you can refer to the following article:

     

    http://blogs.technet.com/b/sushrao1/archive/2011/04/23/sharepoint-display-name-does-not-update-when-nt-authority-authenticated-users-are-added-to-site-s-visitors-group.aspx

     

    Thanks,

    Rock Wang

    Forum Support

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Regards, Rock Wang Microsoft Online Community Support
    Tuesday, November 1, 2011 3:09 AM
  • Hi,

    I am wondering if you resovle your issue, please drop me a note if you have any questions.

    Thanks,

    Rock Wang

    Forum Support

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Regards, Rock Wang Microsoft Online Community Support
    Thursday, November 3, 2011 3:47 AM