none
No providers for Firewall RRS feed

  • Question

  • We are using Windows 10 1903 Enterprise. A User reported that he was not able to access a VM via RDP. User account was already added in the Remote desktop users group and was able to access the VM few hours ago.

    We tried to check the firewall but could not access it.

    We checked and found that there were no Providers in Firewall section of Security providers. Please suggest what could be the cause and how could have we restored Windows Firewall as Firewall provider. Please help.


    • Edited by 3M3M3M Thursday, January 9, 2020 6:27 PM Edit
    Thursday, January 9, 2020 5:53 PM

All replies


    1. Go to Search, type services.msc, and open Services
    2. Look for Windows Defender Firewall
    3. Right-click on it, and choose Restart
    4. Wait until the process is finished
    5. Now, right-click on Windows Firewall, and go to Properties
    6. Make sure Startup type is set to Automatic

    Run the troubleshooter:

    1. Download the dedicated Firewall Troubleshooter, here.
    2. Run the tool and click on Advanced.
    3. Check the ”Apply repairs automatically” box and click Next.
    4. Wait for the procedure to finish and look for changes.

    Reset Firewall:

    reset Windows Firewall settings and address the issue at hand:
    1. Type Firewall in the Windows Search bar and open Windows Defender Firewall from the list of results.
    2. Click on Restore defaults in the left pane.
    3. Click on the ”Restore defaults” button and reboot your PC.


    S.Sengupta,Microsoft MVP Windows and Devices for IT, Windows Insider MVP

    Thursday, January 9, 2020 10:53 PM
  • Thank you, this has fixed the issue. How can I find the cause please?

    Download the dedicated Firewall Troubleshooter, here.

    Friday, January 10, 2020 1:46 PM
  • Hi,

    Just checking the current situation of your problem.

    Was your issue resolved?

    Best regards,

    Ellen


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.




    Monday, January 13, 2020 8:10 AM
  • Thank you Ellen, I have still not been able to find the root cause.
    Monday, January 13, 2020 9:44 AM
  • Hi,

    Since the limited resource in forum, we cannot help you to find the root cause.

    I would suggest you contact Microsoft Customer Services and Support to get an efficient solution:

    Global Customer Service phone numbers 

    https://support.microsoft.com/en-us/gp/customer-service-phone-numbers/en-au?wa=wsignin1.0

    Have a nice day!

    Ellen


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.




    Thursday, January 16, 2020 8:39 AM
  • Hi,

    You could mark the useful reply as answer if you want to end this thread up.

    If there is anything else we can do for you, please feel free to post in the forum.

    Best Regards,

    Ellen


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, January 22, 2020 2:56 AM