locked
Cannot connect to FAST Search server RRS feed

  • Question

  • From the ULS:

    Failed to connect to myfastserver.mydomain.com:13391 sp. Error=Failed to initialize session with document engine: Unable to resolve Contentdistributor  [documentsubmitterworkerthread.cpp:132]  d:\office\source\search\native\gather\plugins\contentpi\documentsubmitterworkerthread.cpp

    Docpush -c sp myfile.txt works fine. And I can do a search from FAST search center and find the new file.

    Q1: How do I determine if SSL is working correctly between my SP Server and my FAST Search Server?

    Q2: The FAST Search server has port 13391 open. Does this port also need to be opened on the SP Server or are all communications (crawling etc) made over port 443?

    Q3: Why does the error refer to d:\office... when this the DVD drive (place FAST was installed from)

    Monday, August 30, 2010 7:32 AM

Answers

  • Hi,

    This error indicate that there's something related to the certificate , please confirm the below steps

     

    1.       Copy the script securefastsearchconnector.ps1 from the FAST Search Server 2010 for SharePoint admin server to the SharePoint Server 2010 server. The securefastsearchconnector.ps1 script is in the installation folder, under installer\scripts\.

    2.       Copy the certificate file FASTSearchCert.pfx from the FAST Search Server 2010 for SharePoint admin server to the SharePoint Server 2010 server. The certificate file is in the installation folder, underdata\data_security\cert\.

    3.       Open a Microsoft SharePoint 2010 Administration Shell with the Run as administrator option on the SharePoint Server 2010 server.

    Navigate to the directory where you copied the securefastsearchconnector.ps1 script and run it, replacing the necessary parameters with the values for your environment. The domain and user name should reflect the details of the user running the SharePoint Server Search 14 (OSearch14) service.

    .\SecureFASTSearchConnector.ps1 –certPath “path of the certificate\certificatename.pfx” –ssaName “name of your content SSA” –username “domain\username”

    When prompted to enter the certificate password, enter the certificate password that you supplied when you ran the post-setup configuration of FAST Search Server 2010 for SharePoint

     

     

    Monday, August 30, 2010 8:25 AM

All replies

  • Hi,

    This error indicate that there's something related to the certificate , please confirm the below steps

     

    1.       Copy the script securefastsearchconnector.ps1 from the FAST Search Server 2010 for SharePoint admin server to the SharePoint Server 2010 server. The securefastsearchconnector.ps1 script is in the installation folder, under installer\scripts\.

    2.       Copy the certificate file FASTSearchCert.pfx from the FAST Search Server 2010 for SharePoint admin server to the SharePoint Server 2010 server. The certificate file is in the installation folder, underdata\data_security\cert\.

    3.       Open a Microsoft SharePoint 2010 Administration Shell with the Run as administrator option on the SharePoint Server 2010 server.

    Navigate to the directory where you copied the securefastsearchconnector.ps1 script and run it, replacing the necessary parameters with the values for your environment. The domain and user name should reflect the details of the user running the SharePoint Server Search 14 (OSearch14) service.

    .\SecureFASTSearchConnector.ps1 –certPath “path of the certificate\certificatename.pfx” –ssaName “name of your content SSA” –username “domain\username”

    When prompted to enter the certificate password, enter the certificate password that you supplied when you ran the post-setup configuration of FAST Search Server 2010 for SharePoint

     

     

    Monday, August 30, 2010 8:25 AM
  • Reapplied the SSL setup with searfastsearchconnector.ps1 script and search is working again. Not sure why the Office Web Apps installation broke the SSL setup but thanks.
    Tuesday, August 31, 2010 10:50 AM
  • Still don't understand why installing Office Web Apps broke the SSL and I needed to reapply the cerficate on the SP server.
    Wednesday, September 1, 2010 1:02 AM