locked
Install IE 11 on Windows 7 SP1 RRS feed

  • Question

  • I cant seem to install IE 11 on Windows 7 SP1 and have now been trying for a while..

    Windows fully updated (Apart from IE 11)

    Currently has IE 10

    Methods trying:

    Windows update

    Download the offline installer

    IE customization tool

    Nothing seems to be working.

    Here is the IE_Main log:

    00:00.000: ====================================================================
    00:00.265: Started: 2014/08/11 (Y/M/D) 08:15:49.177 (local)
    00:00.281: Time Format in this log: MM:ss.mmm (minutes:seconds.milliseconds)
    00:00.296: Command line: "C:\windows\SoftwareDistribution\Download\Install\IE11-Windows6.1-x86-en-us.exe" /WU-SILENT
    00:00.312: INFO:    Setup installer for Internet Explorer: 11.0.9600.16428
    00:00.343: INFO:    Previous version of Internet Explorer: 10.0.9200.17028
    00:00.343: INFO:    Checking if iexplore.exe's current version is between 11.0.9600.0...
    00:00.359: INFO:    ...and 11.1.0.0...
    00:00.359: INFO:    Maximum version on which to run IEAK branding is: 11.1.0.0...
    00:00.374: INFO:    iexplore.exe version check success. Install can proceed.
    00:00.374: INFO:    Operating System: Windows Workstation: 6.1.7601 (Service Pack 1)
    00:00.390: INFO:    Trying to extract ID: SetupDownloadList.txt (0) as "SetupDownloadList.txt"
    00:00.421: INFO:    Trying to extract ID: HardwareBlockingList.xml (0) as "HardwareBlockingList.xml"
    00:00.421: INFO:    Trying to extract ID: 6006 (0) as "IE11-neutral.Extracted.cab"
    00:01.310: INFO:    Trying to extract ID: 5501 (1033) as "Spelling_en.msu"
    00:01.373: INFO:    Extracted Spelling dictionary for en to C:\windows\TEMP\IE1215C.tmp\Spelling_en.msu.
    00:01.373: INFO:    Trying to extract ID: 5502 (1033) as "Hyphenation_en.msu"
    00:01.404: INFO:    Extracted Hyphenation dictionary for en to C:\windows\TEMP\IE1215C.tmp\Hyphenation_en.msu.
    00:01.404: INFO:    Trying to extract ID: 6128 (1033) as "IE11-support.cab"
    00:05.788: INFO:    Updated Download list, Hardware Blocking list, and no reboot policy files successfully downloaded and extracted for use.
    00:06.084: INFO:    Launched program to check hardware: "C:\windows\TEMP\IE1215C.tmp\IE11-SUPPORT\IEXPLORE.EXE" /CheckHardware "C:\windows\TEMP\IE1215C.tmp\IE11-support\HardwareBlockingList.xml"
    00:06.786: INFO:    Graphics Device Information: VMware SVGA 3D
    00:06.802: INFO:    Hardware support check succeeded. Installation will continue.
    00:06.817: INFO:    Windows 7 operating system detected.
    00:06.817: INFO:    Service pack major: 1
    00:06.833: INFO:    Service pack minor: 0
    00:06.833: INFO:    Service pack name:  Service Pack 1
    00:06.848: INFO:    Version Check for (KB2834140) of C:\windows\System32\d3d11.dll: 6.2.9200.16570 >= 6.2.9200.16570 (True)
    00:06.848: INFO:    Version Check for (KB2670838) of C:\windows\System32\api-ms-win-downlevel-user32-l1-1-0.dll: 6.2.9200.16492 >= 6.2.9200.16426 (True)
    00:06.864: INFO:    Version Check for (KB2639308) of C:\windows\System32\Ntoskrnl.exe: 6.1.7601.18409 >= 6.1.7601.17727 (True)
    00:06.880: INFO:    Version Check for (KB2533623) of C:\windows\System32\api-ms-win-security-base-l1-1-0.dll: 6.1.7601.18229 >= 6.1.7601.17617 (True)
    00:06.895: INFO:    Version Check for (KB2731771) of C:\windows\System32\conhost.exe: 6.1.7601.18229 >= 6.1.7601.17888 (True)
    00:06.895: INFO:    Checking for correct version of C:\windows\Fonts\segoeui.ttf.
    00:06.895: INFO:    Version Check for (KB2786081) of C:\windows\System32\taskhost.exe: 6.1.7601.18010 >= 6.1.7601.18010 (True)
    00:06.926: INFO:    Version Check for (KB2888049) of C:\windows\System32\drivers\tcpip.sys: 6.1.7601.18438 >= 6.1.7601.18254 (True)
    00:06.973: INFO:    Version Check for (KB2882822) of C:\windows\System32\tdh.dll: 6.1.7601.18247 >= 6.1.7601.18247 (True)
    00:14.664: INFO:    IE Setup Language pack included: C:\windows\TEMP\IE1215C.tmp\IE-Spelling-en.cab
    00:14.695: INFO:    IE Setup Language pack included: C:\windows\TEMP\IE1215C.tmp\IE-Hyphenation-en.cab
    00:14.726: INFO:    Waiting for 0 prerequisite downloads.
    00:18.783: INFO:    The neutral pack was successfully downloaded from the internet. Installation will continue using the downloaded package.
    00:18.814: INFO:    Waiting for 0 language pack downloads.
    00:18.829: INFO:    Language pack downloads completed. (exit code = 0xffffffff (4294967295)).
    00:19.017: INFO:    No reboot logic message NrApiStart(0), lParam=0x004b2708 returned 0x00000000.
    00:20.499: INFO:    No reboot logic message NrApiScan(1), lParam=0x00000001 returned 0x00000000.
    00:20.514: INFO:    No reboot logic message NrApiStartInstall(4), lParam=0x00000001 returned 0x00000014.
    00:20.514: INFO:    Installing with the downloaded package. C:\windows\TEMP\IE1215C.tmp\IE11-neutral.Downloaded.cab
    00:20.561: INFO:    Launched package installation: C:\windows\System32\dism.exe /online /add-package /packagepath:C:\windows\TEMP\IE1215C.tmp\IE11-neutral.Downloaded.cab /quiet /norestart
    00:38.719: INFO:    Process exit code 0x00000002 (2) [The system cannot find the file specified. ]
    00:38.735: ERROR:   Neutral package installation failed (exit code = 0x00000002 (2)).
    00:38.735: INFO:    No reboot logic message NrApiInstallDone(7), lParam=0x00009c59 returned 0x00000000.
    00:38.751: INFO:    No reboot logic message NrApiStartFinish(11), lParam=0x00000000 returned 0x00000000.
    00:38.797: INFO:    No reboot logic message NrApiFinish(12), lParam=0x00000000 returned 0x00000016.
    00:38.797: INFO:    Waiting for Active Setup to complete.
    00:38.797: INFO:    Waiting for Active Setup to complete. ({89820200-ECBD-11cf-8B85-00AA005B4383})
    00:43.805: INFO:    Waiting for Active Setup to complete. ({89820200-ECBD-11cf-8B85-00AA005B4383})
    00:48.860: INFO:    Waiting for Active Setup to complete. ({89820200-ECBD-11cf-8B85-00AA005B4383})
    00:53.867: INFO:    Waiting for Active Setup to complete. ({89820200-ECBD-11cf-8B85-00AA005B4383})
    00:58.875: INFO:    Waiting for Active Setup to complete. ({89820200-ECBD-11cf-8B85-00AA005B4383})
    01:04.101: INFO:    Setup exit code: 0x00009C59 (40025) - The neutral cab failed to install.
    01:04.335: INFO:    Scheduling upload to IE SQM server: http://sqm.microsoft.com/sqm/ie/sqmserver.dll
    01:04.366: INFO:    SQM Upload returned 403
    01:08.141: INFO:    Cleaning up temporary files in: C:\windows\TEMP\IE1215C.tmp
    01:08.406: INFO:    Unable to remove directory C:\windows\TEMP\IE1215C.tmp, marking for deletion on reboot.
    01:08.422: INFO:    Released Internet Explorer Installer Mutex
    

    00:20.561: INFO:    Launched package installation: C:\windows\System32\dism.exe /online /add-package /packagepath:C:\windows\TEMP\IE1215C.tmp\IE11-neutral.Downloaded.cab /quiet /norestart
    00:38.719: INFO:    Process exit code 0x00000002 (2) [The system cannot find the file specified. ]

    Seems to be the issue. The file is there and present and the installer is being run as local admin.

    I have also tried to install KB947821 as seen on another forums with no luck.

    Any ideas?

    I wanted to deploy this silents to my client computers but on this test pc with the Default build its not looking good! =[

    Rob

    Monday, August 11, 2014 8:04 AM

Answers

All replies

  • 00:20.561: INFO:    Launched package installation: C:\windows\System32\dism.exe /online /add-package /packagepath:C:\windows\TEMP\IE1215C.tmp\IE11-neutral.Downloaded.cab /quiet /norestart
    00:38.719: INFO:    Process exit code 0x00000002 (2) [The system cannot find the file specified. ]

    Seems to be the issue. The file is there and present and the installer is being run as local admin.

    do you have some anti-virus or security software which might be locking the file (inspecting the file)?

    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)

    Monday, August 11, 2014 8:11 AM
  • Nope No AV installed.

    I even tried downloading it from the Microsoft catalog, extracting to a folder and running the dism command pointing to that with an elevated cmd. Still no joy.

    • Edited by rob_meh Monday, August 11, 2014 8:14 AM
    Monday, August 11, 2014 8:13 AM
  • Hi,

    We might first take a look at the following troubleshooting steps:

    Troubleshooting a failed installation of Internet Explorer 11

    Please refer to Checklist before you install Internet Explorer 11, and the other installation issues listed in the above KB aticle.

    Best regards


    Michael Shao
    TechNet Community Support

    • Marked as answer by Karen Hu Thursday, August 21, 2014 1:33 AM
    Wednesday, August 13, 2014 7:24 AM