none
autounattend.xml & How to use leftover space? RRS feed

  • Question

  • Hi!

    I created that XML using WSIM. However, if I leave the size field blank (partition: 4), I encounter an error during installation, claiming DiskConfiguration to be incorrect. Is there any way to do this, and how?
    Also, after I fixed this, I got a message telling me drivers for HDD/SSD were missing. Since this doesn't seem to happen with the regular installer disks, how and which drivers I need to integrate?

    Thanks in advance!

    <?xml version="1.0" encoding="utf-8"?><unattend xmlns="urn:schemas-microsoft-com:unattend">    <settings pass="windowsPE">        <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">            <SetupUILanguage>                <UILanguage>de-DE</UILanguage>            </SetupUILanguage>            <InputLocale>de-DE</InputLocale>            <SystemLocale>de-DE</SystemLocale>            <UILanguage>de-DE</UILanguage>            <UserLocale>de-DE</UserLocale>            <UILanguageFallback>en-US</UILanguageFallback>        </component>        <component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">            <DiskConfiguration>                <Disk wcm:action="add">                    <CreatePartitions>                        <CreatePartition wcm:action="add">                            <Order>1</Order>                            <Size>500</Size>                            <Type>Primary</Type>                        </CreatePartition>                        <CreatePartition wcm:action="add">                            <Order>2</Order>                            <Size>100</Size>                            <Type>EFI</Type>                        </CreatePartition>                        <CreatePartition wcm:action="add">                            <Order>3</Order>                            <Size>16</Size>                            <Type>MSR</Type>                        </CreatePartition>                        <CreatePartition wcm:action="add">                            <Extend>true</Extend>                            <Order>4</Order>                            <Type>Primary</Type>                        </CreatePartition>                    </CreatePartitions>                    <ModifyPartitions>                        <ModifyPartition wcm:action="add">                            <Format>NTFS</Format>                            <Label>WinRE</Label>                            <Order>1</Order>                            <PartitionID>1</PartitionID>                            <TypeID> TypeID: DE94BBA4-06D1-4D40-A16A-BFD50179D6AC.</TypeID>                        </ModifyPartition>                        <ModifyPartition wcm:action="add">                            <PartitionID>2</PartitionID>                            <Order>2</Order>                            <Label>System</Label>                            <Format>FAT32</Format>                        </ModifyPartition>                        <ModifyPartition wcm:action="add">                            <Order>3</Order>                            <PartitionID>3</PartitionID>                        </ModifyPartition>                        <ModifyPartition wcm:action="add">                            <Format>NTFS</Format>                            <Label>Windows</Label>                            <Letter>C</Letter>                            <Order>4</Order>                            <PartitionID>4</PartitionID>                        </ModifyPartition>                    </ModifyPartitions>                    <DiskID>0</DiskID>                    <WillWipeDisk>true</WillWipeDisk>                </Disk>                <WillShowUI>OnError</WillShowUI>            </DiskConfiguration>            <ImageInstall>                <OSImage>                    <InstallTo>                        <DiskID>0</DiskID>                        <PartitionID>4</PartitionID>                    </InstallTo>                </OSImage>            </ImageInstall>            <UserData>                <ProductKey>                    <Key></Key>                </ProductKey>                <AcceptEula>true</AcceptEula>                <Organization></Organization>            </UserData>        </component>    </settings>    <settings pass="specialize">        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">            <OEMInformation>                <SupportPhone>05519003650</SupportPhone>                <SupportProvider>GmbH</SupportProvider>                <SupportURL>www..com</SupportURL>            </OEMInformation>            <CopyProfile>true</CopyProfile>        </component>    </settings>    <settings pass="oobeSystem">        <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">            <InputLocale>de-DE</InputLocale>            <SystemLocale>de-DE</SystemLocale>            <UILanguage>de-DE</UILanguage>            <UILanguageFallback>en-US</UILanguageFallback>            <UserLocale>de-DE</UserLocale>        </component>        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">            <OOBE>                <HideEULAPage>true</HideEULAPage>                <HideOEMRegistrationScreen>true</HideOEMRegistrationScreen>                <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>                <HideOnlineAccountScreens>true</HideOnlineAccountScreens>                <ProtectYourPC>3</ProtectYourPC>            </OOBE>            <UserAccounts>                <LocalAccounts>                    <LocalAccount wcm:action="add">                        <Password>                            <Value>==</Value>                            <PlainText>false</PlainText>                        </Password>                        <Description>Technik </Description>                        <DisplayName>Technik</DisplayName>                        <Group>Administrators</Group>                        <Name>Technik</Name>                    </LocalAccount>                </LocalAccounts>                <AdministratorPassword>                    <Value>==</Value>                    <PlainText>false</PlainText>                </AdministratorPassword>            </UserAccounts>        </component>    </settings>    <cpi:offlineImage cpi:source="wim:c:/win10installfilesneu/sources/install.wim#Windows 10 Pro" xmlns:cpi="urn:schemas-microsoft-com:cpi" /></unattend>

    Tuesday, August 13, 2019 8:49 AM

All replies

  • <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
        <settings pass="windowsPE">
            <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <SetupUILanguage>
                    <UILanguage>de-DE</UILanguage>
                </SetupUILanguage>
                <InputLocale>de-DE</InputLocale>
                <SystemLocale>de-DE</SystemLocale>
                <UILanguage>de-DE</UILanguage>
                <UserLocale>de-DE</UserLocale>
                <UILanguageFallback>en-US</UILanguageFallback>
            </component>
            <component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <DiskConfiguration>
                    <Disk wcm:action="add">
                        <CreatePartitions>
                            <CreatePartition wcm:action="add">
                                <Order>1</Order>
                                <Size>500</Size>
                                <Type>Primary</Type>
                            </CreatePartition>
                            <CreatePartition wcm:action="add">
                                <Order>2</Order>
                                <Size>100</Size>
                                <Type>EFI</Type>
                            </CreatePartition>
                            <CreatePartition wcm:action="add">
                                <Order>3</Order>
                                <Size>16</Size>
                                <Type>MSR</Type>
                            </CreatePartition>
                            <CreatePartition wcm:action="add">
                                <Extend>true</Extend>
                                <Order>4</Order>
                                <Type>Primary</Type>
                            </CreatePartition>
                        </CreatePartitions>
                        <ModifyPartitions>
                            <ModifyPartition wcm:action="add">
                                <Format>NTFS</Format>
                                <Label>WinRE</Label>
                                <Order>1</Order>
                                <PartitionID>1</PartitionID>
                                <TypeID> TypeID: DE94BBA4-06D1-4D40-A16A-BFD50179D6AC.</TypeID>
                            </ModifyPartition>
                            <ModifyPartition wcm:action="add">
                                <PartitionID>2</PartitionID>
                                <Order>2</Order>
                                <Label>System</Label>
                                <Format>FAT32</Format>
                            </ModifyPartition>
                            <ModifyPartition wcm:action="add">
                                <Order>3</Order>
                                <PartitionID>3</PartitionID>
                            </ModifyPartition>
                            <ModifyPartition wcm:action="add">
                                <Format>NTFS</Format>
                                <Label>Windows</Label>
                                <Letter>C</Letter>
                                <Order>4</Order>
                                <PartitionID>4</PartitionID>
                            </ModifyPartition>
                        </ModifyPartitions>
                        <DiskID>0</DiskID>
                        <WillWipeDisk>true</WillWipeDisk>
                    </Disk>
                    <WillShowUI>OnError</WillShowUI>
                </DiskConfiguration>
                <ImageInstall>
                    <OSImage>
                        <InstallTo>
                            <DiskID>0</DiskID>
                            <PartitionID>4</PartitionID>
                        </InstallTo>
                    </OSImage>
                </ImageInstall>
                <UserData>
                    <ProductKey>
                        <Key></Key>
                    </ProductKey>
                    <AcceptEula>true</AcceptEula>
                    <Organization></Organization>
                </UserData>
            </component>
        </settings>
        <settings pass="specialize">
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <OEMInformation>
                    <SupportPhone></SupportPhone>
                    <SupportProvider>GmbH</SupportProvider>
                    <SupportURL>www..com</SupportURL>
                </OEMInformation>
                <CopyProfile>true</CopyProfile>
            </component>
        </settings>
        <settings pass="oobeSystem">
            <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <InputLocale>de-DE</InputLocale>
                <SystemLocale>de-DE</SystemLocale>
                <UILanguage>de-DE</UILanguage>
                <UILanguageFallback>en-US</UILanguageFallback>
                <UserLocale>de-DE</UserLocale>
            </component>
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <OOBE>
                    <HideEULAPage>true</HideEULAPage>
                    <HideOEMRegistrationScreen>true</HideOEMRegistrationScreen>
                    <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
                    <HideOnlineAccountScreens>true</HideOnlineAccountScreens>
                    <ProtectYourPC>3</ProtectYourPC>
                </OOBE>
                <UserAccounts>
                    <LocalAccounts>
                        <LocalAccount wcm:action="add">
                            <Password>
                                <Value>==</Value>
                                <PlainText>false</PlainText>
                            </Password>
                            <Description>Technik </Description>
                            <DisplayName>Technik</DisplayName>
                            <Group>Administrators</Group>
                            <Name>Technik</Name>
                        </LocalAccount>
                    </LocalAccounts>
                    <AdministratorPassword>
                        <Value>==</Value>
                        <PlainText>false</PlainText>
                    </AdministratorPassword>
                </UserAccounts>
            </component>
        </settings>
        <cpi:offlineImage cpi:source="wim:c:/win10installfilesneu/sources/install.wim#Windows 10 Pro" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
    </unattend>

    Tuesday, August 13, 2019 8:54 AM
  • I just realized why I couldnt find the proper forums area, I re-created the topic at technet;
    https://social.technet.microsoft.com/Forums/en-US/61153408-dbf3-426b-98a2-ba35e81f21b4/autounattendxml-how-to-use-leftover-space-and-hddssd-drivers?forum=win10itprosetup

    Please delete this topic, thanks!
    Tuesday, August 13, 2019 9:43 AM