locked
WS2012R2 - Storage Device version mismatch 6.0 vs. 4.2 - Linux Guest RRS feed

  • Question

  • I have a WS2012R2 Hyper-V host that has a vendor provided Linux based vhd. When that guest boots I get:
     "A storage device in 'Server' loaded but has a different version from the server. Server version 6.0 Client version 4.2 (Virtual machine ID). The device will work, but this is an unsupported configuration. This means that technical support will not be provided until this problem is resolved. To fix this problem, upgrade the integration services. To upgrade, connect to the virtual machine and select Insert Integration Services Setup Disk from the Action menu."

    I am not sure if there are newer LIS since the newest ones I can find are 3.5 from Jan 2014 and that doesn't match the reported version number. I want to tell the vendor what they need to do to upgrade but I am not sure.

    Also if a VMs integration services are upgraded to latest 2012R2 level will VM still function on 2008R2? The vendor wants a single image and won't upgrade if it breaks older OS I am sure.

    Thanks.

    Thursday, February 26, 2015 4:14 PM

Answers

  • You can ignore this message coming from Hyper-V -- it is spurious.  See this KB article published by Microsoft:  http://support.microsoft.com/kb/2956569/en-us.

    This problem is fixed in the "vNext" version of Hyper-V such that the spurious messages are no longer generated.


    Michael Kelley, Lead Program Manager, Open Source Technology Center

    • Proposed as answer by HoytB Thursday, February 26, 2015 11:04 PM
    • Marked as answer by Brian Hoyt Thursday, February 26, 2015 11:13 PM
    Thursday, February 26, 2015 10:41 PM
    Moderator