locked
Can't switch input language RRS feed

  • Question

  • Hi.

    I recently upgraded to windows 8 (after all updates now it is 8.1).

    Up until yesterday I only used it with one user account.

    Yesterday I added another account, and for some reason instead of having both input languages It only had English.

    I added the second language successfully and the language bar appeared as expected.

    However, after a restart the language bar disappeared, as well as the ability to use "alt-shift" to switch languages.

    When I look at the settings the both languages are there, and the "Use language bar when possible (or something to that effect)" is checked. Also, the language bar is set to be docked (I tried float - didn't do any good) and the shortcut is set for "Alt Shift". But, no language bar is shown and the input language can not be changes.

    A weird thing is that when I look at the shortcuts list I have "switch language --> Alt-Shift", "Hebrew --> (none)". No entry for English.

    Just to make it clear - in order to write this question in English I had to use my other account.

    Thank you very much,

    Asaf.

    Saturday, December 21, 2013 6:29 AM

Answers

  • Hi,

    Please run “ctfmon.exe”, does the language appear again?

    And  follow the instruction below to force the exe to run each time you start windows.

    Open registry, locate to HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run.

    Create a new string value, specify the name "CTFMon".

    Type “ctfmon”=”CTFMON.EXE” in Value data field, OK.
    Restart your computer.

    Regards,

    Yolanda


    Yolanda
    TechNet Community Support

    Monday, December 23, 2013 7:25 AM

All replies

  • I'm also having this problem on my laptop where I also added a second account. The second account is locked to United Kingdom, but I am in Australia, and I'm pretty sure Windows 8 defaults to UK keyboard in Australia, which is wrong, we use US keyboard. When I look at what Languages are installed, I see English (Australia) / US keyboard ONLY. There isn't even a UK keyboard layout installed.

    Edit : I've added English (UK) so that I have a second language. Although it turns out that there is also English (US) which is also invisible to settings 8-/ But that didn't help, as I am completely unable to change the keyboard layout no matter what I do.


    Edit 2 : I may have it working now by simply installing Eng (UK), Eng (US) and Eng (Aus) and then removing UK and then restarting the computer.
    • Edited by Gavin..Williams Saturday, December 21, 2013 8:43 AM further information
    Saturday, December 21, 2013 8:01 AM
  • Hi,

    Please run “ctfmon.exe”, does the language appear again?

    And  follow the instruction below to force the exe to run each time you start windows.

    Open registry, locate to HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run.

    Create a new string value, specify the name "CTFMon".

    Type “ctfmon”=”CTFMON.EXE” in Value data field, OK.
    Restart your computer.

    Regards,

    Yolanda


    Yolanda
    TechNet Community Support

    Monday, December 23, 2013 7:25 AM
  • For those of you that tried everything here is what <g class="gr_ gr_5 gr-alert gr_tiny gr_spell gr_run_anim ContextualSpelling multiReplace" data-gr-id="5" id="5">i</g> did in addition to the above steps

    <g class="gr_ gr_329 gr-alert gr_tiny gr_spell gr_run_anim ContextualSpelling multiReplace" data-gr-id="329" id="329">i</g> tried the <g class="gr_ gr_57 gr-alert gr_spell gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="57" id="57">regedit</g> hack and reboot and my default was german keyboard but only in one user account the other account defaulted to English , <g class="gr_ gr_330 gr-alert gr_tiny gr_spell gr_run_anim ContextualSpelling multiReplace" data-gr-id="330" id="330">i</g> changed and changed back defaults and inputs but only could see german and not the language bar and in addition to <g class="gr_ gr_517 gr-alert gr_gramm gr_run_anim Grammar multiReplace" data-gr-id="517" id="517">make</g> the icon appear in task bar, it would reset and disappear

    In the Windows 10 Settings  under time/language  

    region/language

    add a new language anything , <g class="gr_ gr_511 gr-alert gr_spell gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="511" id="511">english</g> <g class="gr_ gr_568 gr-alert gr_spell gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="568" id="568">canada</g> or <g class="gr_ gr_585 gr-alert gr_spell gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="585" id="585">uk</g> <g class="gr_ gr_650 gr-alert gr_gramm gr_run_anim Punctuation multiReplace" data-gr-id="650" id="650">or ..</g>  

    make it default you will see not the language bar appear and <g class="gr_ gr_716 gr-alert gr_spell gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="716" id="716">english</g> <g class="gr_ gr_725 gr-alert gr_spell gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="725" id="725">uk</g> default

    remove the <g class="gr_ gr_800 gr-alert gr_spell gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="800" id="800">english</g> US then re-add it, then you can reset US to default it works great and then delete the UK

    <g class="gr_ gr_1183 gr-alert gr_tiny gr_spell gr_run_anim ContextualSpelling multiReplace" data-gr-id="1183" id="1183">i</g> hope saves people hours of frustation


    rob

    Monday, August 22, 2016 11:40 PM