none
100% disk usage in IE11 when opening websites RRS feed

  • Question

  • The last couple of days, the disk usage in task manager goes all the way up to 100% when opening websites in IE11.

    This lasts from anything from 10 to 40 seconds, after which disk usage goes down to less than 10%, untill I want to visit another side or scroll through a page.

    CPU and memory usage are not effected.

    I have already reset internet explorer settings to default, but with no result.

    The problem doesn't occur in other browsers like Edge, Firefox or Tor.

    CPU and memory usage are not effected.

    My laptop is an older model Acer with a Core 2 Duo T7300 processor, 3 GB RAM, Geforce 8600m GT 512MB and running Windows 10 Pro 32-bit.

    Other programs and games work fine.

    Monday, January 23, 2017 8:11 PM

Answers

  • Hi,

    Thanks all for trying to help.

    It turned out to be some bad sectors on my hard disk

    I ran chkdsk twice (chkdsk c /f /r /x) and after that I had the drive defragmented, after that the problem was solved.

    • Proposed as answer by Joy-QiaoModerator Thursday, May 11, 2017 3:08 AM
    • Marked as answer by Cor_de_W Thursday, May 11, 2017 10:24 AM
    Wednesday, May 10, 2017 11:14 PM

All replies

  • Hi Cor_de_W,

    “I have already reset internet explorer settings to default, but with no result.”

    Have you ticked the “delete personal data” when we reset the setting?

    Try to check if the symptom exists in private mode.

    Run “iexplore.exe -extoff” to open Internet Explorer 11 without add-ons to troubleshoot whether the issue is caused by a third party add-on.

    We could open “Resource Monitor” (start\search) when we opened Internet Explorer to check which file the Internet Explorer is reading or writing.

    Best regards,
    Joy.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, January 24, 2017 10:07 AM
    Moderator
  • Thank you for your reply Joy-Qiao.

    I tried checking is the problem persisted in private mode. Unfortunately it did.

    I have deleted personal data and restarted my notebook, also without any result.

    Resource Monitor just tells me "system" does the most writing to the disk. Reading is almost 10 times lower.

    Tuesday, January 24, 2017 10:32 PM
  • Hi Cor,

    What are your IE settings for "Enhanced Protected Mode" on the Advanced tab of Internet Options?

    Is your computer a home computer or a company computer on a domain network? If its a home computer do you access your work via a VPN connection?

    Which version of Windows are you using?

    Can you provide the web addresses of your homepage settings or some of the websites that you frequent and have open at the time....

    Regards.


    Rob^_^

    Tuesday, January 24, 2017 10:47 PM
  • Hi Rob,

    My IE setting for "enhanced protection mode" is that it's turned off.

    It is a home computer and I only connect to my work via RDP.

    I'm using Windows 10 Pro, 32 bit.

    The problem happens on every single website, even www.google.nl

    My homepage is www.msn.com btw.

    Tuesday, January 24, 2017 11:02 PM
  • Hi,

    I think the latest updates for Win10 are giving a false value for disk usage on the tasks manager control panel.....it would appear that it is double counting the 'usage' of 32 bit processes.

    Start>Settings>Update & Security>Update History

    you should have an update for

    Cumulative Update for Windows 10 Version 1607 for x86-based Systems (KB3213986)

    installed on or about the 14th of January....

     (I am using x64 Win10, can you post back with the KB number for the January update as it appears on your x86 machine)...

    My guess is that on both x86 and x64 systems the disk usage is being mis-calculated in the Tasks Managers Process tab, that's all. see This PC>Manage to get the physical usage.

    You could try and uninstall that update (click the uninstall updates on the Update history dialog). reboot your compter then see if the reported disk usage calculations appear reasonable, but if I were you on an x86 computer that is non-domain joined, I would ride with it.

    There is this answers post from 2015

    https://answers.microsoft.com/en-us/windows/forum/windows_10-hardware/how-to-fix-100-disk-usage-in-windows-10/7c5c979b-0ed0-4855-b9b8-05b9499533e2

    google and msn use dns prefetch, but I think its just a hiccup in the actual calculation of space used by 32bit and 64bit processes as displayed on the Disk Usage column of the Tasks Manager... I only see it (100% usage) when I have Enhanced Protected Mode enabled on my x64 machine. When I turn EPM off and reboot, the Tasks Manager reported disk usage is back to expected limits.

    If you can post back with the KB number of the January update as it appears on your machine that would be great.

    Regards.


    Rob^_^

    Wednesday, January 25, 2017 3:14 AM
  • You could also try to turn off/on the IE11 using Control Panel.

    1. RUN dialog box >> type in: control >> Hit enter.

    2. Left click programs and features.

    3. Left click Turn Windows features on or off at the left side.

    3. A small window will appear at the center of the screen.

    4. Kindly scroll down and then look for Internet Explorer 11.

    5. Untick the check box and then click OK. (The IE11 will be uninstalled temporarily)

    6. Restart the computer.

    7. Sign in back again to your user account.

    8. Repeat steps 1-7 (but for this time, please put a check mark at the left side of Internet Explorer 11)

    9. Try and check if you will have the same issue.

    Friday, January 27, 2017 7:26 PM
  • Installed updates this year so far:

    Security Update for Adobe Flash Player for Windows 10 Version 1607 (KB3214628) on 01/10

    Cumulative Update for Windows 10 Version 1607 (KB3213986) on 01/10

    Windows Malicious Software Removal Tool for Windows 8, 8.1 and 10 - January 2017 (KB890830) on 01/10

    Update for Windows 10 Version 1607 (KB3211320) on 01/25

    I personally don't think that it's a hiccup in the calculation, since it slows down my notebook considerably. Opening websites in IE takes at least 5 times as much time as opening websites in another browser.

    Friday, January 27, 2017 8:20 PM
  • Hi,

    Tools>Internet Options>Advanced tab, check "Use software rendering instead of GPU rendering",

    uncheck "Enable Enhance Protected Mode" (should already be unchecked or not in options)

    uncheck "Enable 64bit processes for Enhanced Protected Mode" (should already be unchecked or not in options)

    uncheck "Enable third-party browser extensions"

    save your changes to the Advanced tab settings.

    If using a mobile connection, close it. then

    Close all open programs and restart your computer for the full changes to take affect.

    Regards.

    Questions regarding Internet Explorer 8, 9 and 10 and Internet Explorer 11 for the IT Pro Audience. Topics covered are: Installation, Deployment, Configuration, Security, Group Policy, Management questions. If you are a consumer looking for answers or to raise a question, it's highly recommended you head on over to http://answers.microsoft.com/en-us


    Rob^_^

    Saturday, January 28, 2017 7:56 PM
  • Hi,

    Thanks all for trying to help.

    It turned out to be some bad sectors on my hard disk

    I ran chkdsk twice (chkdsk c /f /r /x) and after that I had the drive defragmented, after that the problem was solved.

    • Proposed as answer by Joy-QiaoModerator Thursday, May 11, 2017 3:08 AM
    • Marked as answer by Cor_de_W Thursday, May 11, 2017 10:24 AM
    Wednesday, May 10, 2017 11:14 PM