none
Different Calendars in MS Project RRS feed

  • Question

  • Hello!

    I am working with a very complex project that has many different time schedules in it. The regular work schedule is from 7am to 330pm with a 30 minute lunch break, Monday through Saturday. I made this my basic calendar, because most tasks will be defined in this time frame.

    However, I have other tasks that have their own schedule, not due to vacations or night shifts, but because agriculture requires different schedules for its produce. Having said that, I made plenty different calendars with the "Change Working Time" feature and it worked perfectly until I tried to create a 24 hour calendar for certain activities. It won't let me set a calendar from 12:00am to 12:00am, and therefore, when I link activities, eventually they start bumping into the next day.

    I would be very grateful if you could help me solve this issue.

    Best regards.

    Tuesday, January 9, 2018 4:41 PM

Answers

  • Digna,

    No need to create a custom 24 hour calendar as there is one already available. Look at the Calendars tab of the Organizer. You should see a calendar called "24 hours".

    If for some reason you do not have that built-in 24h calendar, what exactly happens when you try to create it? Note, the built-in calendar looks like this:

    Also, what exactly do you mean that activities "start bumping into the next day"? An example or screen shot would help us better understand.

    Keep in mind that Project only allows one definition for a day and by default that is 8 hours. When using multiple calendars, attempting to use days as the units for task durations becomes very challenging. Are you perhaps running into this issue? If so, I suggest you use hours for the duration units.

    John

    • Marked as answer by Digna Arino Wednesday, January 10, 2018 3:36 PM
    • Unmarked as answer by Digna Arino Wednesday, January 10, 2018 3:36 PM
    • Marked as answer by Digna Arino Wednesday, January 10, 2018 7:12 PM
    Tuesday, January 9, 2018 5:02 PM
  • I have never seen an installation of any version of MSP that does not have the built in 24 hour calendar.

    Are you sure?

    What if you go to file, organiser, calendars tab?

    What is on the left hand side, in the global.mpt file?

    There should be a standard, 24 hours and night shift calendars.

    Try changing your system settings to 24 hour clock. I find it is much better than having to mess about with am and pm.

    • Marked as answer by Digna Arino Wednesday, January 10, 2018 8:52 PM
    Tuesday, January 9, 2018 10:40 PM
  • Digna,

    Something is wrong if you are not able to create your own custom 24 hour calendar. Even though I already have the built-in 24 hour calendar I created another one based on the Standard calendar using the following entries:

    Are you not able to do that? If not, what version of Project are you using? Is it fully updated?

    John


    • Edited by John - Project Tuesday, January 9, 2018 11:01 PM arrg
    • Marked as answer by Digna Arino Wednesday, January 10, 2018 7:12 PM
    Tuesday, January 9, 2018 11:01 PM
  • Digna,

    One possible explanation for not seeing a built-in 24h clock is that it got deleted from your Global file. Try this.

    1. Create a new blank project

    2. Open the Organizer > Calendars tab

    3. Copy all your custom calendars from the Global to the new file.

    4. Save the new file and close Project.

    5. Find your working Global on your C: drive and drag it to the trash

    6. Re-open Project. A new default Global will be created

    7. Open the Organizer > Calendars tab.

    Do you now see a 24h calendar in the left side (Global) selection list? If you do then open the file you saved in step 4 and use the Organizer to copy all your other custom calendars to the Global.

    John

    • Marked as answer by Digna Arino Wednesday, January 10, 2018 7:12 PM
    Wednesday, January 10, 2018 4:52 PM
  • Digna,

    First I'd try a repair of Project. You can do that using the Windows Control Panel > Programs > Programs and features. If that doesn't help, then yes, I'd do an un-install and re-install.

    John

    • Marked as answer by Digna Arino Wednesday, January 10, 2018 7:12 PM
    Wednesday, January 10, 2018 6:40 PM

All replies

  • Digna,

    No need to create a custom 24 hour calendar as there is one already available. Look at the Calendars tab of the Organizer. You should see a calendar called "24 hours".

    If for some reason you do not have that built-in 24h calendar, what exactly happens when you try to create it? Note, the built-in calendar looks like this:

    Also, what exactly do you mean that activities "start bumping into the next day"? An example or screen shot would help us better understand.

    Keep in mind that Project only allows one definition for a day and by default that is 8 hours. When using multiple calendars, attempting to use days as the units for task durations becomes very challenging. Are you perhaps running into this issue? If so, I suggest you use hours for the duration units.

    John

    • Marked as answer by Digna Arino Wednesday, January 10, 2018 3:36 PM
    • Unmarked as answer by Digna Arino Wednesday, January 10, 2018 3:36 PM
    • Marked as answer by Digna Arino Wednesday, January 10, 2018 7:12 PM
    Tuesday, January 9, 2018 5:02 PM
  • Hi John,

    Thank you for your answer!

    What I have managed is to do 12:00am to 12:00pm and then 12:01pm to 11:59 pm, but the missing minutes eventually cause the activities to shift forward.

    Also, I do not have a built in 24 hour calendar. I manage these activities with "hours" instead of "days" because there are several of them which all need to be completed in different time periods or calendars, depending on what they do.

    As much as I try to write 12:00am to 12:00am, it will automatically change the hours I have written before.

    I have tried to insert pictures but the page won't allow me until they can verify my account.

    Digna

    Tuesday, January 9, 2018 8:12 PM
  • I have never seen an installation of any version of MSP that does not have the built in 24 hour calendar.

    Are you sure?

    What if you go to file, organiser, calendars tab?

    What is on the left hand side, in the global.mpt file?

    There should be a standard, 24 hours and night shift calendars.

    Try changing your system settings to 24 hour clock. I find it is much better than having to mess about with am and pm.

    • Marked as answer by Digna Arino Wednesday, January 10, 2018 8:52 PM
    Tuesday, January 9, 2018 10:40 PM
  • Digna,

    Something is wrong if you are not able to create your own custom 24 hour calendar. Even though I already have the built-in 24 hour calendar I created another one based on the Standard calendar using the following entries:

    Are you not able to do that? If not, what version of Project are you using? Is it fully updated?

    John


    • Edited by John - Project Tuesday, January 9, 2018 11:01 PM arrg
    • Marked as answer by Digna Arino Wednesday, January 10, 2018 7:12 PM
    Tuesday, January 9, 2018 11:01 PM
  • Hi Trevor.

    I tried file, organiser, calendars tab and the only available calendar (aside from those which I created) is the Standard calendar.

    I will try changing the system settings to 24 hour clock. Thank you!

    Wednesday, January 10, 2018 3:22 PM
  • Hi John

    Whenever I try to do the exact same thing you did, it won't let me write 12:00am on the from column, it changes it to pm automatically. I don't know what to do.

    I do have the last version of Project 2016, fully updated.

    Digna

    Wednesday, January 10, 2018 3:26 PM
  • I have also tried opening a new Project, to see if it was maybe something I changed and couldn't remember it, but the new document doesn't have the built in 24 hour calendar and won't let me create a new one either.
    Wednesday, January 10, 2018 3:34 PM
  • Digna,

    One possible explanation for not seeing a built-in 24h clock is that it got deleted from your Global file. Try this.

    1. Create a new blank project

    2. Open the Organizer > Calendars tab

    3. Copy all your custom calendars from the Global to the new file.

    4. Save the new file and close Project.

    5. Find your working Global on your C: drive and drag it to the trash

    6. Re-open Project. A new default Global will be created

    7. Open the Organizer > Calendars tab.

    Do you now see a 24h calendar in the left side (Global) selection list? If you do then open the file you saved in step 4 and use the Organizer to copy all your other custom calendars to the Global.

    John

    • Marked as answer by Digna Arino Wednesday, January 10, 2018 7:12 PM
    Wednesday, January 10, 2018 4:52 PM
  • John,

    I think something is wrong with my Project. I tried opening a new blank project, but when I opened the calendars tab on the organizer, it wouldn't let me mover or copy any calendars.

    I'm considering uninstalling and reinstalling Project but I'm not sure if that would be an issue. Do you have any suggestions?

    Digna

    Wednesday, January 10, 2018 5:54 PM
  • Digna,

    First I'd try a repair of Project. You can do that using the Windows Control Panel > Programs > Programs and features. If that doesn't help, then yes, I'd do an un-install and re-install.

    John

    • Marked as answer by Digna Arino Wednesday, January 10, 2018 7:12 PM
    Wednesday, January 10, 2018 6:40 PM
  • Thank you very much, I will!
    Wednesday, January 10, 2018 7:12 PM
  • Digna,

    You're welcome, and thanks for the feedback.

    John

    Wednesday, January 10, 2018 7:41 PM
  • Hi John!

    I finally managed to create a 24 hour calendar, by taking Trevor's advice of changing the settings to a 24 hour clock instead of worrying about am/pm. It worked with 00:00 to 00:00.

    Thank you so much for your input!

    Wednesday, January 10, 2018 8:53 PM
  • Hi Trevor!

    Your suggestion for changing my system settings to 24 hour clock was what finally allowed me to set the calendar from 00:00 to 00:00.

    THANK YOU VERY MUCH! I had been struggling with this for 3 days already and was going crazy!

    Best regards!

    Digna

    Wednesday, January 10, 2018 8:55 PM