locked
Currently working in the UAE, edge keeps defualting to arabic content for most sites RRS feed

  • Question

  • Every time a click a link from an news articles or others, the content always return Arabic

    If I click to install a suggested android apps, my play store interface defaults to Arabic, this does not happen in Chrome or Mozilla

    I have tried setting my default region to United Kingdom and my language setting is English

    How do I prevent Edge from defaulting to Arabic content?

    Saturday, April 15, 2017 8:26 AM

All replies

  • Hi,

    use InPrivate browsing so that you don't reuse any cookies. Menu charm>InPrivate browsing.

    also Tools>Internet Options>General tab>Languages... make en-gb the default language for IE on win7/8. winkey+[space] on windows 10.

    Regards.

    Questions regarding Internet Explorer 8, 9 and 10 and Internet Explorer 11 for the IT Pro Audience. Topics covered are: Installation, Deployment, Configuration, Security, Group Policy, Management questions. If you are a consumer looking for answers or to raise a question, it's highly recommended you head on over to http://answers.microsoft.com/en-us


    Rob^_^

    • Proposed as answer by Tony_Tao Monday, April 17, 2017 2:33 AM
    Saturday, April 15, 2017 7:09 PM