locked
QuarkXPress 8.5 RRS feed

  • Question

  • Hello all,

    I was just wondering if anyone has successfully packaged QuarkXPress 8.5? I have been trying for the past week or so with no success. The problem I have is that the application works fine when running it as a domain or local admin on the app v server, but when running the application as a normal domain user there is an error that pops up stating that it cannot find files that are needed to start.I have listed below the steps I have take to troubleshoot so far. Any help is appreciated.

    Error when launching app: File not found [-43]

    Step 1: Contacted vendor tech support who was less than helpful.

    Step 2: Consulted Google on the issue, but the app v scenario seems to be a rare thing.

    Step 3: Decided that we are looking at a permissions type error, so I added domain users to the local admin group on the App V server. When domain users were in the local admin group the app launched fine.

    Step 4: Opened the App with domain users removed from the local admin group while running process monitor. The Issue here is that there are too many files in the registry as well as the local machine to tell what specifically is causing the application not to launch.

    Step 5: Gave domain users full access to the local machine registry folder as well as full access to the local C: and cache drive on the application server with no luck.

    The only thing that seems to solve the issue is giving the local admin rights to domain users which is not the ideal solution at all.

    Thanks in advance for any help.


    Mike P.
    Monday, October 10, 2011 10:41 PM

Answers

  • Use Process Monitor to look for ACCESS DENIED entries when running QuarkXpress. Confirm that the same behaviour does or doesn't occur outside of App-V (i.e. when QuarkXpress is natively installed).

    See this forum post that discusses QuarkXpress as administrator rights: http://forums.quark.com/p/25586/103087.aspx and update to 8.5.1 as well: http://www.quark.com/support/downloads/Details.aspx?fid=199



    This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.
    • Marked as answer by MWPxerom Tuesday, October 11, 2011 4:34 PM
    Tuesday, October 11, 2011 6:50 AM
    Moderator

All replies

  • Hello,

    Are you setting enforce security descriptors to off? What client are you distributing to?

    Have you used any type of investigation tool to determine where the desired access is lacking?


    /Znack
    Tuesday, October 11, 2011 5:23 AM
  • Use Process Monitor to look for ACCESS DENIED entries when running QuarkXpress. Confirm that the same behaviour does or doesn't occur outside of App-V (i.e. when QuarkXpress is natively installed).

    See this forum post that discusses QuarkXpress as administrator rights: http://forums.quark.com/p/25586/103087.aspx and update to 8.5.1 as well: http://www.quark.com/support/downloads/Details.aspx?fid=199



    This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.
    • Marked as answer by MWPxerom Tuesday, October 11, 2011 4:34 PM
    Tuesday, October 11, 2011 6:50 AM
    Moderator
  • As Znack said first. Are you setting Enforce Security Descriptors?

     

    Also you if it's not a permission issue as such and just an issue in that it only allows someone who is part of those admin groups to use the app you could try applying a runAsAdmin shim.

    Tuesday, October 11, 2011 8:52 AM
  • Aaron,

    I happened to try the update 8.5.1 today and that was the answer. With 8.5.1 Quark allows you to redirect the preferences file to a network share instead of the default location local to the machine Quark was originally installed on. There is a settings.xml file that allows you to make this change. I just simply pointed the preferences file to the user drive and everything is launching just fine.

     

    I have included the text from the settings file below to show what I did. The line starting with <Win> ususally looks like the following:

    <Win></Win>

    Just add the path you wish to redirect the preferences folder to as I have done below and you are finished.

     

    <?xml version="1.0" encoding="UTF-8" standalone="no"?>
    <Configuration Version='0800'>
    <PreferencesLocation>
    <Win>U:\%username%\My Documents\Quark Pref</Win>
    <Mac></Mac>
    </PreferencesLocation>
    </Configuration>


    Mike P.
    Tuesday, October 11, 2011 4:44 PM