none
Windows 10 VM is locking up after entering credentials on Welcome screen. RRS feed

  • Question

  • Background I've just come through several layers of MS Support (from Windows 10 Get Help, to Windows Advocate and they want me to pay $500 for a business support plan even though it is consumer use and isn't being used in a business). So now I'm here.

    I have a windows 10 host running Hyper-V. It is hosting a window 10 guest VM.
    I can connect to the VM using the Hyper-V manager's "Connect..."
    However since two-three weeks ago I'm now unable to access the machine using Remote Desktop.

    As soon as a I enter my credentials and press enter, the VM locks up entirely. I see the Welcome circle of dots for a bit then they stop moving, or I'll see a blank/black screen.

    Hyper-V Manager Shows the CPU usage pegged at 16% and at this point I can't use Hyper-V manager to connect. I can only Switch Off the VM.
    To trouble shoot I've tried: restarting host and the "Reset my PC" option on the guest VM and the problem remains. I did a brief event log search on the guest, but didn't find anything useful.

    Note: more than three weeks ago I was able to use remote desktop to access the guest VM.

    Any ideas? Windows update did update the VM (1903) and I don't know if that is coincidental. Note host is 1809 (I'll try updating it to 1903 next).

    Now I installed 1903 on the host and it's been running for a while. And I see Hyper-V says it is using 8% Cpu .So I tried accessing using Hyper-V Connect and after entering the credentials on the Welcome screen it appears to lockup using that method too now (or maybe it always did...).

    Power off and on, try connect again and it works, but for how long. I'm confused and unsure how to resolve. Complete fresh install of Windows 10 Guest and/or Host?




    • Edited by Camios Saturday, September 21, 2019 3:07 AM
    Friday, September 20, 2019 2:11 AM

All replies

  • Hi ,

    Did you try to force the use of the XDDM driver to do a test? Please check if the following link is helpful:

    Windows 10 V1903: RDP (dwm.exe) causes high CPU load, freezes VMs

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    If the above step still doesn't work, there might be some early adopter issues at this time with Windows 10 1903, if possible, I would recommend you wait a bit until Windows 10 1903 matures with future cumulative updates.

    Best Regards,

    Candy


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   



    Monday, September 23, 2019 2:34 AM
  • Hi ,

    Just want to confirm the current situations.

    Please feel free to let us know if you need further assistance.                   

    Best Regards,

    Candy



    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   

    Wednesday, September 25, 2019 6:03 AM
  • Hi ,

    Did you have any updates on this issue?

    Best Regards,

    Candy


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   

    Friday, September 27, 2019 1:48 AM
  • I am having this same issue also.  The host is 1903 as are the guest machines. Until I resolve this Hyper-V is not usable because I lose all of my work when I have to power off the guest machine because of lockup.

    I will try the the XDDM driver fix that you suggest.  Also, I have moved the hard drive file for the guest machine to a different host which is Server 2016 so that seems to prove it is the host Windows 10 1903 box.

    Please keep us updated if there is a fix.

    I have a windows 10 host running Hyper-V. It is hosting a window 10 guest VM.
    I can connect to the VM using the Hyper-V manager's "Connect..."
    However since two-three weeks ago I'm now unable to access the machine using Remote Desktop.

    As soon as a I enter my credentials and press enter, the VM locks up entirely. I see the Welcome circle of dots for a bit then they stop moving, or I'll see a blank/black screen.

    Hyper-V Manager Shows the CPU usage pegged at 16% and at this point I can't use Hyper-V manager to connect. I can only Switch Off the VM.
    To trouble shoot I've tried: restarting host and the "Reset my PC" option on the guest VM and the problem remains. I did a brief event log search on the guest, but didn't find anything useful.


    Thursday, October 17, 2019 3:15 PM
  • Hi ,

    Did you try to force the use of the XDDM driver to do a test? Please check if the following link is helpful:

    Windows 10 V1903: RDP (dwm.exe) causes high CPU load, freezes VMs

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    If the above step still doesn't work, there might be some early adopter issues at this time with Windows 10 1903, if possible, I would recommend you wait a bit until Windows 10 1903 matures with future cumulative updates.

    Best Regards,

    Candy


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   



    I am still having the issue on 1903.  Have gone back to 1803 with forced-delay of feature upgrade until there is an official fix because I can't be without Hyper-V.  Thanks for the help and I will check back here often.

    Tuesday, October 22, 2019 11:32 AM
  • An update:

    I reverted my VM by using an old copy of the hdd (vhdx) files. The problem stopped happening. However, after a few weeks the problem started again just this week!  

    After some experimentation today I found if I use a saved password when logging in via remote desktop to the VM, then the VM (or Hyper-V manager) locks-up. @Paratus suggests it is due to using Windows 10 as the hypervisor.

    Another possible workaround: If I change the RD setting to always ask for credentials, then I can login to the VM successfully.

    @Paratus, I wonder if you could change the Remote Desktop connection settings to always ask for credentials and see if my workaround works for you too?

    Note: in my OP I'm not sure exactly how I was logging in to the VM. It sounds like I had to enter credentials on the welcome screen.
    • Edited by Camios Sunday, November 3, 2019 12:41 AM Clarification
    Saturday, November 2, 2019 11:33 PM
  • I have reverted back to 1803 for a workaround for this problem.  All due respect Camios but there is no problem at all with 1803 and the Hyper-V machine locking up, no matter what password options I choose.  I will probably just wait until the next version of Windows 10 comes out and just jump to that, skipping 1903.  Thanks for replying.
    Sunday, November 3, 2019 12:27 AM
  • Disabling "Use WDDM graphics display driver for Remote Desktop Connections" group policy setting appears to be a successful workaround when you have saved credentials for the rdp file.

    Why does the combination of WDDM driver and a saved password in the rdp file cause my problem?

    Sunday, November 3, 2019 1:19 AM
  • @Paratus, three workarounds:

    1. If you want to use Remote Desktop and save the password:Disabling "Use WDDM graphics display driver for Remote Desktop Connections" group policy setting appears to be a successful workaround when you have saved credentials for the rdp file.

    2. If you want to use Remote Desktop but don't want to change group policySave an rdp file for the RDS and tick the checkbox to always ask for credentials.

    3. Use the Hyper-V manager's Connect

    Sunday, November 3, 2019 1:21 AM
  • I don't use Remote Desktop to access the VMs--I access them directly with the Hyper-V console.  They lock up when I enter credentials at the gina to unlock the machine which is why I have reverted to 1803. Remote Desktop doesn't really come into play.  I tried the WDDM GPO workaround but it didn't fix it for me.
    Sunday, November 3, 2019 11:07 AM