none
IE10 - Technical Issues Group Policy RRS feed

All replies

  • reposted from

    http://community.spiceworks.com/topic/342202-ie-10-group-policy-help-needed-i-think-i-ve-found-a-bug

    We have a Windows 2012 DC and I am using Group Policy Management to configure Internet settings for IE 7, 8, 9 and 10 users.

    The group policy settings for IE 7, 8, 9 work fine.  I can configure the Proxy Server settings and the Advanced Settings with no problems.  However, I think I have found a bug when trying to configure the Proxy Server settings for IE10.  Here is what I do.

    1) Go into Group Policy Management

    2) Select the Group Policy Object that I want to add the IE10 settings to.

    3) Edit the Group Policy Object

    4) When Group Policy Management Editor opens, I go to User Configuration / Preferences / Control Panel Settings / Internet Settings.  Here I see the "Internet Explorer 7" and the "Internet Explorer 8 and 9" settings that I have already created.  I right click in the right hand pane, select "New", then select "Internet Explorer 10". 

    5) With the "New Internet Explorer 10 Properties" window open, I go to the "Connections" tab, select "LAN Settings".

    6) Check to enable the "Use a proxy server...." option

    7) Enter the ip address of my proxy server and the port address, in this case I enter "192.168.160.22" and "8080"

    8) Press "F5" so the settings get applied to all users as indicated by the solid green line.

    9) Check to enable the "Bypass proxy server...." option

    10) Click "Ok", then click "Apply", then click "Ok" to save the changes.  I now see the Internet Explorer 10 listed along with the IE 7 and IE8and9.

    11) Double-click the Internet 10 option to go back into its "Properties".

    12) Select the "Connections" tab, then "LAN Settings".  I see the proxy ip address and port number that I entered in step 7 above.

    13) Now the wonderful part where I think there is a bug.  Click "Advanced". This opens the "Proxy Settings" window.

    14) Move the window over so you can see the "Local Area Network (LAN) Settings" window.

    15) Click the "OK" button in the "Proxy Settings" window and watch the proxy ip and port numbers in the LAN Settings window disappear.

    16) So you think to yourself, ok they must still be there.  If you click "Cancel" and go back into the "LAN Settings" you will see the proxy server ip address and port number still there. 

    But if you click "OK", and then "Apply" your screwed.  The proxy server ip address and port numbers never reappear when you go back into "LAN Settings".   To get the proxy server ip address and port numbers to reappear, you have to recreate the Internet Explorer 10 settings, but going into the "Advanced" settings will burn you every time.

    Doing the above when setting the IE 7 and IE 8and9 settings works fine.

    See the attached image showing what I see.

    Anyone else experience this?  Have you found a way around it?

    Thank you for your time and help.

    Thank you.


    Rob^_^

    Wednesday, July 31, 2013 8:11 PM
  • Hi,

    Thank you for your feedback. Internet Explorer team have confirmed the issue you reported in your pervious post. However, based on the limited impact of this issue, this bug is not able to be addressed during this release.
    Meanwhile, I will forward this issue to the development team as well.

    Thank you for your support and appreciate your patience.

    Thanks!

    Thursday, August 1, 2013 12:24 PM
    Moderator
  • Hi,

    This is a bit of a show stopper for us, as we are not able to administer IE10 properly within our 3 forests.

    We spend upwards of £100,000 per year on an Enterprise agreement with Microsoft and we feel that this should be prioritized to reflect both the urgency and also the commitment to us poor IT Staff / End users!

    Is there a way that we can escalate this to get a hotfix?

    Mike


    Peace

    Thursday, August 1, 2013 1:06 PM
  • Hi,

    We will escalate this issue to the Microsoft Technical Support team.
    Thanks for your support and appreciate your patience.

    Thanks again!

    Monday, August 5, 2013 1:03 AM
  • Work arround:

    1. On the tab Connections, click LAN settings.
    2. Check to enable the Use a proxy server... option.
    3. Click Advanced...
    4. Fill in Exceptions and click OK.
    5. Press F5.
    6. Fill in Address: and Port: en press F5.
    7. Check Bypass proxy... and click OK.

    When you try to change the exceptions, you have to remake a new Internet Explorer 10 item under Control Panel Settings/Internet Settings.

    Greetings


    May the source be with you!
    Please Mark As Answer if my post solves your problem or Vote As Helpful if a post has been helpful for you.


    Friday, December 6, 2013 8:39 AM
  • This helped, would love a real fix from MS sometime in the future.
    Wednesday, February 5, 2014 8:02 PM
  • Has Microsoft fixed this?

    My production OU must have internet blocked. I've always done this with a fake proxy 0.0.0.0 80 and exceptions (in the old IE maintenance) to allow our transportors website. I also need to set the home page, and to always open to homepage.

    I've tried this in every order possible, reading everything I can find. I've tried as registry settings or with the workaround here, tried making two different GPP etc.  E

    When I view the registry everything looks fine :ProxyEnable, ProxyOverride and ProxyServer, but nothing gets blocked.

    If I delete the ProxyOveride key with my exceptions internet gets blocked. But I need those exceptions to work as well!

    This works fine on my XP machines but not on my Windows 7 that I have started replacing them with. But if this doesn't work, I will hang on to my XP machines with my life until this is fixed.


    • Edited by KCSPI76 Monday, March 23, 2015 9:12 AM
    Monday, March 23, 2015 9:06 AM
  • Figured this out, in case this helps anyone else, I had problems in the string of exceptions for the "ProxyOverride" exceptions.

    I restarted from 0 putting one in at a time until I broke it.  Had extra "./" before and "/*" after a couple of addresses, plus one that was simply an old domain name no longer in service.  Once I cleaned all this up it worked as expected using

    the method given by AKnight          here:    

    http://community.spiceworks.com/topic/342202-ie-10-group-policy-help-needed-i-think-i-ve-found-a-bug

    I prefered this method because you can go back and edit the exceptions instead of starting over each time.

    Also, this helped me out for debugging my exceptions:

    https://technet.microsoft.com/fr-fr/library/dd361953.aspx

    Monday, March 23, 2015 10:18 AM