none
If I setup folder restrictions, I am unable to save data through the data acquisition software

    Question

  • Hi everyone, my software(data acquisition software) works well and saves data in the folder with full control permissions, but when I try to save my data in the restricted folder(only delete permission is denied) it displays an error access denied.

    Is there any workaround to disable the delete option and keeping the normal functioning of software intact, as my intention is to allow the users to generate the data and restricting them from deleting the generated data

    Thanks in advance

    Saturday, August 8, 2015 8:01 AM

Answers

  • Hi,

    Do you means enable "Write" or just "Delete" as Deny permission?
    Which data acquisition software are you used?

    Here's my test results, for your reference:
    1. If I deny Write permission, I cannot save paint to this folder with no permission error.
    2. If I deny Delete permission, I can save paint to this folder however get an warning "don't permission to modify this files".

    Also, I find some article about How NTFS permission works, please refer to:
    https://technet.microsoft.com/zh-cn/magazine/2006.01.howitworksntfs(en-us).aspx
    https://msdn.microsoft.com/en-us/library/bb727008.aspx

    For your question, it might be caused by application compatibility, I recommend contact application provider to get more details about this issue.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Allen Wang
    TechNet Community Support

    Tuesday, September 8, 2015 9:16 AM
  • As Allen Wang says, Write and Delete permissions differ. You can disable Delete permission, but still save files to a folder. However, if you're seeing "Access Denied" error, it's very likely with the software. The data acquisition software may try to delete some files (even temporary files) in the folder and you're seeing error message for that operation.

    I'd suggest you to set the user of the program to an administrator account, allow full permission to the user for that particular folder and deny delete permission to all other users. By this way, the program will be running as a different user, which has full permission over the folder and so no error message will be displayed. Also, no other users will be able to delete the files created in the folder. To achieve this, go to the path where the main executable of the program is present, open the file properties, go to Compatibility tab, click on Change settings for all users, set the option Run this program as an administrator, click Apply and Ok, then Ok.


    Balaji Kundalam

    Wednesday, September 9, 2015 4:42 AM

All replies

  • Hi,

    Do you means enable "Write" or just "Delete" as Deny permission?
    Which data acquisition software are you used?

    Here's my test results, for your reference:
    1. If I deny Write permission, I cannot save paint to this folder with no permission error.
    2. If I deny Delete permission, I can save paint to this folder however get an warning "don't permission to modify this files".

    Also, I find some article about How NTFS permission works, please refer to:
    https://technet.microsoft.com/zh-cn/magazine/2006.01.howitworksntfs(en-us).aspx
    https://msdn.microsoft.com/en-us/library/bb727008.aspx

    For your question, it might be caused by application compatibility, I recommend contact application provider to get more details about this issue.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Allen Wang
    TechNet Community Support

    Tuesday, September 8, 2015 9:16 AM
  • As Allen Wang says, Write and Delete permissions differ. You can disable Delete permission, but still save files to a folder. However, if you're seeing "Access Denied" error, it's very likely with the software. The data acquisition software may try to delete some files (even temporary files) in the folder and you're seeing error message for that operation.

    I'd suggest you to set the user of the program to an administrator account, allow full permission to the user for that particular folder and deny delete permission to all other users. By this way, the program will be running as a different user, which has full permission over the folder and so no error message will be displayed. Also, no other users will be able to delete the files created in the folder. To achieve this, go to the path where the main executable of the program is present, open the file properties, go to Compatibility tab, click on Change settings for all users, set the option Run this program as an administrator, click Apply and Ok, then Ok.


    Balaji Kundalam

    Wednesday, September 9, 2015 4:42 AM