locked
adding sound device in hyper-v RRS feed

  • Question

  • I setup Win 7 in a windows 2008 r2 x64 with hyper-v but I can't add any sound device in win7 VM, Would somebody help me?
    Monday, September 14, 2009 5:18 AM

Answers

All replies

  • I have managed to duplicate your problem using VIrtual Machine Connection and Windows 7 Professional x64 hosted by Windows Server 2008 R2 Hyper-V.

    See Mike's post and my next post for the workaround.

    Monday, September 14, 2009 11:04 AM
  • I installed Windows 7 Ultimate x64 in Windows 2008 R2 DataCenter x64 with Hyper-V. I was tried to install Integration Service but got message that Integration Service was installed and exit; won't let me install it. I have checked that Device Manager doesn't have any sound device installed.
    • Proposed as answer by Brynhildr Arai Wednesday, November 28, 2018 10:20 AM
    • Unproposed as answer by Brynhildr Arai Wednesday, November 28, 2018 10:20 AM
    Monday, September 14, 2009 3:21 PM
  • Hyper-V doesn't provide a virtual audio device. If you want audio, you need to use RDP to get the virtual audio support working.
    This posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, September 14, 2009 6:08 PM
  • Now that we've established that you were using the Virtual Machine Connection, Windows 7 comes with the Integration Services installed. They shouldn't install. They don't include a sound card. Everything is normal for your circumstances.

    Have you tried Mike's suggestion of using RDP? First you'll need to use Virtual Machine Connection to enable Remote Desktop Connection in your Windows 7 vm.

    Next, you'll need to click the Options button on Remote Desktop Connection to get to all of its tabs. The default for Remote Desktop Connection is (look on the Local Resources tab) to bring remote computer sound to your local computer. But just to be certain, please confirm that you have the default setting before making the connection. Most people prefer the video experience using RDP because you aren't limited to the resolutions offered by Virtual Machine Connection. Also on the Local Resources tab, you can enable sharing of your local disk drives to your virtual machine by checking Disk drives under Local devices. On the Experience tab, you should choose an appropriate connection speed and set your user experience level as you prefer.

    I fully documented all of the steps with screen captures in my blog: http://sqlblog.com/blogs/john_paul_cook/archive/2009/09/14/enabling-sound-on-hyper-v.aspx

    Monday, September 14, 2009 7:52 PM
  • ·         Hi,

     

    I want to see if the information provided was helpful. Your feedback is very useful for the further research. Please feel free to let me know if you have addition questions.

     

     

    Best regards,

    Vincent Hu

    Thursday, September 17, 2009 8:46 AM
  • Hi,

    I have Windows 2008 R2 x64 RTM running on a Dell Precision M6400 with a quad core processor and 8GB of RAM.

    I have Hyper-V running and a VM which runs Windows 7 RTM x64.

    I have a virtual playback device within Windows 7 but no virtual recording device.

    I have followed John's instructions but still no Recording device within Windows 7.

    Any ideas ?

    Thanks

    Nigel
    Monday, September 28, 2009 12:40 PM
  • Sound - input or output device? I haven't tested an audio input device. I have had success enabling audio output via RDP.
    Wednesday, September 30, 2009 2:01 AM
  • Hi John

    I have an audio output device but no audio input device.


    It says "no audio devices are installed" on the "recording" tab after right clicking on the speaker in the tray and selecting recording devices.

    The bare metal o/s (w2k8r2)  has both audio input and output devices installed and working and has the audio service, Windows Audio Service and Windows audio endpoint builder services running.

    The Windows 7 VM has the Windowa Audio Service and Windows audio endpoint builder services running.


    Regards

    Nigel

    Wednesday, September 30, 2009 2:42 PM
  • I found the registry change in this article fixed the issue :-


    http://www.theexperienceblog.com/2009/11/05/manual-steps-required-for-audio-recording-via-rdp-7-0/


    Regards

    Nigel

    • Proposed as answer by Nigel Price Friday, November 27, 2009 9:03 AM
    • Marked as answer by John Paul Cook Friday, November 27, 2009 8:49 PM
    Friday, November 27, 2009 9:03 AM
  • Sorry to dig up a old thread, but this option will not work for me. For a few reason the Hyper-V VM is a closed network and the main OS is not. That is the way both sides wants it, but of course this means that RDP is not able to solve the display or sound settings.  Has Hyper-V improved since 2009 and work more like Parallels for Macs?

    Is there another work around? How about USB flash drives or a shared drive again like Parallels?

    Thanks for any help you can be on this subject.

    Rick

    Monday, April 17, 2017 12:51 PM