none
Executing a CLP program in AS400 RRS feed

  • Question

  • Hi,

    I'm trying to consume a RPG program from HIS. Initially, there was a direct call to the RPG and it worked fine. Now, it has changed and the entry program is a CLP program that loads son libraries and then execute the RPG program. I´ve changed the client definition file with the new entry program ( parameters are the same ) but I keep receiving the following error from server:

    return code = 1281.  The error description is: "An error occurred when calling the program to execute."

    Can I execute CLP programs from HIS?

    Best Regards


    Luis Diego Rojas. http://icomparable.blogspot.com


    MCP, MCTS Biztalk Server, MCTS WCF

    Saturday, November 30, 2013 3:24 PM

Answers

  • Yes, TI can be used to call CL programs on IBM AS/400s. The error that you are seeing is coming back from the AS/400. I found a previous report of this same error message and a network trace of the transaction call showed that the AS/400 was returning a message indicating that the number of parameters being passed didn't match what the program expected.

    You may want to get a network trace to see if you can pull out the error message that the AS/400 is passing back to help determine the cause of the problem. Another option is to work with the AS/400 Admin to see if they can pull any messages out of the system or job logs to see if that will help determine the cause of the problem.

    Thanks...


    Stephen Jackson - MSFT

    Monday, December 2, 2013 4:48 PM