locked
OCS Incoming Call Normalization Rules RRS feed

  • Question

  • I have outgoing communicator calls working through the mediation server and an AudioCodes M1000 gateway, however, I'm not able to get incoming calls to go through the Mediation server and I believe this is because of the number normalization rules. We also have a PBX that handles incoming calls, but I configured the AudioCodes gateway to route those numbers to that server IP and Mediation server calls configured to use a different range of numbers that are available to us (but not working yet).

    I believe my normalizations rules are messed up. I'm trying to get incoming communicator calls to work but this string doesn't seem to work and I can't figure out where to make the adjustments (FEserver, Exchange, or AD). I have this expression ^(6504256\d{3})$ for the FE server, Voice Properties>Location Profiles>Normalization rules>Edit Phone Number Normalization Rule>Translation pattern regular expression. The Phone pattern regular expression is ^(\d{10})$.

    I have extra phone numbers available to me that I can assign DIDs to Communicator incoming calls that start with 6504256***, but our PBX DIDs are 6502867***. How do I go about setting up the incoming Communicator DIDs? Ideally I'd like both devices to ring on incoming calls and whichever picks up cancels the other device, but I can't find good information about how to do that anywhere. Thanks.

    Monday, July 12, 2010 5:36 PM

Answers

  • I think your best friend in this case would be the Enterprise Voice Route Helper

     

    It installs with the resource kit tools, its under Programs->Office Communications Server 2007 R2->Resource Kit

    That tool will allow you a simpler method of creating normalization rules.

     

    For what you want though...

     

    Your pattern would be: ^(\d{10})$

    Translation: +1$1

    What this does, is takes any 10 digit number dialed in communicator, for example 6502225555

    Then it adds a +1

     

    So the result would be +16502225555

    Now, communicator will recognize that as a true E.164 number, and display it as:

    +1 (650) 222-5555

    Communicator will only neatly format numbers that are in proper E.164, and that is a full 11 digit number starting with a +

     

     

     


    Randy Wintle | MCTS: UC Voice Specialization | Winxnet Inc
    • Marked as answer by MarcGel Thursday, July 22, 2010 9:22 PM
    Thursday, July 22, 2010 7:02 PM
  • Change the Tel Uri for the user to read:

     

    tel:+1650222555 

     

    I think you're missing the +1 in the tel uri

    Above you Said "User tel uri look like this and are correct tel:+6504256007"

     



    Randy Wintle | MCTS: UC Voice Specialization | Winxnet Inc
    • Marked as answer by MarcGel Thursday, July 22, 2010 9:23 PM
    Thursday, July 22, 2010 8:16 PM

All replies

  • you need to setup dual forking in that case, I am not sure ifthe audiocodes device supports it or not.

    basically you will configure the incoming DID (PSTN DIDs) to ring on phone, if the GW supports dual forking then configure it to ring on the OC DIDs, assign the DIDs to users (by configuring it in the Tel properties) and it will ring as well on the OC. to do dual forking from the OCS configure the ext= part in the telephony properties and enable simultaneous ringing.

     


    Regards, Mahmoud Magdy Watch Arabic Level 300 Videos about Exchange 2010 here: http://vimeo.com/user3271816 Read pretty advanced Exchange stuff I post here: http://www.enowconsulting.com/ese/blog.asp, follow my blog: http://autodiscover.wordpress.com , corp blog: http://ingazat.wordpress.com and if you Liked my post please mark it as helpful and accept it as an answer
    Tuesday, July 13, 2010 6:37 AM
  • the first suggestion I will make is to reconfigure you internal dial plan to correctly utilize RFC3966-compliant number patterns (+E.164) and then configure the AudioCodes gateway to add/strip the + from incoming/outgoing calls.  Failure to do so is the root of most dialing issues I have seen time after time.

    I suggest you read this article for more background on this best practice: http://blogs.technet.com/b/dougl/archive/2009/06/25/phone-numbers-in-ocs.aspx

    At that point if you still have problems take a look at both the AudioCodes log to see if inbound calls are routing as expected, and also enable logging on the OCS Mediation and Front-End servers to validate if those calls are received and what is happening with the digit normalization.


    Jeff Schertz, PointBridge | MVP | MCITP: Enterprise Messaging | MCTS: OCS
    Tuesday, July 13, 2010 12:33 PM
  • Moderator Note: Immediately proposing your responses as answers is considered poor practice.  Please allow for the original poster to do so if they believe the response was helpful and is in fact an answer.  If the poster does fail to do so after some time has passed the Moderator staff will later review unanswered questions and mark answers where appropriate.

    Thanks,


    Jeff Schertz, PointBridge | MVP | MCITP: Enterprise Messaging | MCTS: OCS
    Tuesday, July 13, 2010 12:38 PM
  • I'm able to add or remove the + sign from within the audiocodes, but the mediation server doesn't seem to route to my communicator client when calling a DID I've assigned to myself. I get an invalid number message from our carrier. What's odd is our UM Dial-in Conferencing number is setup to have the + stripped and is working and allowing conference calls. So, I'm not sure where my configuration is off now...
    Tuesday, July 13, 2010 7:41 PM
  • from where you dial those DIDs! do you dial them from another phone or from the OC!
    Regards, Mahmoud Magdy Watch Arabic Level 300 Videos about Exchange 2010 here: http://vimeo.com/user3271816 Read pretty advanced Exchange stuff I post here: http://www.enowconsulting.com/ese/blog.asp, follow my blog: http://autodiscover.wordpress.com , corp blog: http://ingazat.wordpress.com and if you Liked my post please mark it as helpful and accept it as an answer
    Wednesday, July 14, 2010 8:25 AM
  • @Jeff:

    I don't suggest false replies as answers to spam the forum, I only suggest answers when I am 200% sure that they are correct, OCS and Exchange is what I do on hourly basis, you can check my other replies on the forums to know that.

    I checked the rules and nothing prevents me from proposing my replies as answers the asker have the full power to reject it if required or even ignore it, however you are the forum moderator and you have the power to set the rules which will be considered.


    Regards, Mahmoud Magdy Watch Arabic Level 300 Videos about Exchange 2010 here: http://vimeo.com/user3271816 Read pretty advanced Exchange stuff I post here: http://www.enowconsulting.com/ese/blog.asp, follow my blog: http://autodiscover.wordpress.com , corp blog: http://ingazat.wordpress.com and if you Liked my post please mark it as helpful and accept it as an answer
    Wednesday, July 14, 2010 8:43 AM
  • You are correct in that the forum does not prevent that behavior, thus it is not a rule that I am attempting to enforce.  I'm simply offering an opinion that such practice reflects poorly on the person as it appears they are just 'out for the points'.  I understand many of the new contributors in the OCS forums are here to attempt to gain MVP status through community participation, and doing the self-answer thing on a regular basis is a pretty good way to be overlooked by the program.

    And I'm by no means attempting to single you out as others have been doing the same thing recently.  As I'd like to see the quality of the 'answered' threads be as good as possible I'd hope that all contributors to these forums might follow the same advice.


    Jeff Schertz, PointBridge | MVP | MCITP: Enterprise Messaging | MCTS: OCS
    Wednesday, July 14, 2010 10:15 AM
  • LOL,

    pre-judging on my contributions only to be seen by MVP program is pretty interesting, however you can see that I am participating since very long time on EE (I am on the top) and the fourth on Exchange section on EE and the top since the beginning of last quarter on the Exchange forum and I don't need to add the OCS as a extras just to apply for MVP.

     you can see my contribution since 4 years in the arabic community as explaining OCS R1 and LCS 2005, but it is ok since we are new friends together i found it is so hard for me to follow the very distrbituted OCS forum, however I will assume the good intention and ignore your bad remark on my contribution and I will assume that others made you furious and that came back on me.

    see you around 


    Regards, Mahmoud Magdy Watch Arabic Level 300 Videos about Exchange 2010 here: http://vimeo.com/user3271816 Read pretty advanced Exchange stuff I post here: http://www.enowconsulting.com/ese/blog.asp, follow my blog: http://autodiscover.wordpress.com , corp blog: http://ingazat.wordpress.com and if you Liked my post please mark it as helpful and accept it as an answer
    Wednesday, July 14, 2010 6:53 PM
  • I can see incoming logs in real time on the AudioCodes and it indicates the + sign was added to the incoming number and was sent to Mediation server. I guess it stops there, but don't know. How do I setup the logging on Mediation and FE server?

    Wednesday, July 14, 2010 8:45 PM
  • Install the OCS resource kit and RDP to the mediation server

    open the OCS management console and right click on the mediation and click new debug session (enable logging for S4 and SIP), once done click on analyse logs and this will open them in the snooper and let you know what goes on exactly.


    Regards, Mahmoud Magdy Watch Arabic Level 300 Videos about Exchange 2010 here: http://vimeo.com/user3271816 Read pretty advanced Exchange stuff I post here: http://www.enowconsulting.com/ese/blog.asp, follow my blog: http://autodiscover.wordpress.com , corp blog: http://ingazat.wordpress.com and if you Liked my post please mark it as helpful and accept it as an answer
    Thursday, July 15, 2010 6:09 AM
  • I see S4 but not SIP in the tool (Session Initiation Protocol). Ok, tried without that and SIP shows up in logs. Looks ok though like the +15554449999@ourcompany.com hits but then I get a SIP/2.0 not found 404 error. I have the number associated with my test account in FE server. So, now log at FE server? I also see LocalEndpointAllocated; Status:None. So something's missing in my configuration.
    Friday, July 16, 2010 4:10 PM
  • ok do only S4
    Regards, Mahmoud Magdy Watch Arabic Level 300 Videos about Exchange 2010 here: http://vimeo.com/user3271816 Read pretty advanced Exchange stuff I post here: http://www.enowconsulting.com/ese/blog.asp, follow my blog: http://autodiscover.wordpress.com , corp blog: http://ingazat.wordpress.com and if you Liked my post please mark it as helpful and accept it as an answer
    Saturday, July 17, 2010 5:37 AM
  • Only S4 yielded nothing. On the FE server it has SIPstack as a choice, so I used that and it shows the call is successfully routed, but the user number doesn't exist. I checked Exchange 2007 UM user and saw in the email addresses a place where the number wasn't set correctly, however this didn't work either. Can someone please tell me how its possible for a call to route correctly through the mediation server and FEserver yet fail to ring the Communicator client when the numbers are in the user profile correctly. I also tried adding +1, taking away the +1, and adding just 1 (at the PSTN gateway AudioCodes M1k) and can see in the logs on FE and Mediation the changes, but still not successful in hitting Communicator.

    I've copied and pasted an article where I think my problem is. I have a legacy PBX which handles DIDs starting with 650286xxxx. However, we have 19 numbers available in the block 6504256xxx. I'd like to setup normalization rules for the second set of numbers to do communicator incoming calls. My current rules are phone pattern regular expression ^(\d{10})$ and Translation Pattern regular expression ^(6504256\d{3})$.

    ·         Users have the flexibility of setting the default location profile using the device interface.

    Each Location Profile has an ordered list of normalization rules, which are used to translate a dialed number. A normalization rule contains:

    ·         Number pattern – regular expression

    ·         Translation – translation pattern

    For example:

    NormRule1                      ^5(\d{4})$             +1425555$1,

    translates the dialed number 50100 to the E.164 format +14255550100. The regular expression (^5(\d{4})$) matches any number that starts with the numeral 5 followed by any 4 digits.

     

    Note

    The order of the normalization rules in a location profile has significance because the first rule that matches is used to translate the number. If no match is found, an error response is sent to the caller.

     

    Monday, July 19, 2010 4:53 PM
  • Can you actually copy and paste where you are seeing that the number does not exist, and that it is routed properly?

     

    Can you also take a screenshot of the user settings for voice, where you should see the users teluri

     

    Thanks.

     


    Randy Wintle | MCTS: UC Voice Specialization | Winxnet Inc
    Monday, July 19, 2010 9:17 PM
  • I think this area is where my problem is. Also, since I've been messing with this, the Communicator clients no longers automatically adds the +1 and (415) brackets around the area code. User tel uri look like this and are correct tel:+6504256007

    Standard 10 Digit Dialing
     
      Phone Pattern: ^(\d{10})$
      Translation: ^(6504256\d{3})$
    OCS Internal
     
      Phone Pattern: ^(\d{10})$
      Translation: ^(6504256\d{3})$

    • Edited by MarcGel Thursday, July 22, 2010 6:30 PM
    Thursday, July 22, 2010 6:25 PM
  • Can you show us what the logging tool has in it. You said before when you did tracing you saw the number come in but not find a user.

     

     


    Randy Wintle | MCTS: UC Voice Specialization | Winxnet Inc
    Thursday, July 22, 2010 6:30 PM
  • How do I paste a screen shot in here?
    Thursday, July 22, 2010 6:40 PM
  • You will have to upload it somewhere and share a link. Pain, I know.

     


    Randy Wintle | MCTS: UC Voice Specialization | Winxnet Inc
    Thursday, July 22, 2010 6:44 PM
  • Regardless of the trace and looking at the current information, how would you go about normalizing numbers in Communicator to automatically add the +1(xxx) to say 6502225555 so that it shows as +1(650) 222-5555 before dialing out? Where is that done exactly? I had a Microsoft tech help me with this last year and I didn't think I changed anything, so not sure why it all of a sudden stopped doing this for me.
    Thursday, July 22, 2010 6:55 PM
  • I think your best friend in this case would be the Enterprise Voice Route Helper

     

    It installs with the resource kit tools, its under Programs->Office Communications Server 2007 R2->Resource Kit

    That tool will allow you a simpler method of creating normalization rules.

     

    For what you want though...

     

    Your pattern would be: ^(\d{10})$

    Translation: +1$1

    What this does, is takes any 10 digit number dialed in communicator, for example 6502225555

    Then it adds a +1

     

    So the result would be +16502225555

    Now, communicator will recognize that as a true E.164 number, and display it as:

    +1 (650) 222-5555

    Communicator will only neatly format numbers that are in proper E.164, and that is a full 11 digit number starting with a +

     

     

     


    Randy Wintle | MCTS: UC Voice Specialization | Winxnet Inc
    • Marked as answer by MarcGel Thursday, July 22, 2010 9:22 PM
    Thursday, July 22, 2010 7:02 PM
  • Ok, cool. That worked. Thanks. Now I'm still not able to assign a DID to communicator or at least complete a call to communicator. I get a recording saying, "The number you dialed is not a working number." yet I know its configured correctly in FE server and getting to the FE server then getting the SIP/2.0 error 404 not found and 403 forbidden. the trace shows the +16502225555@ourcompany.com as not being valid, yet it says the response was routed correctly. Also, the dial in conferencing number connects and shows the +6502225001@ourcompany.com connecting successfully. thoughts?
    Thursday, July 22, 2010 8:12 PM
  • Change the Tel Uri for the user to read:

     

    tel:+1650222555 

     

    I think you're missing the +1 in the tel uri

    Above you Said "User tel uri look like this and are correct tel:+6504256007"

     



    Randy Wintle | MCTS: UC Voice Specialization | Winxnet Inc
    • Marked as answer by MarcGel Thursday, July 22, 2010 9:23 PM
    Thursday, July 22, 2010 8:16 PM
  • Thank you Randy! That was the trick. Not sure how this conversation got so side tracked on such a small simple configuration issue. But thanks a bunch!
    Thursday, July 22, 2010 9:22 PM