locked
regsvr32- unable to register a library with windows RRS feed

  • Question

  • Hi

    I am using Windows 7 with Excel 2012. I would like to include a library that is associated with a VB control application so that I can monitor and control it using Excel.

    I have saved the .dll in C:\Windows\sysWOW64 and initialized command prompt as an administrator. I then run C:\Windows\sysWOW64\regsvr32 C:\Windows\sysWOW64\Litron.Control.PulsedLasers.dll and it errors and says it was loaded but the loading point DLLRegisterServer was not found. I know the file is a proper .dll file because there is an application that runs off of it.

    What can I check?

    Thanks

    Best regards

    Tuesday, March 12, 2013 9:36 PM

All replies

  • Please don't forget to add the quote on the full path.

    regsvr32 "C:\Windows\sysWOW64\Litron.Control.PulsedLasers.dll"


    Niki Han
    TechNet Community Support

    Thursday, March 14, 2013 5:48 AM
  • This didn't help. I received the same error message. Anything else?

    I have tried running regsvr32 from sysWOW64 with the dll saved in system32 and also running regsvr32 from system32 with the dll saved in sysWOW64 with no luck. I have ensured that there are quotation marks and tried without to be sure. 

    Is there a log that I could provide that may help to debug this?

    Thursday, March 21, 2013 3:08 PM