none
Installing v2 CTP on Server 2008 R2 in Internetless environment

    Question

  • I'm trying to install in an Internetless environment on a Server 2008 R2 server.  I get the error "Setup Wizard failed while navigating from the Welcome screen".  Any guidance on how to install on a 2K8 R2 server?  I'm not sure if the lack of Internet is part of the problem or not.

     

    Thanks.

    Friday, June 10, 2011 2:20 PM

Answers

  • I set a system environment variable for PUBLIC and my installation ran fine - thanks for the workaround!

    Right-click on My Computer, Properties, Advanced, Environment Variables (System Variables), New

    PUBLIC (name) and %SystemDrive% (value), click on OK, then close the System Properties

    Start, Run, browse to Security_Compliance_Manager_Setup.exe, OK

    It should (might?) run for you - it did for me :-)

    If you don't need the PUBLIC variable anymore you can go back and delete it.  I left it just in case I have to reinstall...

    Jim



    Tuesday, July 26, 2011 5:22 PM
  • A fellow SCM team member discovered a workaround just last week for this. Give this a whirl, we've seen success using this already with fellow beta customers:

    1. open a command prompt

    2. type this as it is "set PUBLIC=%SystemDrive%"

    3. Run SCM installer from this command prompt. It should install fine.

    Sorry about the trouble!

    -jeff

     

    Monday, July 25, 2011 5:34 PM

All replies

  • I recently had that challenge as well. Not sure if I had exactly the same error but I remember I needed to update several certificate revocation lists manually before the prerequisite checker and installer wanted to kick off.

    To figure out which crl you need, you inspect the details of the signing certificate, go to the url you find in there, download the .crl file and install it on the internetless machine. Had to jump through multiple of these hoops before I got there.

    Thursday, June 16, 2011 8:18 PM
  • Wow, this is the first time I've heard this one.... How is the SCM v2 Beta doing on these machines? Did it install OK??

    -jeff

    Friday, July 8, 2011 7:00 PM
  • I am unable to install it in my lab environment, which is Internetless as well.  I get an error code 1603 each time from the installer.  Upon review of the msilog file, the error is actually 1606: Could not access network location \Microsoft Security Compliance Manager\Baselines.

    Tuesday, July 12, 2011 1:55 PM
  • Any news one this?

     

    Product: Microsoft Security Compliance Manager -- Error 1606. Could not access network location \Microsoft Security Compliance Manager\Baselines.
    http://matthew1clarke.com
    Monday, July 18, 2011 11:26 AM
  • I've got the same issue as TestIDP (Internetless connection on my LAN) - SCM 1 installs fine, but SCM 2 fails with Error 1603 displayed, Error 1606 in the log as well.

    Is there a way to tweak the SCM 2 installation to suppress the requirement for the Baseline download?  I've already downloaded the Baselines I need and they imported into SCM 1 fine.  When I went to upgrade to SCM 2 I ran into the Error 1603 failure.

    Jim

    Tuesday, July 19, 2011 4:36 PM
  • I am experiencing the same issues as TestIDP and JimInTucson. Error 1603. When i try to run the installation directly from the extracted "scmsetupx86.msi" it returns "Could not access network location \Microsoft Security Compliance Manager\Baselines.". 


    One difference here is that this system has full access to the internet!

    Wednesday, July 20, 2011 2:08 PM
  • Jeff & I may have found the culprit by looking in the SCMSetupMSI.log file -

    The entry "Property(S): TempBaselinesFolder = \Microsoft Security Compliance Manager\Baselines" isn't complete - it should have the complete path, including the drive letter.

    All the other entries are explicit in the log file, so this is something that got missed in the proofreading.

    I haven't figured a workaround and Jeff has passed the bug up the chain.

    Jim

    Wednesday, July 20, 2011 4:53 PM
  • A fellow SCM team member discovered a workaround just last week for this. Give this a whirl, we've seen success using this already with fellow beta customers:

    1. open a command prompt

    2. type this as it is "set PUBLIC=%SystemDrive%"

    3. Run SCM installer from this command prompt. It should install fine.

    Sorry about the trouble!

    -jeff

     

    Monday, July 25, 2011 5:34 PM
  • I attempted this workaround and am still seeing the error.  I have verified that PUBLIC=%SystemDrive% is in my path. 

    As mentioned by JimInTuscon above, the entry "Property(S): TempBaselinesFolder = \Microsoft Security Compliance Manager\Baselines" still isn't complete.  Thoughts?

    Thanks for your help!



    Monday, July 25, 2011 7:12 PM
  • How did you launch the installer? You have to make sure you actually launch the MSI from an environment with that parameter set properly.

     

    -jeff

    Monday, July 25, 2011 8:47 PM
  • I typed "set PUBLIC=%SystemDrive%" 

    I typed "set P" to make sure that the PUBLIC was set to my system drive.

    I typed "scmsetupx86.msi" and I tried typing "Security_Compliance_Manager_Setup.exe" from the command prompt which was still open from the above two commands.

     

    Monday, July 25, 2011 9:46 PM
  • Ah ha! I slightly mistyped. You should never run the MSI directly, just the EXE. Try again with nothing at all running. Set the environment up, then run the Security_Compliance_Manager_Setup.exe from the same prompt. This HAS to work! :)

    I guess the other option is you can set a system wide option which all new processes will get. This can be done from the properties page of My Computer. That is a global area in there.

    Let me know which works (please)!

    -jeff

     

    Monday, July 25, 2011 9:55 PM
  • Hi Jeff,

    sorry, this helps not out.

    Environment says PUBLIC=c: (as expected) but still same error (1603 and in msi-log 1606).

    No folder \Microsoft Security Compliance Manager\Baselines is on the harddrive

    I have a german OS, can that be an issue?

    rgds

    Horst

    Tuesday, July 26, 2011 12:51 PM
  • I set a system environment variable for PUBLIC and my installation ran fine - thanks for the workaround!

    Right-click on My Computer, Properties, Advanced, Environment Variables (System Variables), New

    PUBLIC (name) and %SystemDrive% (value), click on OK, then close the System Properties

    Start, Run, browse to Security_Compliance_Manager_Setup.exe, OK

    It should (might?) run for you - it did for me :-)

    If you don't need the PUBLIC variable anymore you can go back and delete it.  I left it just in case I have to reinstall...

    Jim



    Tuesday, July 26, 2011 5:22 PM
  • Welcome! OK, cool - sounds like it is working if it is system wide. I think the MSI creates several processes during our setup. Just launching setup from a CMD environment with it set isn't enough. Thank you for letting us know!!

    -jeff

    Tuesday, July 26, 2011 8:37 PM
  • What happened to the good old pushing new registry value solution?

    I only wanted to change the maximum password duration of the local security policy on some of the computers from the default value of "42" to "90", and I have to go through all these just to change a number .....

     

    Tuesday, August 16, 2011 5:00 AM
  • Barramundi,

    You don't have to use SCM to configure settings, SCM is for organizations that want to centrally manage baselines and export their baselines in multiple formats. If all you want to do is configure password policy then I suggest that you simply use group policy if the computers are in a domain, or the Local Security Policy console if they are stand-alone.

    Kurt


    Kurt Dillard http://www.kurtdillard.com
    Tuesday, August 16, 2011 3:17 PM
    Moderator
  • I've changed the Local Security Policy on my computer and am trying to export and replicate the password policy to about 50 computers that are not in the domain.

    Are you saying there is another way of doing this?  Do tell ...

    Thanks.


    Wednesday, August 17, 2011 1:52 AM
  • I assume there is no other way of doing this, so I tried SCM and while I am running the following command on Windows XP SP3 PC:

     

    cscript C:\GPOBackups\{CE0AA99F-D59F-4DC7-9FB4-E4068CE664F5}\GPOPack.wsf /Path:C:\GPOBackups\{CE0AA99F-D59F-4DC7-9FB4-E4068CE664F5}

     

    the following error occurred:

     

    GPOPack.wsf(207, 14) Microsoft VBScript runtime error: variable not defined: 'conLABEL_CODE002'

     

    Any idea? 

    Thanks

    Thursday, August 18, 2011 3:04 AM
  • In my the issue of error 1603 was cyrilic login name Администратор in my Russian Windows

    In my case problem solved.

     

    Friday, September 16, 2011 5:52 AM