locked
Internet Explorer 10 Won't Open on Windows Server 2012 RRS feed

  • Question

  • Seems to have started after installing Windows Update.  You click the IE icon and nothing happens.  Nothing is logged in the event log.

    I've tried disabling & re-enabling the feature - no luck.

    What else can be done?  

    Wednesday, April 17, 2013 5:25 AM

All replies

  • Another note - nothing in control panel "Internet Options" section is working.  Will not launch Internet Options.
    Wednesday, April 17, 2013 6:04 AM
  • Hi,

    Reset Internet Explorer on Propeties.

    Wednesday, April 17, 2013 6:13 AM
  • How would I open Properties when Internet Options is not responsive?

    Wednesday, April 17, 2013 1:56 PM
  • Anyone from Microsoft qualified to take a stab at this?

    Hello?

    Thursday, April 18, 2013 1:59 PM
  • Can you browse to IE via C:\Program Files\Internet Explorer

    Try right-clicking and running as administrator.

    Friday, April 19, 2013 11:05 AM
  • If this does not work, try uninstalling IE10, run IE9 and try installing IE10 manually again.

    Best greetings from Germany
    Olaf

    Friday, April 19, 2013 11:21 AM
  • Hey Olaf - thanks for the reply.  Windows Server 2012 does not support earlier versions of IE (pre IE10) so I cannot try that.

    I have tried uninstalling and reinstalling the Win Server GUI & IE 10 (in different tests VIA powershell).  

    Dale - I have tried running as admin, super admin (based on my test account), I've disabled and enabled IESC.  I've enabled and disabled UAC.  So on and so forth.

    I've tried launching IE with add-ins turned off VIA command line.

    I've tried opening Internet Options from Control Panel (does nothing).

    I've used msconfig to load different selective startup configurations and it still doesn't run.  

    The only thing I have installed that's not from Microsoft is Juniper Networks VPN client.  
    This is a SharePoint 2013 stand alone installation with AD + SP2013 + SQL Server + Visual Studio 2012 all on one box.

    The VM may use up to 64GB of RAM and at minimum 12GB - it has 4 CPUs assigned in Hyper V.

    This is good (new) hardware & my other farm does not have this issue.


    • Edited by Matt Stark Friday, April 19, 2013 5:12 PM MS Text Editor made text unreadable - figures...
    Friday, April 19, 2013 5:12 PM
  • Does anyone have a list of things that could cause this problem to occur?

    I could run the list and try to reduce to something concrete.

    There clearly isn't much support for the 2012 stack yet so may be SOL on this.

    Friday, April 19, 2013 5:23 PM
  • Windows Server 2012 does not support earlier versions of IE (pre IE10) so I cannot try that.

    Arrgh - sleepy me, you are right of course (I was mentally at 2008 R2)!

    Is there anything in the application log of the server? (Like missing or unregistered DLL, COM or DCOM permissions ...)
    Would another browser run on the machine without problems?

    With Run as Admin you mean by right click and select Run as Administrator?

    Did you try to use a new account?

    Did you configure any Group Policies which might restrict launch of applications?

    Did you disable User Account Control? If so, see KB2736601.

    Which kind of video driver is installed?

    Best greetings from Germany
    Olaf

    Friday, April 19, 2013 6:12 PM
  • I understand.

    1) Application Logs have a few Software Protection information messages (lists of GUIDs indicating licensing is OK).  There are some warnings from SP about log disk space which isn't unusual.  Performance Point is having trouble loading a datasource provider but this is running in the SP Service space so shouldn't be an issue for IE.  I do see an error around the FIM Synchronization Service - in SP2013 - again, shouldn't be an issue for IE.  Security Logs are fine.  The System Logs show a "Local Activation permission for the COM Server application with CLSID {000C101C-0000-0000-C000-000000000046} and APPID {SAME}" ... but again, this is a SP process.  Thoughts?

    2) Google Chrome runs fine.

    3) Right clicking run as admin from C:\Program Files\Internet Explorer\iexplore.exe does not work. Down swiping on tile in Metro & selecting run as administrator does not work.  Running as a different user and entering valid Admin / Non-Admin credentials does not work.

    4) Additionally yes - I tried a couple other accounts - does not work.

    5) I have not configured any Group Policies other than adding groups to users to fabricate a super admin account which IMO is OK.

    6) I have disabled UAC & Google Chrome was set to the default browser on the system.  I just tested creating a HTM file and open with IE to simulate default browser - does not work.

    7) The video driver is just the Generic Non-PnP Monitor, on Microsoft Hyper-V Video.  The host system is on EVGA GeForce GTX 690 4GB 512-bit GDDR5 PCI Express 3.0.  However I have a couple other farms on this box and they all open IE.  Could I go further with this diagnostic?  Device Manager shows the driver as OK but we all know that's misleading at times.

    Olaf - I really appreciate you already taking time out to reply to me & brainstorm this further.  I appreciate someone in the community has the time and ability to help troubleshoot!

    Cheers,

    Matt 

    Friday, April 19, 2013 6:36 PM
  • I should probably also add - which may be related - the host system is Windows 8.  

    But the other farms hosted on this hardware all open IE so not sure how.

    I've also Shut Down all other VMs on Hyper-V to ensure that I'm isolating this VM when testing.

    Friday, April 19, 2013 6:43 PM
  • Hi Matt,

    Just an idea: My Inernet Explorer 64 bit crashed without an error message as soon as it wanted to load a 32 bit ActiveX component.

    Does Internet Explorer 32 bit come up?

    Greetings Marcel

    Friday, April 19, 2013 8:09 PM
  • Good idea - unfortunately 32bit didn't work either.

    Thanks for the suggestion!

    Friday, April 19, 2013 8:24 PM
  • Hi Matt,

    Please open a Command Prompt. Change drive and Directory to C:\Program Files\Internet Explorer and enter the command iexplore.exe<CR>.

    Can't you see an error message?

    If not, do you know how to run the SysInternals 'Process Monitor' Tool 'ProcMon'?

    'ProcMon' shows you a lot of important System API calls with Parameters and the results 'success' or 'failed'.

    For 32 bit i have a very old tool 'LodPrf32' from Matt Pietrek. Once it was contained in the Windows Platform SDK

    'LodPrf32' is much easier to  use than 'ProcMon'. Below you see the output of my version of LodPrf32.

    Greetings Marcel


    LODPRF32  14:29:49 20.04.2013
    C:\Program Files (x86)\Internet Explorer\iexplore.exe
    Process loaded at: 00D00000
    DLL Load: ntdll.dll at address 775A0000
    DLL Unload: ntdll.dll at address 00FD0000
    DLL Unload: ntdll.dll at address 77210000
    DLL Unload: ntdll.dll at address 00FD0000
    DLL Unload: ntdll.dll at address 00FD0000
    DLL Load: KERNEL32.dll at address 77210000
    DLL Load: KERNELBASE.dll at address 76220000
    DLL Init: 87248000 ms - KERNELBASE.dll , C:\Windows\SYSTEM32\KERNELBASE.dll
    DLL Init: 87248001 ms - KERNEL32.dll , C:\Windows\SYSTEM32\KERNEL32.DLL
    DLL Load: apphelp.dll at address 734B0000
    DLL Init: 87248003 ms - apphelp.dll , C:\Windows\system32\apphelp.dll
    OutDbgStr 000001: SHIMVIEW: ShimInfo(Complete)
    DLL Load: msvcrt.dll at address 77420000
    DLL Load: iertutil.dll at address 76F90000
    DebugBreak breakpoint hit
    DLL Init: 1 ms - msvcrt.dll , C:\Windows\SYSTEM32\msvcrt.dll
    DLL Init: 1 ms - iertutil.dll , C:\Windows\SYSTEM32\iertutil.dll
    EXE entry point hit - 2 ms initializing
    DLL Load: USER32.dll at address 74C60000
    DLL Load: GDI32.dll at address 76AA0000
    DLL Init: 82 ms - GDI32.dll , C:\Windows\SYSTEM32\GDI32.dll
    DLL Init: 83 ms - USER32.dll , C:\Windows\SYSTEM32\user32.dll
    DLL Load: IMM32.dll at address 76400000
    DLL Load: MSCTF.dll at address 76C70000
    DLL Init: 118 ms - MSCTF.dll , C:\Windows\SYSTEM32\MSCTF.dll
    DLL Init: 118 ms - IMM32.dll , C:\Windows\system32\IMM32.DLL
    DLL Load: SHCORE.dll at address 74710000
    DLL Load: combase.dll at address 76960000
    DLL Load: RPCRT4.dll at address 767C0000
    DLL Load: SspiCli.dll at address 74BE0000
    DLL Load: CRYPTBASE.dll at address 74BD0000
    DLL Load: SECHOST.dll at address 773C0000
    DLL Load: bcryptPrimitives.dll at address 74B70000
    DLL Init: 210 ms - bcryptPrimitives.dll , C:\Windows\SYSTEM32\bcryptPrimitives.dll
    DLL Init: 215 ms - CRYPTBASE.dll , C:\Windows\SYSTEM32\CRYPTBASE.dll
    DLL Init: 215 ms - SECHOST.dll , C:\Windows\SYSTEM32\sechost.dll
    DLL Init: 217 ms - SspiCli.dll , C:\Windows\SYSTEM32\SspiCli.dll
    DLL Init: 217 ms - RPCRT4.dll , C:\Windows\SYSTEM32\RPCRT4.dll
    DLL Init: 217 ms - combase.dll , C:\Windows\SYSTEM32\combase.dll
    DLL Init: 218 ms - SHCORE.dll , C:\Windows\SYSTEM32\shcore.dll
    DLL Unload: <unknown> at address 011C0000 , C:\Program Files (x86)\Internet Explorer\iexplore.exe
    EXIT_PROCESS
    • Edited by marcelloman Saturday, April 20, 2013 12:37 PM
    Saturday, April 20, 2013 4:40 AM
  • Hi Matt,

    did IE work at any time in the past on that machine? If so try to restore the server back to that stage, maybe some update messed up.

    If this is not the case: TBH - if its an option yet, I would reinstall the box rather than invest more countless hours into the troubleshooting.

    Best greetings from Germany
    Olaf

    • Proposed as answer by Nick Gu - MSFT Tuesday, April 23, 2013 2:36 AM
    • Marked as answer by Nick Gu - MSFT Thursday, April 25, 2013 1:56 AM
    • Unmarked as answer by Matt Stark Thursday, April 25, 2013 2:29 AM
    • Unproposed as answer by Matt Stark Monday, August 19, 2013 11:42 AM
    Saturday, April 20, 2013 10:37 PM
  • Hey - IE was working for three months on this machine - it stopped after an update.

    I want to figure this out but have been sidetracked - will update thread after some more research.

    M

    Thursday, April 25, 2013 2:30 AM
  • Hi,

    Thank you for the post.

    Please refer to this guide to check the settings: http://windows.microsoft.com/en-US/windows7/tips-for-solving-problems-with-internet-explorer, if the IE still stop working, you may also reset IE as per: http://support.microsoft.com/kb/923737/en-us

    Regards,


    Nick Gu - MSFT

    Tuesday, May 7, 2013 5:50 AM
  • Thanks Nick - 

    Unfortunately if you read the entire thread, I've already tried these things.  

    Thanks for your contribution.

    Matt

    Tuesday, May 7, 2013 1:44 PM
  • Having a similar problem.  A number of items under "Start' simply don't work, IE included.  I can run the program from command line, but Administrative Tools, IE, and Computer all refuse to run.  Either I click the button and nothing happens (IE) or I click the button and it goes back to the desktop and nothing else happens (Computer, Administrative Tools).  Nothing is logged, nothing is listed in task manager as running... just nothing happens.  I've tried unpinning and pinning to the start menu.  Why did MS saddle their servers with this awful tablet interface?
    Monday, August 12, 2013 8:36 PM
  • I have been experiencing this problem off and on running Server 2012 on the Microsoft Azure cloud.  One odd think I found is that if I right click on the IE Ikon in the task bar, then right click on the Internet Explorer and pick Properties.  Then change Run to Minimized.  IE then runs though minimized.  You can maximize it from there.

    I have no idea what is causing this but you might see if you get the same result

    Friday, August 16, 2013 7:03 PM
  • I realize this is an old thread, but here is what I did to fix the issue.

    open a command prompt as administrator

    cd to system drive:\windows\system32\

    run the following command

    for %i in (*.dll) do regsvr32 %i -s

    give it about five minutes after the command seems to have finished and restart the computer. Once the computer has restart try Internet Explorer again.

    Wednesday, June 11, 2014 6:22 PM
  • Following this forum suggestion - open a cmd.exe prompt and run the following:

    cd "c:\program files\internet explorer"
    iexplore.exe -extoff
    Disable all extensions, accelerators, etc. then retry opening IE without the flag. This worked for me for Windows Server 2012 R2 (IE11) - think it was Lync extension that was causing the crash. 

    You can also try disabling/re-enabling the feature using dism

    Friday, January 9, 2015 4:48 PM