locked
Sharepoint 2010 MP in SCOM 2016 RRS feed

  • Question

  • Hi,


    Found a SCOM MP for Sharepoint that indicates it is for SCOM 2012

    https://www.microsoft.com/en-us/download/details.aspx?id=34697

     I tried it in SCOM 2016 since I couldn't find a newer one and on the off chance it would work.  It doesn't appear to work (surprise) faulting for a dll version issue on the group tasks to configure SharePoint.

    The Event Policy for the process started at 3:25:29 PM has detected errors in the output. The 'StdErr' policy expression: 
    .+ 

    matched the following output: 

    Exception calling "Load" with "1" argument(s): "Could not load file or assembly 'Microsoft.EnterpriseManagement.Core, Version=7.0.5000.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified." 

    Failed to load Microsoft.EnterpriseManagement.Core.dll 

    Any chance that this will be fixed at some point?  Would it be as simple as editing the MP to point to the 2016 version of the dll which appears to be 7.2.11719.0?  I understand it is an old version of SharePoint and ideally we could upgrade it but this is where we are at this point :).

    Thanks,

    Jon

     

    Tuesday, January 10, 2017 8:31 PM

All replies

  • Hi Jon,

    If you look at that download page you will notice the following text:

    "It needs to be used together with SharePoint 2010 Management Pack"

    That is just an update for SCOM 2012, and you will notice the version, when imported is 1.0.0.0

    You need to get the SharePoint MP:

    Peep this link for assistance: http://www.systemcentercentral.com/sharepoint-2010-mp-on-scom-2012/


    Regards, Blake Email: mengotto<at>hotmail.com Blog: http://discussitnow.wordpress.com/ If my response was helpful, please mark it as so, if it answered your question, then please also mark it accordingly. Thank you.

    Tuesday, January 10, 2017 9:45 PM
  • Thanks for the info.  I had seen that and do have those MP's installed as well.  

    Jon

    Wednesday, January 11, 2017 12:44 PM
  • Hi Sir,

    Have you checked if that file exists under the similar path as "C:\Windows\assembly\GAC_MSIL\Microsoft.EnterpriseManagement.Core\7.0.5000.0__31bf3856ad364e35" .

    (I don't have SCOM 2016 server , this path belongs to server 2012 R2 )

    Best Regards,

    Elton


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, January 12, 2017 4:36 AM
  • Hi,

    Sorry for the delayed response.  That path does not exist.

    Thanks,

    Jon

    Wednesday, January 18, 2017 7:23 PM
  • Hi. FYI I have this issue too and posted the issue in the SCOM forum: https://social.technet.microsoft.com/Forums/systemcenter/en-US/af83fbce-aa0a-4863-afe1-2ea2ee2e3cca/sharepoint-2010-mp-for-scom-2016?forum=operationsmanagermgmtpacks
    Wednesday, February 1, 2017 2:46 PM
  • Hi, 

    I am experience the same issue as well.  Have anyone found a solution?

    Thursday, February 2, 2017 3:29 PM
  • I have talked to Microsoft, and the SharePoint 2010 mp is not supported with SCOM 2016, and there are currently no plans for an upgrade.
    • Proposed as answer by Elton_Ji Thursday, February 9, 2017 5:05 AM
    Wednesday, February 8, 2017 9:18 AM