none
Project Server 2013 Tasks differ in project site and plan RRS feed

  • Question

  • I have an Project Server 2013 enterprise plan that I created with an associated project site. The plan has tasks added to the timeline. The project site has a timeline webpart but the problem is the tasks added to the timeline differ.

    Does anyone have any ideas what could be the problem here? I checked the timeline webpart and it's correct.

    Thanks!

    [Images below].

    The following image is taken from the schedule PDP.

    Schedule PDP

    This image taken from the project site depicts what is out of sync.

    project site

    • Edited by Roland G29 Saturday, February 8, 2014 2:52 PM Added images
    Saturday, February 8, 2014 12:31 AM

All replies

  • Hi mawaru,

    Please attach some screenshots so we can have a better idea of the issue and thus provide you a better help.

    Basic things would be to publish the project plan to "push" data from the project plan to the sharepoint task list. Be sure checking the queue that the publish job have been successfully proceeded.

    Hope this helps.


    Guillaume Rouyre - MBA, MCP, MCTS

    Saturday, February 8, 2014 1:39 AM
    Moderator
  • Hello, take a look at the schedule PDP for that project (not in edit mode), does the timeline here match the project site? If it does, just publish the project, once the job has been successful all the timelines will match. Paul

    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS

    Saturday, February 8, 2014 12:20 PM
    Moderator
  • Hi Guillaume,

    I attached the images. 

    Yes, what I did so far was publish the project plan. I also unlinked the project site from the plan, then linked them again. Basically I was trying to force the SharePoint task list to sync with the project plan.

    Thanks,

    Roland

    Saturday, February 8, 2014 2:54 PM
  • Hi Paul,

    No, the timelines have different tasks added (see the images I added above). I'm trying to force the SP list to sync with the project plan, but un-linking the project site didn't seem to work. 

    I'm still looking for other options.

    Thanks,

    Roland

    Saturday, February 8, 2014 2:56 PM
  • Hi Roland,

    Unfortunately the screenshots don't help since they do not show any unsync between the Schedule PDP and the project site timeline..

    Have you checked the ULS log and the queue while publishing the project?

    Regards.


    Guillaume Rouyre - MBA, MCP, MCTS

    Saturday, February 8, 2014 3:35 PM
    Moderator
  • Hi Guillaume,

    Yes, I've checked the queue while publishing the project. It's successful without any errors. I don't remember if I checked the ULS logs, but what I suspect is that it will say something along the lines of orphaned tasks in the project site.

    Anyways I've tried a number of things and I think the only 2 options I have are:

    1. Re-create the project site then sync the plan to it
    2. Ask MSFT for a script to resolve the orphaned tasks

    For the same of time, I'm going to assess how long it would take to re-create the project site.

    Thanks,

    Roland

    Monday, February 10, 2014 8:20 PM
  • Thanks for the feedback.

    Have you read this post about orphans that might cause troubles to the reporting DB:

    http://social.technet.microsoft.com/Forums/en-US/bf1cb4e8-b9c8-4ade-b9d8-a41faedef44c/tasks-missing-from-reporting-database-even-though-they-are-in-the-project-plan?forum=projectserver2010general

    Hope this helps.


    Guillaume Rouyre - MBA, MCP, MCTS

    Monday, February 10, 2014 8:31 PM
    Moderator