none
Driver Found But Not Installing - MDT 2013 RRS feed

  • Question

  • I'm working on a Windows 10 test image and I'm trying to install some USB 3 drivers on an older HP systems. I've found drivers that work from HP that were for Vista originally. I can update them in Device Manager but they don't seem to install in MDT 2013. 

    ZTIDrivers.log shows the drivers are found and copied to the machine but when I look at the system after deployment, they're not installed in Device Manager.

    Is there a command line method to force the installation / detection of a specific .inf file?

    This is what my ZTIDrivers.log shows

    Found a driver for PCI\VEN_8086&DEV_3A36: {57c8c9c8-f696-4349-b4c9-84c636e3542e} from \\MDT000\DeploymentShareBareMetal$\Out-of-box Drivers\System\2008s4el_9.1.0.1012_9DA8BEA05AD6B17A06B9EAC51A20BC7E89C76C7E\ichausb.inf

    Validating connection to \\MDT000\DeploymentShareBareMetal$\Out-of-box Drivers\System\2008s4el_9.1.0.1012_9DA8BEA05AD6B17A06B9EAC51A20BC7E89C76C7E

    Copying drivers from "\\MDT000\DeploymentShareBareMetal$\Out-of-box Drivers\System\2008s4el_9.1.0.1012_9DA8BEA05AD6B17A06B9EAC51A20BC7E89C76C7E" to "C:\Drivers\System\2008s4el_9.1.0.1012_9DA8BEA05AD6B17A06B9EAC51A20BC7E89C76C7E"

    About to run command: cmd.exe /c xcopy /seihycd "\\MDT000\DeploymentShareBareMetal$\Out-of-box Drivers\System\2008s4el_9.1.0.1012_9DA8BEA05AD6B17A06B9EAC51A20BC7E89C76C7E" "C:\Drivers\System\2008s4el_9.1.0.1012_9DA8BEA05AD6B17A06B9EAC51A20BC7E89C76C7E" 1> NUL 2>NUL



    Orange County District Attorney

    Monday, January 25, 2016 4:19 PM

All replies

  • Setupapi.dev.log should tell you why (probably driver ranking).  Although Intel chipset drivers aren't needed by win 10.

    Logs are very important. https://keithga.wordpress.com/2014/10/24/video-mdt-2013-log-files-basics-bdd-log-and-smsts-log/ Mention any customizations you have made.

    Monday, January 25, 2016 9:24 PM
    Moderator
  • I did subsequently find that we had two versions of the driver. The newer one was trying to load and wasn't working.

    I did a workaround using devcon.exe and created a .cmd file in my Task Sequence that loads the correct driver at the end of the deployment.


    Orange County District Attorney

    Monday, January 25, 2016 9:27 PM
  • If you don't install the driver at all doesn't windows have it covered already?

    Logs are very important. https://keithga.wordpress.com/2014/10/24/video-mdt-2013-log-files-basics-bdd-log-and-smsts-log/ Mention any customizations you have made.

    Monday, January 25, 2016 9:31 PM
    Moderator
  • No, it doesn't.

    Orange County District Attorney

    Monday, January 25, 2016 9:32 PM