none
('/') forward slash causing trouble me in FullText Search RRS feed

  • Question

  • Hello All,

    I have a column with fulltext search and it contains 'S/Y' and 'M/Y' special abbreviations.
    When I try to use contains function it is not working. I did some researches and I try to remove my, m, s, y nose words from nose file, but problem still continue.

    Any Idea how can I fix this issue?

    PS: 
    We are using SQL Server 2005 ( 9.0.3054 ) and Database running on win2k3. 
    My Databases compatibility level is 90.


     
    Thursday, September 24, 2009 6:59 PM

Answers

  • Sounds strange. Based on my tests, either one of the followings should work.

    After removing the words from the noise-words file

    1.    Right-click the relevant full text catalog, select Rebuild .

    2.    Drop the full text index from the table and re-create the full text index in a different full text catalog.
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by Bulent COSKUN Wednesday, October 14, 2009 12:41 PM
    Monday, October 12, 2009 5:20 AM

All replies

  • Hi,

    What do you get when you execute the following query?

    select value, value_in_use from sys.configurations where name = 'default full-text language'

    Please make sure the corresponding noise-word file was edited.

    After removing noise words from the noise-word file, have you repopulated the full-test catalog? If not, please right-click the table name in SQL Server Management Studio, select Full-Text index -> Start Full Population .

    References:

    Noise Words
    http://msdn.microsoft.com/en-us/library/ms142551%28SQL.90%29.aspx

    default full-text language Option
    http://msdn.microsoft.com/en-us/library/ms180854%28SQL.90%29.aspx

     
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Tuesday, September 29, 2009 12:52 PM
  • Hi,

    when I run your query I get the following result.
    value = 1033
    value_in_use = 1033

    So I have already done what you suggested.

    Thanks, 


    Thursday, October 1, 2009 3:06 PM
  • There is a note in Noise Words that says:

    If you edit a noise-word file, you must repopulate the full-text catalogs before the changes will take effect.

    So after we edit the noise-words file, we need to right-click the corresponding full text catalog and then select Rebuild .

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by KJian_ Monday, October 12, 2009 2:04 AM
    • Unmarked as answer by Bulent COSKUN Monday, October 12, 2009 4:19 AM
    Monday, October 5, 2009 10:00 AM
  • Sounds strange. Based on my tests, either one of the followings should work.

    After removing the words from the noise-words file

    1.    Right-click the relevant full text catalog, select Rebuild .

    2.    Drop the full text index from the table and re-create the full text index in a different full text catalog.
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by Bulent COSKUN Wednesday, October 14, 2009 12:41 PM
    Monday, October 12, 2009 5:20 AM
  • I made a mistake you were right "REBUILD" solved this issue. 

    I appreciated.

    Thanks again.

    Wednesday, October 14, 2009 12:45 PM