locked
Add ing a user group that have access to only one document library RRS feed

  • Question

  • Hello! I am creating many user groups, and some of them are groups who only need access to one document library, and we don't want them to see the rest of the site.. Is there an efficient/recommended way to accomplish this?

    Thanks!

    T

    Thursday, March 17, 2011 8:21 PM

Answers

  • Hi Thomas,

    You simply navigate to the content area (document library, lists, etc.), click settings > permissions and assign a a user group with permission level. However, do bear in mind with your site content structure as too many specific permissions will give you overheads.

    hth,


    -- techChirag
    • Marked as answer by THTolleson Monday, March 21, 2011 4:43 PM
    Thursday, March 17, 2011 8:58 PM
  • Go to the document library settings-> Permissions for this document library-> actions->Edit Permissions & then add your users there.

    This users added here are provided permissions only to that document library and nowhere else.


    Thanks,
    Chanakya
    • Marked as answer by THTolleson Monday, March 21, 2011 4:43 PM
    Friday, March 18, 2011 5:46 AM

All replies

  • Hi Thomas,

    You simply navigate to the content area (document library, lists, etc.), click settings > permissions and assign a a user group with permission level. However, do bear in mind with your site content structure as too many specific permissions will give you overheads.

    hth,


    -- techChirag
    • Marked as answer by THTolleson Monday, March 21, 2011 4:43 PM
    Thursday, March 17, 2011 8:58 PM
  • Go to the document library settings-> Permissions for this document library-> actions->Edit Permissions & then add your users there.

    This users added here are provided permissions only to that document library and nowhere else.


    Thanks,
    Chanakya
    • Marked as answer by THTolleson Monday, March 21, 2011 4:43 PM
    Friday, March 18, 2011 5:46 AM
  • Hello!

    Thanks for the responses. I've tried that, but the user group doesn't show up in the document library > settings > permissions interface. The user group is there when I look under site settings, but they don't show up in the document library.

    Is this because I have not given the user group any permissions at all?

    I don not want the group to be able to read or access any other part of the site but the specific document library. How shall I set the group up?

    Thanks!

    T

    Monday, March 21, 2011 4:38 PM
  • Oops! Just figured it out... i have to add the group to the document library.

    Thanks, everyone!

    T

    Monday, March 21, 2011 4:43 PM