locked
"Link failed" status is showing between Central Administration site and Primary Site in SCCM 2012 R2 RRS feed

  • Question

  • Hi,

    I am very fear when I see the "Link Failed" status between Central Administration Site and Primary Site in Database Replication tab in Monitoring column in SCCM 2012 R2.

    Can anyone help to resolve the issue?

    • Moved by Frank Dong Friday, September 15, 2017 7:27 AM SCCM2012Question
    Thursday, September 14, 2017 1:16 PM

All replies

  • Have you tried the replication link analyzer?

    Jason | https://home.configmgrftw.com | @jasonsandys

    Thursday, September 14, 2017 1:48 PM
  • https://configmgrblog.com/2012/02/11/replication-link-analyzer-in-configuration-manager-2012/

    Check the above link for how to check the issue and fix the same on step by step basis.


    Kamala kannan.c| Please remember to click “Mark as Answer” or Vote as Helpful if its helpful for you. |Disclaimer: This posting is provided with no warranties and confers no rights

    Thursday, September 14, 2017 10:29 PM
  • Hii,

    When I am running "Replication Link Analyzer" on "Central Administration Site" server and found the below message:

    "Unable to launch engine for Replication Link Analyzer"



    • Edited by VivekPorwal Friday, September 15, 2017 6:01 AM
    Friday, September 15, 2017 6:00 AM
  • Hi, 

    Please read below link - Prerequisites to use the Replication Link Analyzer paragraph:

    https://technet.microsoft.com/en-us/library/gg712676.aspx

    Enven though the Replication Link Analyzer did not open normally, the ReplicationLinkAnalysis.log should generated. Any information in it?

    Several links of tips for troubleshooting database replication issue:

    https://support.microsoft.com/en-us/help/20033/troubleshoot-database-replication-service-in-mcm

    https://blogs.msdn.microsoft.com/minfangl/2012/05/16/tips-for-troubleshooting-sc-2012-configuration-manager-data-replication-service-drs/

    https://blogs.technet.microsoft.com/umairkhan/2014/03/24/configmgr-2012-drs-troubleshooting-faqs/


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, September 15, 2017 7:39 AM
  • Hii,

    Logs, when I run Replication Link Analyzer on Central Administration Site server:

    9/15/2017 2:21:39 PM: ReplicationLinkAnalysis Information: 1 : Initializing replication link analysis engine...

    9/15/2017 2:21:39 PM: ReplicationLinkAnalysis Information: 1 : Reading SQL server and database name from the registry NTMM0WA1.ntamc.in.

    9/15/2017 2:21:39 PM: ReplicationLinkAnalysis Verbose: 1 : Reading registry key SOFTWARE\Microsoft\SMS\SQL Server\Server on NTMM0WA1.ntamc.in.

    9/15/2017 2:21:40 PM: ReplicationLinkAnalysis Verbose: 1 : Reading registry key SOFTWARE\Microsoft\SMS\SQL Server\Database Name on NTMM0WA1.ntamc.in.

    9/15/2017 2:21:40 PM: ReplicationLinkAnalysis Information: 1 : Reading SQL server and database name from the registry NTBB0WA1.ntamc.in.

    9/15/2017 2:21:40 PM: ReplicationLinkAnalysis Verbose: 1 : Reading registry key SOFTWARE\Microsoft\SMS\SQL Server\Server on NTBB0WA1.ntamc.in.

    9/15/2017 2:21:44 PM: ReplicationLinkAnalysis Error: 1 : GetRegistryKey: IOException - server NTBB0WA1.ntamc.in not found.

    9/15/2017 2:21:44 PM: ReplicationLinkAnalysis Error: 1 : Failed to read the SQL information from the registry NTBB0WA1.ntamc.in.

    9/15/2017 2:21:44 PM: ReplicationLinkAnalysis Information: 1 : Enumerating failed rules list.

    9/15/2017 2:21:44 PM: ReplicationLinkAnalysis Information: 1 : Enumerating succeeded rules list.

    9/15/2017 2:21:44 PM: ReplicationLinkAnalysis Information: 1 : Returning Executed rules.

    9/15/2017 2:21:44 PM: ReplicationLinkAnalysis Error: 1 : Failed to initialize the link analysis engine.

    9/15/2017 2:21:44 PM: ReplicationLinkAnalysis Information: 1 : Completed replication link analysis thread.

    Please help me

    • Edited by VivekPorwal Friday, September 15, 2017 9:02 AM
    Friday, September 15, 2017 9:01 AM
  • Hii,

    Logs, when I run Replication Link Analyzer on Central Administration Site server:

    9/15/2017 2:21:39 PM: ReplicationLinkAnalysis Information: 1 : Initializing replication link analysis engine...

    9/15/2017 2:21:39 PM: ReplicationLinkAnalysis Information: 1 : Reading SQL server and database name from the registry NTMM0WA1.ntamc.in.

    9/15/2017 2:21:39 PM: ReplicationLinkAnalysis Verbose: 1 : Reading registry key SOFTWARE\Microsoft\SMS\SQL Server\Server on NTMM0WA1.ntamc.in.

    9/15/2017 2:21:40 PM: ReplicationLinkAnalysis Verbose: 1 : Reading registry key SOFTWARE\Microsoft\SMS\SQL Server\Database Name on NTMM0WA1.ntamc.in.

    9/15/2017 2:21:40 PM: ReplicationLinkAnalysis Information: 1 : Reading SQL server and database name from the registry NTBB0WA1.ntamc.in.

    9/15/2017 2:21:40 PM: ReplicationLinkAnalysis Verbose: 1 : Reading registry key SOFTWARE\Microsoft\SMS\SQL Server\Server on NTBB0WA1.ntamc.in.

    9/15/2017 2:21:44 PM: ReplicationLinkAnalysis Error: 1 : GetRegistryKey: IOException - server NTBB0WA1.ntamc.in not found.

    9/15/2017 2:21:44 PM: ReplicationLinkAnalysis Error: 1 : Failed to read the SQL information from the registry NTBB0WA1.ntamc.in.

    9/15/2017 2:21:44 PM: ReplicationLinkAnalysis Information: 1 : Enumerating failed rules list.

    9/15/2017 2:21:44 PM: ReplicationLinkAnalysis Information: 1 : Enumerating succeeded rules list.

    9/15/2017 2:21:44 PM: ReplicationLinkAnalysis Information: 1 : Returning Executed rules.

    9/15/2017 2:21:44 PM: ReplicationLinkAnalysis Error: 1 : Failed to initialize the link analysis engine.

    9/15/2017 2:21:44 PM: ReplicationLinkAnalysis Information: 1 : Completed replication link analysis thread.

    Please help me

    Can any one help on the same?????
    Wednesday, September 20, 2017 7:10 AM
  • Hi, 

    from above log, we can see "Server NTBBOWA1.ntamc.in not found" thus the tool can't read the registry "Failed to read the SQL information from registry NTBBOWA1.ntamc.in".

    Double check the registry key SOFTWARE\Microsoft\SMS\SQL Server\ServerSOFTWARE\Microsoft\SMS\SQL Server\Database Name to be sure they are on the CAS server.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, September 21, 2017 9:58 AM
  • Hi Frank Dong,

    As I have checked in registry, I got below:

    HKLM\SOFTWARE\Microsoft\SMS\SQL Server on CAS site

    Database Name:  CM_CAS Site

    Server  :   NTMM0WA1.ntamc.in

    HKLM\SOFTWARE\Microsoft\SMS\SQL Server on Primary site

    Database Name:  CM_Primary Site

    Server  :   NTBB0WA1.ntamc.in

    Both systems have different server and database name.

    Thursday, September 21, 2017 10:59 AM
  • Hi, 

    then please review again the "Prerequisites to use the Replication Link Analyzer" paragraph in below link to be surethe permissions are properly applied before running the tool.

    https://docs.microsoft.com/en-us/sccm/core/servers/manage/monitor-hierarchy-and-replication-infrastructure


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, September 25, 2017 9:06 AM