locked
Exchange 2007 External email delay issue

    Question

  • Hi Experts,

    We have exchange 2007 as our mailing servers with 3 MBX and 2 server as Client access which are serving as HUB transport 1 and 2 roles respectively. Office365 ( Protection.outlook.com ) is our smart host service provider. Offlate we have noticed we are observing delays with outbound messages ranging from 5 - 25 minutes while inbound / internal ( within domain ) is absolutely fine with no delays. When done test in Office 365 for mail flow it clearly says there was an external delay prior to the message was received by Office 365.

    Initially we were thinking it might be due to network load so we have done some changes in our NW Switches and had given dedicated NW devices to HT servers but even when there is no traffic or utilization of the bandwidth there seems to be delay.

    I had done testconnectivity.microsoft.com SMTP test where it shows RDNS lookup fails, but does that really delays outgoing email as we have a Smart host provider in between ?

    Can someone really help to understand if the issue is from the Exchange side or NW side ?

    Tuesday, May 31, 2016 12:12 AM

Answers

  • Is your Outbound mail directed to Outlook.com as a smart host?  If so, you might want to open a support ticket in your portal.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Tuesday, May 31, 2016 5:35 AM
  • Hi Farhan,

    Welcome to our forum.

    In addition to Ed’s suggestion, please add RDNS for your domain, and add SPF for your domain in ISP to check if the issue persist.

    Best Regard,

    Jim Xu

    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Jim Xu
    TechNet Community Support

    Tuesday, May 31, 2016 6:40 AM
    Moderator

All replies

  • Is your Outbound mail directed to Outlook.com as a smart host?  If so, you might want to open a support ticket in your portal.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Tuesday, May 31, 2016 5:35 AM
  • Hi Farhan,

    Welcome to our forum.

    In addition to Ed’s suggestion, please add RDNS for your domain, and add SPF for your domain in ISP to check if the issue persist.

    Best Regard,

    Jim Xu

    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Jim Xu
    TechNet Community Support

    Tuesday, May 31, 2016 6:40 AM
    Moderator