App-V for TS Bluescreens Citrix Servers RRS feed

  • Question

  • Is anyone else seeing Bluescreens on Citrix servers after installing App-V for Terminal Services v4.5?  We have been running the softgrid client on our Citrix servers for years with no issues.  After installing the new client, all of our Citrix servers are crashing with the following STOP error:  0x0000008e (0xc0000005, 0x8081be86, 0xf2c3f730, 0x00000000)

    The dump debug results show:  Probably caused by cdm.sys or sftplay2K3.sys

    Thursday, January 15, 2009 1:51 PM


  • Here is a hotfix from Microsoft that includes a fix for a stop error.  I have not installed this hotfix in our environment, so I am just assuming  at this point it will address our issue.

    • Marked as answer by hockera Tuesday, February 17, 2009 5:11 PM
    Tuesday, February 17, 2009 5:11 PM

All replies

  • Can't be of much help yet. We are looking to migrate to SoftGrid 4.5 from version 3.2. (Terminal Server Farm with W2K3, Citrix MPS4) One of the reasons for this migration is that we sometimes get the EXACT same BSOD you are talking about. Our debug results show: Probably caused by sftplay.sys.

    I was hoping MS left the BSOD of the App-V client in the past when moving to App-V 4.5..
    Friday, January 16, 2009 7:19 AM
  • What version and service pack level of Windows Server are you running? Are you also running the latest version and hotfix rollup of XenApp?
    Friday, January 16, 2009 10:51 AM
  • Thanks for the replies. 

    Our Citrix servers are Windows 2003 SP2 (patches up-to-date).  We are running Presentation Server 4.5 RO2.  However, I just installed RO3 on one of them last night to see if that takes care of the issue.  Also, starting last night, two of the four servers wont even launch some of the apps.  You recieve the following: Error code: 4505CD-11D0580A-00000163, which means "This problem occurs when the SoftGrid Client performs partial GUID reads. This behavior causes GUID conflicts."

    Friday, January 16, 2009 2:07 PM
  • If you are experiencing blue screens with all of the latest service packs, updates and drivers etc and the 4.2 client works OK on your servers, I would recommend opening a case with Microsoft support. 
    Friday, January 16, 2009 4:08 PM
  • And please keep us informed of your progress so that you might help others that experience the same problem.
    Regards and good luck..

    Wednesday, January 28, 2009 3:28 PM
  • We ended up contacting Microsoft support about this issue.  We were told that Microsoft and Citrix were aware of some 'incompatibility' with running the App-V client on Citrix servers and were working together to resolve the issue.  Their recommendation was to backrev the client to v4.1.  I removed all of the App-V 4.5 clients, re-installed v4.1 client and re-sequenced the apps with v4.2 of the sequencer.  I have not had a blue screen on the Citrix servers since.  I only wish that Microsoft or Citrix would have posted their 'known issue' somewhere so I wouldn't have wasted so many hours!
    Wednesday, January 28, 2009 3:38 PM
  • Jeepers, how happy I am...

    Just planned a changed to upgrade to 4.5 + hotfix for TS with servers running Win2k3 SP1 and Citrix PS 4.5 + HFRU1.

    The test-server is of course stable, but then again its not beeing utilized except for testing of applicatio behiavour.

    Any news would of course be appreciated.....

    Thursday, January 29, 2009 11:55 AM
  • Did they happen to mention a certain Citrix version or did they just mention Citrix servers in general..?

    Thanks for keeping us updated..I'll be watching this thread as a hawk..!
    Friday, January 30, 2009 8:18 AM
  • We have access to a private hotfix from Citrix and are testing. Will let you know how we go.
    Friday, January 30, 2009 12:48 PM
  • Hello,

    Any chance if we might get more information regarding this?

    What does the hotfix apply for? Specific for HFRU2/3? (we are running HFRU1...)
    How can the BSOD be generated? Does it appear randomly during time-periods or is it generated by application launch?


    • Proposed as answer by Patrick.Paijmans Tuesday, February 10, 2009 10:21 AM
    • Unproposed as answer by hockera Tuesday, February 17, 2009 5:05 PM
    Friday, January 30, 2009 1:10 PM
  • Hello,

    We are also seeing these Bluescreens (STOP error:  0x0000008e (0xc0000005, 0x8081be86, 0xf2c3f730, 0x00000000))
    on our Citrix servers. We are on a brand new Citrix environment with windows 2003 sp2 (almost fully patched), and citrix advanced edition 4.5/5.0 + HFRU3 and App-V for Terminal Services v4.5.

    We use Wyse V10L terminals and when we browse to a USB stick connected to the Wyse V10L from a App-V application the Citrix server crashes in the above noted bleuscreen.

    I see there is a private citrix hotfix and somebody has contacted microsoft.

    Is there any news, because my users are deperate to start using their USB sticks.

    Tuesday, February 10, 2009 10:35 AM
  • I have not gotten an update from the case I opened with Microsoft.  I will call them later today for an update and post to the forum.

    Tuesday, February 10, 2009 1:03 PM
  •  I only tested against version 5.0 of Presentation Server (eh, make that XenApp).  Had no issues there.
    Thursday, February 12, 2009 12:47 PM
  • Here is a hotfix from Microsoft that includes a fix for a stop error.  I have not installed this hotfix in our environment, so I am just assuming  at this point it will address our issue.

    • Marked as answer by hockera Tuesday, February 17, 2009 5:11 PM
    Tuesday, February 17, 2009 5:11 PM
  • I tried to install this hotfix, but it didn't resolve the issue for me :(
    I am able to procreate this stop error if I fire up a SoftGrid application on our Terminal Server and try to access a mapped client drive through a browse dialog in the app.

    Monday, February 23, 2009 12:03 PM
  • Hello,

    Any chance you might post your STOP-error here aswell?

    Monday, February 23, 2009 12:08 PM
  • znack said:


    Any chance you might post your STOP-error here aswell?


    0x0000008e (0xc0000005, 0x8081c7c4, 0x9ea99730, 0x00000000)
    Monday, February 23, 2009 6:48 PM
  • I contacted Microsoft regarding this issue, they say that the issue is probably caused by a known issue in one of the drivers from Citrix (cdm.sys). For more details see: http://support.citrix.com/article/CTX119985.

    This issue has been fixed, apply Hotfix Rollup Pack 3 for Presentation Server 4.5/XenApp 5.0 2003, along with Hotfix PSE450R03W2K3034.

    I will install this hotfix tonight and report back the result. I am however fairly confident that this will fix the issue.

    • Proposed as answer by JohnDoe79 Wednesday, February 25, 2009 8:31 AM
    Wednesday, February 25, 2009 8:31 AM
  • John,

    Others who tested the hotfix report connection problems. Maybe the following link is of intrest for you.




    Wednesday, February 25, 2009 10:51 AM
  • Since we haven't upgraded out SoftGrid server to 4.5 yet, we ended up uninstalling 4.5 from our Terminal Servers and reinstalling 4.1. After doing this the servers seem to be running as normal. Haven't received the hotfix from Citrix yet, but not sure we want to install it after reading Patricks post. We will test SoftGrid 4.5 later on....

    Monday, March 2, 2009 2:04 PM
  • We have the same issues on our Citrix PS 4.5 R03 farm when we update the SoftGrid TS 4.2 Client to the Microsoft Application Virtualization 4.5 TS Client... Our CTX Servers reboot unexpectedly, and return the error code: 0x0000008e (0xc0000005, 0x80842c83, 0xa6ede730, 0x00000000) after the restart.

    I think the issue is when users access their local drives from the Citrix server (e.g. access the V: drive), after that; the unexpected reboot occurs.

    The newest Rollup Pack from App-V (R03) didn't resolve this issue.... The CU01 pack for App-V is not for the TS client.

    I have received the Hotfix PSE450R03W2K3034 from Citrix Support. And I've installed the Hotfix PSE450R03W2K3034 and PSE450R03W2K3032 both.

    I let you know if it solve the issue for us.

    Saturday, March 14, 2009 10:03 PM
  • We are seeing this situation on our PS4 environment (access client local drive from App-V enabled application) but it looks like there isn't a PS4 fix. Our Citrix guys are talking to Citrix for guidance.


    BTW App-V CU1 is available for TS, just go to MSDN or the Volume license site. Look under Servers -> Application Virtualization for Terminal Services. We haven't tried CU1 but we might just do that since we are in a tight spot.

    Wednesday, May 20, 2009 8:17 PM
  • The CITRIX Hotfixes PSE450R03W2K3032 and PSE450R03W2K3034 solved this issue for us.

    In PS 4.5 RU04 (recently released) are the fixes included too.

    We have'nt problems anymore, the invorinment is at the moment used for > 2000 users.

    This issue was not only within app-v applications, but it was there too from the Explorer... (not published through App-V).
    But always with the install of the app-v client on the server.
    Wednesday, May 20, 2009 8:23 PM
  • Ok, well it looks like Citrix does have a PS4 fix but I'm a bit out of the loop because our Citrix admins are working directly with Citrix to resolve the issue. We're going to put the fix in place Sunday and see what happens. I still have to see if our new PS5 environment will have the same issue.
    Wednesday, May 20, 2009 8:26 PM
  • I saw on the Citrix forums that 4.5 RU04 might be the better release to go with but it could depend on what your environment looks like.
    Thursday, May 21, 2009 3:46 PM
  • Hello,

    Implemented the PSC 4.5 RU04, 2003 SP2, app-v 4.5 + HFRU3. No BSODs so far, however if running a app-v publication on a client with multiple monitors the app doesn't start and only shows in taskbar.

    Thursday, May 21, 2009 3:54 PM
  • Hi,

    To solve our bleuscreen errors on Xenapp 4.5 R04, 2003 SP2, app-v 4.5 whe found a "little bug".

    People who are thinking about installing Xenapp 4.5 R04 beware there is a problem with some Wyse Thinclients.
    Whe are using Wyse V10L and while testing whe encountered the error : PSE450W2K3R04 causes connection reset by peer errors on wyse V10L
    Link : http://forums.citrix.com/thread.jspa?threadID=244712&start=0&tstart=0

    My regards,

    Patrick Paijmans
    Monday, May 25, 2009 9:44 AM
  • I should add the PS4 fix we were told to implement was rollup 6.
    Tuesday, June 2, 2009 10:24 PM
  • Wierd, our build is identical but we've tested up to 4 x 1280x1024 displays. Maybe you are on a different client?

    We're running XenApp client.
    Tuesday, June 2, 2009 10:31 PM
  • Hello,

    Yeah, we have a pretty wide-spread client usage..
    I started trouble-shooting and we had the latest on one client and... (downloaded same week from citrix.com), v8 v10.2 etc etc...
    So the issue showed itself regardless of what client version we used.

    • Edited by znack Wednesday, June 3, 2009 12:53 PM spell-check
    Wednesday, June 3, 2009 4:32 AM
  • Looks like HFRU6 is giving us no love. Luckily we only have a tiny PS4 silo running App-V 4.5 but having the odd user crash it is still not acceptable.
    Thursday, July 16, 2009 4:28 PM
  • we are having this issue with MPS 4.0 Windows 2003 and App-V 4.5 [CU1]

    It was all working fine but then after the App-V upgrade which seemed to work ok...i started to notice some random crashes...now in citrix terms we were at HotFix Rollup PSE400W2K3R02 and had had no problems...but the Citrix Forums made me believe it was because of SpeedScreen issues....so I applied the hotfix that was suppose to fix this....HotFix Rollup PSE400W2K3R06 .....of course I upgraded our license server first [so running ] - anyway this didnt fix it and it generated another issue in that InUse licenses were being reported incorrectly..so I applied the PSE400R06W2K3020 hotfix for this..which cured that problem but I am still getting the BSD..Also had to recreate the local host cache to sort out the licensing...

    After investigating memory.dmp file I found it was the citrix cdm.sys driver causing the problem , which is responsible for client drive mapping...I by now had disabled all other client mapping overrides...as printing started to concern me.

    I then started to think it must be App-V 4.5 [we did test App-V 4.5 and it worked very well so we assumed it would be fine as 4.2 had been too ] - and it must be this conflict , and hence why only happening on a few occasions....as most users wont access local discs while running App-V applications - but there must be a few who do.

    I have the Microsoft HotFix for App-V 4.5 Ts [http://support.microsoft.com/Default.aspx?kbid=961473] dated January - but is there any mileage in me applying this ? as we are already running App-V 4.5 [CU1] - will this fix the problem ?

    If not I can see 4 possible solutions, each of which will generate pain :-) - Any ideas on other solutions would be great :-)

    [1]. Disable Client Drive Mapping completely so no issue with App-V and limp along until implement either option [2] or [3]
    [2]. Upgrade current MPS 4.0 to 4.5 and apply the specific Citrix Hotfix for MPS 4.5 / XenApp and App-V 4.5
    [3]. Upgrade current MPS 4.0 to XenApp and apply the specific Citrix Hotfix for MPS 4.5 / XenApp and App-V 4.5 [although we have a dev project to go to XenApp but its a totally diff setup using XenServer etc]
    [4]. Downgrade App-V back to 4.2 - but this is a headache as u cant run 4.2 clients with 4.5 servers so we would have to also create a 4.2 App-V server.....

    ANy IDEAS ??????

    Wednesday, December 9, 2009 11:23 AM
  • Apologies...apparently [our App-V guy tells me] we went straight to App-V 4.5 ......
    Wednesday, December 9, 2009 11:26 AM
  • Hello,

    I would recommend 1 until 2 is completed, or just really push for number 3.

    See these articles;


    There are some forum threads in the citrix-forums which might be of assistance, but pushing the new version forward would probably be the best way forward.
    See this search for more discussions;

    Wednesday, December 9, 2009 11:30 AM
  • Hi,

    thanks for the quick response....Yeah so disable drive mapping...prob do this on say a couple of servers that have had a BSD [go into ICA client protocol and disable it along with the other mappings] and see if they still BSD....

    So a possibility would be to upgrade to MPS 4.5 - is this possible to do as an upgrade on each server rather than a fresh install?  and then apply the hotfix listed here http://support.citrix.com/article/ctx119985,  why arent they offering this hotfix for 4.0 - I know support finished in June and product is end of life end of Dec but surely its a bit naughty to just do this?

    I know going to XenApp is the way forward but this is going to be done long term using a XenServer infrastructure..so I dont want to do a quick fix now and say upgrade what we have to XenApp and then redo it again to run under XenServer if that makes sense.

    I suspect best option is to disable mapping and live with it while we get the XenServer project moving....unless the upgrade to 4.5 is easy enough to do ?


    Wednesday, December 9, 2009 12:32 PM
  • What concerns me is I dont seem to be able to recreate this issue myself...so I am wondering is it an issue with users who have an older version of the ICA client , or even using Java client...I am using Citrix XenApp Web Plugin .....wonder if version 9 of clients are having this issue ?
    Wednesday, December 9, 2009 12:33 PM
  • Hello,

    Well, you could try to upgrade the client if you have positive results.

    I would think that they discontinue support is having the intended effect, forcing you to upgrade (but also not having to spend time on products that are old )

    For a Xenapp / 4.5 upgrade, check the citrix-forums / documentation.

    Wednesday, December 9, 2009 1:46 PM
  • I would probably be better off having to upgrade to 4.5 first.....what I want to know is does this hotfix actually fix the problem


    So would  upgrade the license server first . Then I would make sure my license files were up to date. You can do this by returning and reallocating them.

    I would upgrade Data Collectors and Farm Metric servers first. Then I would upgrade the remaining farm member servers. Make sure to look at the hotfixes and rollup packs as
    well - as above.

    And this should work right

    and defo best to do with NO users on the system at all..

    Any mileage in stopping the IMA service on all servers and then doing them one by one so to speak and firing them up?

    Wednesday, December 9, 2009 2:53 PM
  • Well, upgrading Presentation Server 4 to 4.5 (called XenApp 5.0 now) should not be done "...by the way".

    Especially if you know that you are going to upgrade the infrastructure "soon" you should not perform an helter-skelter update right now, because you could face new issues - and downgrading an upgraded Citrix environment essentially means restoring complete machine and database backups...

    Besides that, the proposed order of upgrading the Citrix Servers sounds right. You should make sure that you have a vaild Subscription (Software Assurance) and that this is represented by your license files.

    Remember that upgrading your first server to PS4.5/XA5 also upgrades the Farm Database. During Upgrade you are potentially not able to publish new applications nor configure printers, you have to use the right management consoles (versions!) to connect to the right servers... nothing I'd do on a Friday morning because potentially it'll destroy my weekend.

    Anyway this is going to be off-topic since we still are in a MS forum here. For the upgrading you may refer to a Citrix forum or you may PM some of the guys here that surely have profund Citrix experience (I know that almost every "MVP" here knows Citrix best...)

    Wednesday, December 9, 2009 8:18 PM