locked
Windows 7 Explorer Drag & Drop doesn't work under any conditions! RRS feed

  • Question

  • Problem: Drag and Drop doesn't work in Windows 7 Explorer. Whenever I try to drag an icon, the circle with a line through it always shows.

    I've read scores and scores of posts describing how to fix this issue, and I've found the following set of things to try. But I've tried every one of them, but nothing helps.

    The problem DOES occur even in Clean Boot and Safe Mode!

    I've tried the following:

    (1): I'd already completely disabled UAC (registry confirms this) - makes no difference.
    (2): Hold left-click & press escape - doesn't work.
    (3): Hold right-click & press escape - doesn't work.
    (4): Ctrl-Alt-Del & press escape - doesn't work.
    (5): Confirmed no keys are stuck on my keyboard.
    (6): First disable "Enable context menus and dragging and dropping", then reboot, then re-enable it, then reboot - doesn't work.
    (7): Uninstalled mouse and keyboard drivers, then reboot - doesn't work!
    (8): Ran SFC /SCANNOW - reported NO integrity or other problems.
    (9): Ran Avia & SpyBot & MBAM - all reported NO malware.

    I've examined the Drag & Drop handlers in ShellExView, and found nothing unusual.  I have tried disabling them all, but makes no difference.

    Since it is often asked what I had done prior to experiencing this problem, my answer is: I made a clone backup of my system partition to another disk.

    System details: Windows 7 Professional 64-bit (Installed one week ago) - Hardware: Z87-A Mobo / Intel i7-4770K CPU / 16GB RAM / RAID 0 MBR system disk

    I am desperate for assistance, please!

    Saturday, March 1, 2014 6:21 AM

Answers

  • Did you try a clean boot?

    And does this works in safe mode or only a problem in normal Windows Mode?


    Arnav Sharma | http://arnavsharma.net/ Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by arnavsharma Wednesday, June 7, 2017 1:33 AM
    Saturday, March 1, 2014 7:03 AM

All replies

  • Did you try a clean boot?

    And does this works in safe mode or only a problem in normal Windows Mode?


    Arnav Sharma | http://arnavsharma.net/ Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by arnavsharma Wednesday, June 7, 2017 1:33 AM
    Saturday, March 1, 2014 7:03 AM
  • Did you try a clean boot?

    And does this works in safe mode or only a problem in normal Windows Mode?


    Arnav Sharma | http://arnavsharma.net/ Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thank you for your reply!

    The answer to your question is Yes, I tried it in Safe Mode and it does NOT work there either.  (Please note that I made sure to say this in my OP, where I wrote: "The problem DOES occur even in Clean Boot and Safe Mode!").

    I hope you can help!



    Saturday, March 1, 2014 8:29 AM
  • checked this?

    http://it.thelibrarie.com/weblog/2010/06/drag-and-drop-stops-working/


    Arnav Sharma | http://arnavsharma.net/ Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Saturday, March 1, 2014 4:45 PM
  • I appreciate your reply, but with respect, may I ask you to read my OP more carefully?

    The link you provided me in your last reply suggests trying two things I not only have already repeatedly tried but have already listed AS being already tried in my OP.  The link suggests (a): pressing the escape key (see items 2, 3 & 4 in my OP), or (b): Rebooting (see items 6 & 7 in my OP).  And naturally I tried pressing esc and rebooting dozens of other times.

    I need more than what I've already tried, please.  For example, is there a key in the registry that controls Explorer drag & drop?  A setting that prohibits it or something akin to that?


    Sunday, March 2, 2014 4:46 AM
  • Hope you've not checked this :

    http://answers.microsoft.com/en-us/windows/forum/windows_7-performance/can-you-turn-off-drag-and-drop-in-windows-7/81804779-a061-e011-8dfc-68b599b31bf5

    I dont think we have registry keys for the exact issue.


    Arnav Sharma | http://arnavsharma.net/ Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Sunday, March 2, 2014 2:15 PM
  • Thanks for finding something I haven't already tried.  It is appreciated.

    Unfortunately, those registry values are set correctly to the default: 4 pixels.

    But Drag & Drop still won't work.

    This is incredibly frustrating!

    I suppose I'll just have to bite the bullet and perform a Win 7 Repair Install...

    Tuesday, March 4, 2014 3:30 AM