locked
Branchcache in hosted cache mode RRS feed

  • Question

  • I have set up BranchCache in hosted cache mode.

    Followed the BranchCache Deployment Guide to install the content server and hosted cache server and the test clients.

    When i take of a test file of 30 mb of the fileserver, its not being cached, not on the clients and not on the hosted cache server

     

    config details

    hosted cache server:

    BranchCache Service Status:
    ------------------------------------------------------------------------
    Service Mode          = Hosted Cache Server
    Client Authentication = No Authentication
    Current Status        = Running
    Service Start Type    = Automatic
    This machine is currently configured as a hosted cache server.

    Local Cache Status:
    ------------------------------------------------------------------------
    Maximum Cache Size        = 5% of hard disk
    Active Current Cache Size = 0 Bytes
    Local Cache Location      = C:\Windows\ServiceProfiles\NetworkService\Ap
    cal\PeerDistRepub (Default)


    Publication Cache Status:
    ------------------------------------------------------------------------
    Maximum Cache Size         = 1% of hard disk
    Active Current Cache Size  = 0 Bytes
    Publication Cache Location = C:\Windows\ServiceProfiles\NetworkService\A
    ocal\PeerDistPub (Default)


    Networking Status:
    ------------------------------------------------------------------------
    Content Retrieval URL Reservation          = Configured (Required)
    Hosted Cache URL Reservation               = Configured (Required)
    SSL Certificate Bound To Hosted Cache Port = Configured (Required)
    Content Retrieval Firewall Rules           = Enabled    (Required)
    Peer Discovery Firewall Rules              = Disabled   (Not Required)
    Hosted Cache Server Firewall Rules         = Enabled    (Required)
    Hosted Cache Client Firewall Rules         = Enabled    (Not Required)

     

    clients:


    BranchCache Service Status:
    -------------------------------------------------------------------------------
    Service Mode          = Hosted Cache Client
    Current Status        = Running
    Service Start Type    = Automatic
    Hosted Cache Location = iss101DC1.incaiss.be


    Local Cache Status:
    -------------------------------------------------------------------------------
    Maximum Cache Size        = 5% of hard disk
    Active Current Cache Size = 0 Bytes
    Local Cache Location      = C:\Windows\ServiceProfiles\NetworkService\AppData\Lo
    cal\PeerDistRepub (Default)


    Publication Cache Status:
    -------------------------------------------------------------------------------
    Maximum Cache Size         = 1% of hard disk
    Active Current Cache Size  = 0 Bytes
    Publication Cache Location = C:\Windows\ServiceProfiles\NetworkService\AppData\L
    ocal\PeerDistPub (Default)


    Networking Status:
    -------------------------------------------------------------------------------
    Content Retrieval URL Reservation          = Configured     (Required)
    Hosted Cache URL Reservation               = Configured     (Not Required)
    SSL Certificate Bound To Hosted Cache Port = Not Configured (Not Required)
    Content Retrieval Firewall Rules           = Enabled        (Required)
    Peer Discovery Firewall Rules              = Disabled       (Not Required)
    Hosted Cache Server Firewall Rules         = Disabled       (Not Required)
    Hosted Cache Client Firewall Rules         = Enabled        (Required)

    anyone an idea how to troubleshoot further or what could be the problem?

    thanks in advance

    Wednesday, June 1, 2011 11:49 AM

All replies

  • Hi Customer,

     

    Thank you for your post.

     

    > When i take of a test file of 30 mb of the fileserver, its not being cached, not on the clients and not on the hosted cache server

     

    Please ensure that the file is not in the transparent cache. Transparent cache is a secondary cache where the file is stored in addition to the BranchCache. Storing the file in the transparent cache enables subsequent reads of the file to be satisfied locally improving end-user response times and savings on WAN bandwidth. To delete transparently cached data, search for Offline Files applet in Control Panel. Click the Disk Usage tab, and then click Delete Temporary Files. Note that this will not clear the BranchCache cache.

     

    Meanwhile, when your attempting to access a file share, please verify that the latency between the client and server is higher than the minimum threshold. By default, the value is 80 milliseconds. Please set this value to 0 on your test client and force BranchCache for network files to be turned on all the time and test again.

     

    1.Open the Group Policy Management Console. Click Start, point to Administrative Tools, and click Group Policy Management Console.

    2. Locate the GPO created previously for BranchCache. Right-click the GPO and choose Edit.

    3.Click Computer Configuration, point to Policies, Administrative Templates: Policy definitions (ADMX files) retrieved from the local machine, Network and click BranchCache.

    4.Double click Configure BranchCache for network files.

    5.Select the radio button next to Enabled.

    6.In the Options window, enter 0.

    7.Click OK.

     

    If your problem still exits, please take a look at your event logs from "Applications and services Logs\Microsoft\Windows\PeerDist\Operational". If there have any error log on your client, please post it here.

     

    Best Regards,

    James Zou

    Thursday, June 2, 2011 9:46 AM
  • Hello James,

    Cleaned the transparent cache, but it was empty already.

    Latency I already configured to 0, GPO was also already configured with the right values + firewall settings are reporting configured correct also.

    looked in the logs on the clients, under "Applications and services Logs\Microsoft\window\BranchCache\Operational" , I assume it's this one, also look at BranchCacheSMB\Operational logs, no errors reported

    taken from the Operational logs of BranchCacheSMB:

     
    - CounterSummary
       
      ServiceActiveTimeInSeconds 3594
       
      SMBBranchCacheBytesRequested 0
       
      SMBBranchCacheBytesReceived 0
       
      SMBBranchCacheBytesPublished 0
       
      SMBBranchCacheBytesRequestedFromServer 0
       
      SMBBranchCacheHashesRequested 0
       
      SMBBranchCacheHashesReceived 0
       
      SMBBranchCacheHashBytesReceived 0
       
      PrefetchOperationsQueued 0
       
      PrefetchBytesReadFromCache 0
       
      PrefetchBytesReadFromServer 0
       
      ApplicationBytesReadFromCache 0
       
      ApplicationBytesReadFromServer 0
       
      ApplicationBytesReadFromServerNotCached 0

    Best regards

    Jim



    Monday, June 6, 2011 7:48 AM
  • Jim:

    I see no references to your BranchCache content server.  Please confirm that the content server has been configured appropriately.  If your setup is still not working, please forward the configuration details for the content server.

    References to setting up a content server:

    http://technet.microsoft.com/en-us/library/ee649147(WS.10).aspx

    http://social.technet.microsoft.com/wiki/contents/articles/2342.aspx

    Sorry for the late response.

    Thanks.

    • Proposed as answer by James McIllece Wednesday, December 28, 2011 6:29 PM
    Tuesday, November 8, 2011 1:37 AM