locked
email notification problem on the scsm additional server RRS feed

  • Question

  • Hi all :)

    we have a SCSM management server with some OS issues, i have been asked to install additional SCSM management server and remove the old one, so i prepared another server and i did install a SCSM management server role on that server (in the installation wizard i did point to the Service manager DB from the old server) then the installation has been completed successfully and the new server shows the exact same data as the old one, i have also promoted the new server to be the main server, when i shutdown the old server the new server works fine but the outbound emails notification doesn't work for some reason, i have tested sending an email via telnet using the SCSM workflow account and it works fine !! , any one can help me please ???

    thank u ...

    Tuesday, April 28, 2015 12:21 PM

All replies

  • Hi,

    have you tried recreating the notification channel and choosing a different option for the authentication type?
    I would recommend you reading a blog post about dealing with multiple management servers. There is a part about decommissioning old management servers. May be you have missed something on the way?

    Part 3/3: Decommission old Management Servers (this post)
    http://marcelzehner.ch/2012/08/01/dealing-with-multiple-management-servers-33-decommission-old-management-servers/

    Regards,

    Stoyan


    Tuesday, April 28, 2015 12:38 PM
  • thank u stoyan :)

    i have made the Decommission process, i have deleted the SMTP server and reconfigured the channel with a different authentication type (windows integrated) and also didn't work,  any other suggestions ??

    thank u

    Tuesday, April 28, 2015 1:50 PM
  • Hi Mohammed,

    it surely sounds like strange issue, especially when you have tested outbound mail notifications, using telnet and it worked fine.
    Please check the Event Logs on the new management server, when the old one is not running. Are there any related events under the "Application" log?

    Regards,

    Stoyan

    Tuesday, April 28, 2015 2:26 PM
  • yes there is three errors :

    1- [source: MSSQLSERVER - event ID: 18054] Error 777980050, severity 16, state 1 was raised, but no message with that error number was found in sys.messages. If error is larger than 50000, make sure the user-defined message is added using sp_addmessage.

    2- [source: Security-SPP - event ID: 8198] License Activation (slui.exe) failed with the following error code:
    hr=0xC004F074
    Command-line arguments:
    RuleId=eeba1977-569e-4571-b639-7623d8bfecc0;Action=AutoActivate;AppId=55c92734-d682-4d71-983e-d6ec3f16059f;SkuId=f0f5ec41-0d55-4732-af02-440a44a3cf0f;NotificationInterval=1440;Trigger=UserLogon;SessionId=2

    3- [source: ESENT - event ID: 455] msmdsrv (1748) Error -1032 (0xfffffbf8) occurred while opening logfile C:\Windows\system32\LogFiles\Sum\Api.log.

    Tuesday, April 28, 2015 3:05 PM
  • Hmmm, it gets weirder and weirder. So if those are all the events you found, then we cannot tell much based on them. I don't think, that any of the errors above are related to the problem.
    According to the below given post the issue can be with the System Center Management Configuration service. Have you checked all the relevant services on the new mgmt. server:

    https://social.technet.microsoft.com/Forums/systemcenter/en-US/ae851640-d925-4960-a402-10120905165c/email-notifications-not-working-scsm

    Tuesday, April 28, 2015 3:58 PM
  • yes i have checked all the cases mentioned in this link too from before but still it doesn't work !!
    Tuesday, April 28, 2015 4:20 PM
  • The Primary management server is also the workflow server. Workflows will only run on this server. Are the workflows running ok when you promote the New management server to Primary?
    Tuesday, April 28, 2015 8:40 PM
  • thank u

    is there a way to make the new server the workflow server ?

    when we did promote the new server the workflows or the email notifications are not working,

    Wednesday, April 29, 2015 8:34 AM
  • Hi Mohammed,

    you can make the new server a workflow server by following the guide under Step 1 - Reconfigure the Workflow Server, from the article I posted:

    http://marcelzehner.ch/2012/08/01/dealing-with-multiple-management-servers-33-decommission-old-management-servers/

    but you said, that you have already done it, so your new server has to be the workflow server. This you can check again with the query:

    select DisplayName, [PrincipalName] from [MTV_Computer]

    where [BaseManagedEntityId]=

    (SELECT ScopedInstanceId

    FROM dbo.[ScopedInstanceTargetClass]

    WHERE [ManagedTypeId] = dbo.fn_ManagedTypeId_MicrosoftSystemCenterWorkflowTarget()

    )

    Is this the case?

    Regards,

    Stoyan

    Wednesday, April 29, 2015 9:17 AM
  • I suspect that you might be missing the workflow assembly files, which are DLL files in the SCSM installation folder on the old Workflow server. Copy any missing DLL files over to the new workflow server and restart the services:

    System Center Data Access Service

    • System Center Management

      You can monitor the workflows and check for success/failure in the Console (Administration->Workflows->Status).

    Wednesday, April 29, 2015 9:22 AM
  • @stoyan: i made the query and the result was the new SCSM server name

    @ morten: i have checked all the dll files in the old server and the new server but they are exactly the same !!, could it be that some files are corrupted ? if so then can you please tell me which files are responsible for the workflow processes ?

    Thank u all for the support :)

    Wednesday, April 29, 2015 11:48 AM
  • You can look up the workflow with the same name as the Subscription under Administration->Workflows->Status. See if you can get any Clues when looking at the two tabs (Need attention and All instances) for those workflows.
    Wednesday, April 29, 2015 12:02 PM