none
Symantec Endpoint Protection failing to install via MDT, installs manually RRS feed

  • Question

  • I'm trying to install Symantec Endpoint Protection Agent 12.1.6 MP7 on Windows 10 Pro.

    While installing through MDT, Windows 10 pops up and says "Symantec Endpoint Protection doesn't work on this version of Windows.  I have verified that this version of Symantec is compatible with Windows 10.

    Also, if I install the software manually using the same commands it works fine.

    I'm not sure where to begin troubleshooting this, is it a known issue?

    Monday, March 6, 2017 8:33 PM

All replies

  • Take a look at the MSI log for the application install.

    Many questions such as where do I find logs and what logs are interesting are found in: MDT TechNet Forum - FAQ & Getting Started Guide Please take the time to read it. Also if you don't post logs your problem won't be easily solved.

    Tuesday, March 7, 2017 2:40 AM
    Moderator
  • I have been installing symantec via MDT for the past 7 years... Are you using the single file exe or extracting the files? What is your command line? Seems like a packaging issue versus MDT issue!
    Tuesday, March 7, 2017 12:32 PM
  • The single file exe which was generated from the Symantec server.

    Not sure what kind of packaging issue it could be if it installs manually, or what I should do to fix it.


    Tuesday, March 7, 2017 2:24 PM
  • What is the command line you use? Also what order does this install-meaning is it first or last or in between installs of another application? Remember windows can only install one MSI action at a time and it must wait for one to finish before executing another one.. I have had issues with this many times before...
    Tuesday, March 7, 2017 2:32 PM
  • Simply "setup.exe /s"

    I've tried moving it to first, last, and in between but it doesn't help.  Also, the error message is from Windows 10 saying it won't install due to a compatibility issue so I don't think it's an issue with the task sequence.

    Tuesday, March 7, 2017 3:07 PM
  • RIGHT! What version of windows are you deploying? 1507, 1511 or 1601?
    Tuesday, March 7, 2017 3:08 PM
  • Version 1607
    Tuesday, March 7, 2017 3:41 PM
  • Is there anyway you can upload MDT and/or Symantec log files?
    Tuesday, March 7, 2017 4:08 PM
  • The MDT log file says it installed successfully.  Not sure where to find the Symantec log on the actual machine though.
    Tuesday, March 7, 2017 4:39 PM
  • GO here and see the logs for symantec

    https://support.symantec.com/en_US/article.TECH164067.html

    Thursday, March 9, 2017 12:54 PM
  • I had this issue and the fix for me was:

    go to the application object in MDT and double-click to open. Select the Details tab and verify that either "This can run on any platform" option is selected OR the applicable OS is selected under "This can run only on the specified platforms" option.


    Thanx
    SteveInOregon
    "Never never doubt what nobody is sure about." -Willy Wonka



    Tuesday, November 13, 2018 9:23 PM
  • Make sure your application matches the architecture of the OS, x64 or x86. The log will show success as long as the application install end with a success code. It will say success if it runs through its installation process and does not install if the architecture is wrong. I am assuming the architecture match since you say you can install manually.

    A simple way to test the install is to remove the "/s" from the install command. When it comes to that point in the task sequence it will wait until you click through and maybe error at some point.

    Wednesday, November 14, 2018 3:36 PM