locked
Exchange POP, IMAP and OWA Monitor not working RRS feed

  • Question

  • Hello

    I've loaded the Exchange 2007 MP for SCOM R2 and installed the agents on the Exchange Servers too. Now the monitoring of our Exchange infrastructure works quite fine. But the connectivity monitors for IMAP, POP and OWA (internal and external) don't work. Those for ActiveSync and the Webservices are ok.

    I configured these monitors using the Exchange MP wizards. I also created the Test Users on each Mailbox-Servers with the given PS-Script. The users exist and their mailbox is also initialized.

     

    Here some information about our servers:

    - The CAS role is installed on 3 servers which are run in NLB (Windows Network Load Balancing)
    - 2 other servers are executing the Hub/Transport role
    - and at least the 6 mailbox servers

    I've read something on the internet about issues with NLB and IMAP/POP/OWA Monitoring. But I'm not sure wheter this info is true. Then why should the ActiveSync Monitoring work and the OWA doesn't? They both communicate via HTTPS, right?

     

    Here the errors i get in SCOM:

    IMAP

    State Change Event

    Context:

     

    Date and Time: 09.07.2010 10:33:06
    Property Name Property Value
    State Error
    Message System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it 172.16.x.x:993 - IMAP4 connectivity transaction has failed. Detailed information: Target: mx03.campus.intern| Error: System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it 172.16.x.x:993 -------------------------------------

     

    --> Why does SCOM establish the connection via the second network interface? Of course this can't work because Exchange only listens on the main NIC (the second one is used for data backup).

     

    POP

    State Change Event

    Context:

     

    Date and Time: 16.06.2010 14:31:53
    Property Name Property Value
    State Error
    Message System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it 172.16.x.x:995 - POP3 connectivity transaction has failed. Detailed information: Target: mx02.campus.intern| Error: System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it 172.16.x.x:995 -------------------------------------

     

    --> Same here, why does it use the backup interface? Any way to change it? Or does he use automatically the second interface, because the primary is in NLB?

     

    OWA (internal and external)

     

    Context:

     

    Date and Time: 06.07.2010 10:45:51
    Property Name Property Value
    State Error
    Message The operation failed because there was no response after 60 seconds. - One or more of the Outlook Web Access Connectivity tests failed. Additional information: ------------------------------------- Target: mx01.campus.intern|mx10.campus.intern Error: The operation failed because there was no response after 60 seconds. -------------------------------------


    or

    State Change Event

    Context:
     

     

    Date and Time: 16.06.2010 14:43:32
    Property Name Property Value
    State Error
    Message The test received an unexpected response to an Outlook Web Access request. URL: https://webmail.xxx.ch/owa/ - One or more of the Outlook Web Access Connectivity tests failed. Additional information: ------------------------------------- Target: mx03.campus.intern|mx10.campus.intern Error: The test received an unexpected response to an Outlook Web Access request. URL: https://webmail.xxx.ch/owa/ -------------------------------------

     

     

    I also executed the Test-PS Scripts on the Exchange Servers manually - no success. Therefore I think there must be something with this NLB - SCOM combination. But why does Active Sync work?!?

    Thank you all in advance for any hints or suggestions.

    Cheers
    Reto

    Friday, July 9, 2010 9:14 AM

Answers

  • I agree Mike on the host records, check there, but check the network card binding order. Your secondary nic may actually be listed first. To do this do the following:

     

    1. Open Network Adapters control panel applet.

    2. Press alt key to display menu and select advanced ... then advanced settings.

    3. Check the binding order to see if the network cards are in the correct order. Your public nic should be at the top of the list, with any others below it.

     


     Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, July 22, 2010 6:58 AM

All replies

  • My hunch here is that you have two A records registered for the same DNS name 
    addresses (probably resulting in a round robin or possibly netmask
    ordering setup where the 172.16 address is being resolved part or all of
    the time), I would recommend changing the records to have the one
    involved in NLB has the same name and the 172.16.x.x interface be
    something like mx02-priv.campus.intern or mx02-back.campus.intern.
    Otherwise, you could configure the HOSTS file of the SCOM server to
    resolve the system with the correct IP.
     
    Can you confirm this as a DNS issue by running an nslookup on the SCOM
    server seeing what the name resolves to?
     

    -- Mike Burr
    • Edited by Mike Burr Thursday, July 15, 2010 9:13 PM typo
    Wednesday, July 14, 2010 9:12 PM
  • I agree Mike on the host records, check there, but check the network card binding order. Your secondary nic may actually be listed first. To do this do the following:

     

    1. Open Network Adapters control panel applet.

    2. Press alt key to display menu and select advanced ... then advanced settings.

    3. Check the binding order to see if the network cards are in the correct order. Your public nic should be at the top of the list, with any others below it.

     


     Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, July 22, 2010 6:58 AM