none
SBS vs iPhone & iPAD, Calendar sync problems

    Question

  • Dear all,

    I noticed that SBS2008 seems to have a problem when syncing Calendar with iPhone & iPAD. SBS2008 is patched up to date. iPhone & iPAD were purchased a few months ago. Emails sync works fine.

    The problem is the Calendar sync and here are what I see
    - If I create an appointment from Outlook (by the way, it is Outlook 2007), the appointment will show up on both iPhone & iPAD in seconds, which is good
    - If I make a change with the appointment on Outlook, the change will show up on both iPhone & iPAD in seconds, which is good
    - If I make a change with the appointment on either iPhone or iPAD, the change will NOT show up on Outlook. It will NOT show up on the other Apple device either
    - If I delete the appointment on either iPhone or iPAD, the appointment will be deleted from Outlook, BUT not on the other Apple device
    - If I create an appointment, either on iPhone or iPAD, the new appointment will NOT show up on Outlook. It will NOT show up on the other Apple device either

    It seems to me that syncing Calendar from Outlook to iPhone & iPAD is fine, but not the other way around.

    Any thought, idea?

    Thanks

    Jack

    Wednesday, December 15, 2010 9:40 PM

Answers

  • The problem seems to be fixed by KB830836

    After further troubleshooting, I noticed that the problem may not be related to iPhone and iPAD
    Reason#1: I setup his account with my Windows Mobile SmartPhone, I got the same problem
    Reason#2: I login OWA using his account, created a new appointment, I could not save the appointment and got an error.

    When the problem occurred, the following errors were always logged in App Log
    - 9646, MSExchangeIS | 8230, 8206, 8213, 8199 EXCDO

    When digging into 9646, I found KB830836 which applies to Exchange2003 only. However, the described symtoms in the KB is very much like my problem, I deployed the solution without much hesitation. All seems to be fine now.

    Here is the solution:

    To resolve this issue, follow these steps:

    1. On the Exchange 2003 computer, click Start, click Run, type regedit in the Open box, and then click OK.
    2. Locate and then click the following registry key:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem
    3. On the Edit menu, point to New, and then click Key.
    4. Type MaxObjsPerMapiSession, and then press ENTER.
    5. For each object type that is listed in the event ID 9646 message (in the "Symptoms" section of this article, the example object types are objtMessage and objtAttachment), follow these steps:
      1. On the Edit menu, point to New, and then click DWORD Value.
      2. Type the object name (for example, type objtMessage), and then press ENTER.
      3. Press ENTER again to open the Edit DWORD Value dialog box, type 500 in the Value data box, and then click OK.
    6. Close Registry Editor.

     

    Thank you all again for all the effort!

    Jack

     

     

     

     

     

    Sunday, December 19, 2010 1:23 PM

All replies

  • As I understand it this is an issue with Apple's implementation of
    Activesync.  I'll see if I can find the threads where this has been
    reported.
     
    Wednesday, December 15, 2010 11:53 PM
    Moderator

  • The client claimed that he did not see the problem at all with SBS2003 R2, which was just replaced (not migrated) by SBS2008 a few days ago. He said that he had this problem after the upgrade.

    SBS2008 has a third party certificate while SBS2003 used a self-signed one. SBS2008 has a different local domain name from the one that was used by SBS2003.

    But I do not think the above changes were the cause of the problem, because I have removed and recreated his exchange account on both iPhone and iPAD successfully. and emails are working fine.

    I also rebooted the Apple devices a few times, still no joy.

    It looks like the problem has something to do with Exchange 2007, not Apple.

     

    Thursday, December 16, 2010 2:15 AM
  • Run the Activesync test from https://testexchangeconnectivity.com and see if everything works OK.

     


    Regards, Boon Tee - PowerBiz Solutions, Australia
    Thursday, December 16, 2010 7:54 AM
  • It's probably not Apple's fault.

    I configured another user account (in the same domain) on iPhone, Calendar sync worked fine. I did not see the mentioned problems at all. It seems the problems only happen with the particular user's mailbox

    Thursday, December 16, 2010 11:19 AM
  • Already tried. everything works well.

    New findings on this problem

    - wheneven I added a calendar event from iPhone, a few errors would be logged immediately on SBS

    MSExchangeIS (9646), EXCDO(8230, 8206, 8213, 8199)

    - if I configured iPhone with a different user account in the same domain, no errors would be logged and Calendar sync worked well

    I will be looking into this in further, I think I am very close to the solution

    Thanks for all the help

    jack

     

     

    Thursday, December 16, 2010 11:29 AM
  • Is the user account quite large - ie. many objects (folders, emails, etc)?

     


    Regards, Boon Tee - PowerBiz Solutions, Australia
    Thursday, December 16, 2010 11:57 AM
  • His mailbox is only 1.5Gb or so. He does have "many" items in Calendar. However, Calendar sync worked with SBS2003.

     

    Friday, December 17, 2010 4:08 AM
  • You said you had removed and recreated the accounts on his ipad and iphone, did you remove the devices from his exchange profile?

    What you can try is to remove the account from the ipad and iphone, then log into OWA and remove the device profiles from his exchange account. Under options and mobile devices.


    Roman
    Friday, December 17, 2010 2:43 PM
  • The problem seems to be fixed by KB830836

    After further troubleshooting, I noticed that the problem may not be related to iPhone and iPAD
    Reason#1: I setup his account with my Windows Mobile SmartPhone, I got the same problem
    Reason#2: I login OWA using his account, created a new appointment, I could not save the appointment and got an error.

    When the problem occurred, the following errors were always logged in App Log
    - 9646, MSExchangeIS | 8230, 8206, 8213, 8199 EXCDO

    When digging into 9646, I found KB830836 which applies to Exchange2003 only. However, the described symtoms in the KB is very much like my problem, I deployed the solution without much hesitation. All seems to be fine now.

    Here is the solution:

    To resolve this issue, follow these steps:

    1. On the Exchange 2003 computer, click Start, click Run, type regedit in the Open box, and then click OK.
    2. Locate and then click the following registry key:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem
    3. On the Edit menu, point to New, and then click Key.
    4. Type MaxObjsPerMapiSession, and then press ENTER.
    5. For each object type that is listed in the event ID 9646 message (in the "Symptoms" section of this article, the example object types are objtMessage and objtAttachment), follow these steps:
      1. On the Edit menu, point to New, and then click DWORD Value.
      2. Type the object name (for example, type objtMessage), and then press ENTER.
      3. Press ENTER again to open the Edit DWORD Value dialog box, type 500 in the Value data box, and then click OK.
    6. Close Registry Editor.

     

    Thank you all again for all the effort!

    Jack

     

     

     

     

     

    Sunday, December 19, 2010 1:23 PM