none
Storage Spaces Inacessible, possibly corrupt metadata (please help..!) RRS feed

  • Question

  • TL:DR - The issue: A 3-disk simple Storage Space pool using is Inaccessible.. So now I cannot access 10TB+ of files, which around 1TB is incredibly important.. I am experienced with handling HDDs and have some RAID knowhow, but this is my first and only experience with Windows Storage Spaces.. I have never made any other pools before.. If anyone has any insight please do help! I would really appreciate any info on this.. Thanks in advance!

    (simple, no resiliency;I know, be gentle with me… because this pool was supposed to only  be used temporarily)

    The system & additional info:

    Windows 10 Pro 1909 Build 18363.628

    Disks are three similar/same 4TB WD REDs connected via my desktop motherboard SATA. These disks were only ever used for this storage space pool since they were brand new.. The pool was an old pool (ReFS, not NTFS) created a few years ago, used for around 1.5yr then system was in cold storage for 2 years.

    How we got here:

    I needed a large space to move and merge data off a bunch of external HDDs then move the data to my NAS, so I decided to use an old pool of mine. I never had much confidence in software RAID like Storage Spaces but decided this pool should hold up for a while.. Things had been going well; I managed to move ALL the data off the external HDDs to the pool, which occupies about 10.5TBs on the pool.. During the process of sorting the data… This happened: 1. The 3-disk (let’s call them A, B & C) simple Storage Space Pool using is suddenly becoming very slow (KB/s, not MB/s transfer speed), task manager would sometimes show pool disk usage at 100% when pool is accessed and this could last a while, slowing down the entire system and making transfers come to a complete stop. 

    2. Then I found that one of the disks had a yellow “warning” in Storage spaces Manager, the only option available is to delete the pool (clicking the “Change settings” button does nothing). At this point I tried to move all the data off the pool to a new 8TB WD RED connected via SATA, but transferring was so slow and intermittent (see point 1), and couldn’t practically move the data to the new HDD. I had a feeling one of the disks in the pool had bad sectors.. Further analysis confirmed this; disk C had a few bad sectors, which I tried repairing in windows error checking > “repair this drive” which would not run at all, I assume because the pool is ReFS..

    3. I shut down the system and scanned all 3 disks on a different computer, each one would be detected OK, and ran chkdsk/R and then ran HDD Regenerator for each of the disks, results were; disk A was perfect, disk B was good (had one repairable bad sector), and disk C had about 3000 bad sectors which were mostly repaired, did about 10 passes, last scan only showed 8 bad sectors which were also repaired.

    4. Reattached the disks back to the original computer and now the Storage Spaces pool is not showing up in explorer and Storage Spaces Manager shows that the pool is inaccessible; Disk B & C now has red “error”, which I believe is the standard status for a missing disk; which is confusing. Disks B & C would show up in task manager and disk management (they wouldn’t before when they were part of the pool). So the disks DO show in Storage Space Management (plugging in the disks show that’s  it is “connected via SATA” & red “error”, and unplugging it shows nothing and a yellow “warning”), the disks also show in disk management & task manager. If I connect the disks one at a time; only when disk A is connected, would Storage Space Management show the pool. Connecting disk B or C alone would show no pool in Storage Space Management; so I’m taking a guess that some metadata files for the pool on disk B and C is corrupted or lost..

    5. Tried attaching all 3 drives of this pool to 2 different computers and the results were the same; still Inaccessible.. Also tried recovering data with multiple data recovery software to no success; maybe because the disks are formatted in ReFS..

    What do I do now:

    So now I cannot access 10TB+ of files, which I guess around 1-2TB is incredibly important.. Please HELP!


    Sunday, April 5, 2020 10:15 AM

All replies