locked
Publishing RemoteApps + User Assignment RRS feed

  • Question

  • Hello,
    I am running a single server UAG setup with one https trunk. I have an Remote Apps server running and want to publish the apps with UAG.
    Every RemoteApp had his own security group configured on it, the reason for this is that not every user is allowed to start certain Remoteapps.

    I am exporting the remote App settings and imported the tspub file on the UAG and did select all RemoteApps in the application creation.
    The problem i am facing with deploying the RemoteApps with UAG is that the security rights configured on the RemoteApp are ignored by UAG and all RemoteApps are exposed to every user that in the UAG portal.

    My question is how do i apply security rights on the RemoteApps published in UAG without creating an application for every Remoteapp?
    I know it is possible to create a single application for every RemoteApp and apply security rights on that application. I think this is not the way to do it by design and will also give some limitation on the endpoint policies.

    Thank you.

    Monday, April 23, 2012 6:39 PM

Answers

  • I passed by the same issue and I solved it by doing the following:

    Let us say you have 3 remote app applications, 2 of them for finance team and 1 for sales team

    1. I exported the TSPUB file from my single RDS Host server, From the UAG I added RemoteApp application, pointed to the TSPUB, picked only the 2 Finance Apps. From the Authorization TAB, I unchecked allow all users and allowed only the Finance OU (AD integrated) or you can add them manually.

    2. Again I add another Remote App in the UAG, pointed to the same TSPUB (It gave me a warning since the same RDS Host was used on another RemoteApp but it will work normally), this time picked the 1 Sales applications. From the Authorization TAB, I unchecked allow all users and allowed only the Sales OU (AD integrated) or you can add them manually.

    One other workaround, is to create one RemoteApp and right click on it in the UAG - Duplicate and change your settings.


    Please remember to click “Mark as Answer” / "Vote as Helpful" on the post that helps you

    My blog: http://itcalls.blogspot.com/


    Wednesday, November 28, 2012 9:18 AM