none
Team Builder Permission in Project Professional RRS feed

  • Question

  • I am using Project Professional 2010 connected to Project Server.

    As a project Manager in PWA I am able to use the build team function on a project and assign resources as desired.  However, in Project Professional when trying to use this feature, I receive a message that says "You do not have sufficient permissions to add enterprise resources to your project from Project Server".

    I understand that there are two seperate permissions related to Team Bulder.  One that allows you to add resources to new projects and one that allows you to add resources to exisiting projects.  The permission to add resources through Team Builder on new projects has NOT been enabled.

    The project in quesiton has been published because I assigned myself a task and see it in the tasks page.

    The ability for Project Managers to publish new projects has also NOT been enabled, but I am able to save and publish this project without issue, which tells me this project does not qualify as new.  I am listed as the project owner on the project as well as the Status Manager.

    Any insgiht to this scenario would be greatly appreciated.

    Tuesday, May 15, 2012 8:07 PM

All replies

  • Hi,

    Without getting too much into detail, it is worth reviewing the documentation at http://technet.microsoft.com/en-us/library/cc197622.aspx .  The easiest way to troubleshoot this is to remove yourself from all groups other than PM, and/or set your permissions per user (ie for you).  You might not have the rights to do this, so you'll need to work with your admin to set this up.  Also remember that the DENY setting overrules all other permissions.


    Ben Howard [MVP] blog | web

    Tuesday, May 15, 2012 9:38 PM
    Moderator
  • Hi Ben,

    Thanks for the response.

    I have reviewed the Project Administrator document in detail before posting my question and was unable to determine the setting that is preventing this from working.  I have administrator privileges and have tried a number of different scenarios without identifying the solution.

    My hope is that someone with specific knowledge related to this feature can provide me with the specifics to resolve this issue.

    Tuesday, May 15, 2012 11:32 PM
  • Hi ColinMacw,

    If you are a member of the administrators group, then this should work.  To further troubleshoot this.

    1.  Remove yourself from all groups except administrator

    2.  Remove any category associations from your specific user

    3.  Remove any global permissions from your specific user.

    Re-check the issue.  If it still doesn't work, then you have a functional issue somewhere effecting the integrity of your Project Server soln.   If it does  work then you have or had a deny permission set somewhere.

    The above assumes that the administrator permissions have not been changed from the default.


    Ben Howard [MVP] blog | web

    Wednesday, May 16, 2012 6:51 AM
    Moderator
  • Hi Ben,

    Thank you for the continued support.

    My apologies if the question was not clear, but I am asking this question based on me acting as a Project Manager which will not have administrator access.  I have already confirmed that this functionality works without issue if I am logged in as an administrator.

    My question is what differentiates the Build Team on Project versus Build Team on New Project.  We do not allow Project Managers to create new Projects or Build Team on new projects, but we do allow Build Team on Projects.  With these settings as a Project Manager I was able to Build Team through PWA and it worked as expected, but when I tried to use this functionality in Project Professional I got a message "You do not have sufficient permissions to add enterprise resources to your project from Project Server". 

    It does not make sense to me why it would work through PWA and not Project Professional.

    Friday, May 18, 2012 4:18 PM
  • What happens if you add the Build team on new  project permission? Anything?

    For me if I deny that permission I am no longer able to build team in Project Pro, even if it is not a 'new' project.

    I think the permission is a bt narrowly named. It seems to control the ability to build team in Project Pro completely.


    Brian Kennemer - Project MVP
    DeltaBahn Senior Architect
    endlessly obsessing about Project Server…so that you don’t have to.
    Blog | Twitter | LinkedIn


    Friday, May 18, 2012 4:56 PM
    Moderator