locked
Windows 7 Logon RRS feed

  • Question

  • When i sign on or switch users, my windows 7 does not display an icon for all users.  Instead it displays an icon for the last user and "others".  How do i get each user icon to show on the logon screen (5 in total)???

     

    Thanks for your help.

     

    Friday, April 1, 2011 2:41 PM

Answers

  • You should try the following steps. I did not try them personally but it should work for you...

    1- First let’s login with the current user account.

     2. Click Start and type run in the search and hitEnter.

     

    3. Let’s type “control userpaswords2” in therun window and hit Enter

     

    4. Let’s check whether the check box which says Users must enter a user name and password to use is checked. If the check box is checked then let’s uncheck the check box, click on apply and ok tab and hit enter.

     

    5. Restart the system.

    6. You will be able to see different users in the logon screen.

    --------------------------------------------------------------------------------

    Or you can try this registry change on your own risk... (You can always make a backup of this registry key)

    Click the Start menu and type regedt32. Navigate to the following key.

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList

    In the profile list, there is a key called .DEFAULT with no data. Delete that key and restart your computer.

     

    I found these solutions on the http://answers.microsoft.com/en-us/windows/forum/windows_7-security/make-windows-7-show-user-list-on-login-screen-not/63cea659-f6a0-412d-a0b1-952a26c1df44 site.

    Thanks

     

     


    Kubilay Elmas
    • Marked as answer by Juke Chou Monday, April 25, 2011 9:10 AM
    Tuesday, April 5, 2011 4:26 PM

All replies

  • Are you on a domain or workplace/school network?  
    Shawn Keene
    Saturday, April 2, 2011 2:19 AM
  • Its really just one computer at my home that various people use.  They each have seperate user accounts.
    Sunday, April 3, 2011 6:37 PM
  • Well I know that if the computer idles-to-lock (screensaver, sleep or anything else that makes the computer lock), it will only show the current logged in user until you click the blue "Switch User" button.  On a domain, this would cause you to see the screen you describe (just the last user, then "other user" where they'd have to type their own username and password.

    At home, clicking the blue "Switch User" button should make it show all accounts.  Unless you've told it not to store or display the last logged in user.  It sounds counter-inituitive, but disabling that also loses the list of accounts.

     

    Are you having to type the other user's name and password, or are you able to access the icon tiles for them and just click the user you want to login as?

     

     


    Shawn Keene
    Sunday, April 3, 2011 7:21 PM
  • I have to click other, then type the user's name and password (no icon titles shown except for the last user).  I did not consciously disable anything.  However, can't say whaat I did inadvertantly.

     

    Thanks for your help

    Monday, April 4, 2011 3:52 PM
  • You should try the following steps. I did not try them personally but it should work for you...

    1- First let’s login with the current user account.

     2. Click Start and type run in the search and hitEnter.

     

    3. Let’s type “control userpaswords2” in therun window and hit Enter

     

    4. Let’s check whether the check box which says Users must enter a user name and password to use is checked. If the check box is checked then let’s uncheck the check box, click on apply and ok tab and hit enter.

     

    5. Restart the system.

    6. You will be able to see different users in the logon screen.

    --------------------------------------------------------------------------------

    Or you can try this registry change on your own risk... (You can always make a backup of this registry key)

    Click the Start menu and type regedt32. Navigate to the following key.

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList

    In the profile list, there is a key called .DEFAULT with no data. Delete that key and restart your computer.

     

    I found these solutions on the http://answers.microsoft.com/en-us/windows/forum/windows_7-security/make-windows-7-show-user-list-on-login-screen-not/63cea659-f6a0-412d-a0b1-952a26c1df44 site.

    Thanks

     

     


    Kubilay Elmas
    • Marked as answer by Juke Chou Monday, April 25, 2011 9:10 AM
    Tuesday, April 5, 2011 4:26 PM