locked
Message Size Attachment Rejection when sending outbound. RRS feed

  • Question

  • Good Afternoon,

           I have a customer running Exchange 2010 SP3 RU5 on SBS 2011. When trying to send a message that has a 10+ MB attachment they receive a rejection message:

    This message wasn't delivered to anyone because it's too large. The limit is 9 MB. This message is 25 MB.
    lance.lingerfelt@domain.net (lance.lingerfelt@domain.net)
    Requested gave this error:
    SMTPSEND.OverAdvertisedSize; message size exceeds fixed maximum size

    This message is larger than the size limit for messages. Please make it smaller and try sending it again.
     
    Diagnostic information for administrators:
    Generating server: GFPSBS11.sourcedomain.local

    lance.lingerfelt@domain.net
    Requested #550 5.3.4 SMTPSEND.OverAdvertisedSize; message size exceeds fixed maximum size ##

    I have checked and adjusted all the connectors and transport server settings to 40MB:

    [PS] C:\Windows\system32>Get-TransportConfig | fl *Max*

    MaxDumpsterSizePerDatabase      : 25 MB (26,214,400 bytes)
    MaxDumpsterTime                 : 7.00:00:00
    MaxReceiveSize                  : 40 MB (41,943,040 bytes)
    MaxRecipientEnvelopeLimit       : 5000
    MaxSendSize                     : 40 MB (41,943,040 bytes)
    ExternalDsnMaxMessageAttachSize : 40 MB (41,943,040 bytes)
    InternalDsnMaxMessageAttachSize : 40 MB (41,943,040 bytes)

    [PS] C:\Windows\system32>Get-SendConnector | fl Name,*Max*

    Name                         : Windows SBS Internet Send GFPSBS11
    SmtpMaxMessagesPerConnection : 20
    MaxMessageSize               : 40 MB (41,943,040 bytes)

    Name                         : GFIFaxmaker
    SmtpMaxMessagesPerConnection : 20
    MaxMessageSize               : 40 MB (41,943,040 bytes)

    Name                         : Internet Send
    SmtpMaxMessagesPerConnection : 20
    MaxMessageSize               : 40 MB (41,943,040 bytes)

    [PS] C:\Windows\system32>Get-ReceiveConnector | fl Name,MaxMessageSize

    Name           : Default GFPSBS11
    MaxMessageSize : 40 MB (41,943,040 bytes)

    Name           : Windows SBS Fax Sharepoint Receive GFPSBS11
    MaxMessageSize : 40 MB (41,943,040 bytes)

    Name           : Windows SBS Internet Receive GFPSBS11
    MaxMessageSize : 40 MB (41,943,040 bytes)

    Name           : Network Devices
    MaxMessageSize : 40 MB (41,943,040 bytes)

    Name           : CrystalReports
    MaxMessageSize : 40 MB (41,943,040 bytes)

    Name           : Konica Minolta Printer
    MaxMessageSize : 40 MB (41,943,040 bytes)

    There are no special SmartHosts that the internet send connector sends to. I created a new send connector and disabled all of the other send connectors and tried to send the message again with the same error. I also checked the corresponding ADSI Attributes to see if they did  not apply or were wrong for some reason:

    I went to ADSI Edit and browsed to Configuration\Services\Microsoft Exchange\GASFP\Global Settings
    I then looked at the following of Message Delivery Properties:

    delivContLength: This is the incoming message size limit that corresponds to the MaxReceiveSize parameter in the Set-TransportConfig cmdlet.
    submissionContLength: This is the receiving message size limit that corresponds to the MaxSendSize parameter in the Set-TransportConfig cmdlet.
    msExchRecipLimit: This is the maximum number of message recipients that corresponds to the MaxRecipientEnvelopeLimit parameter in the Set-TransportConfig cmdlet.

    The first two were set to 40MB and the last was set to 5000 recipients. All these settings are correct.

    I am stuck at this point and any help would be appreciated.

    Thanks,

    Lance Lingerfelt

    Friday, June 27, 2014 8:14 PM

Answers

  • Lance hi,

    Log on to your BlackBerry Administration Service web console.

    Servers and components > BlackBerry Solution topology > Server view > <BES Name>  > BES Server Name_EMAIL > Click on the Messaging tab

    The settings for maximum attachments are defined here.

    Can you check if this is relevant to your case? If it is, scroll down and hit the Edit Instance hyper-link, and set the values appropriately.

    That said, I do not know why this should prevent them from sending large emails.

    Regards

    • Marked as answer by Richard Kuai Tuesday, August 5, 2014 4:26 AM
    Friday, July 11, 2014 10:05 AM

All replies

  • Hello,

    What about a mailbox settings?

    Get-mailbox | ft Name, MaxSendSize, MaxReceiveSize

    Do you try to send an email with Outlook or Outlook Web App? 

    Any transport rules?
    Friday, June 27, 2014 8:38 PM
  • Hi,

    Did this issue occur if you send messages internally?

    Have you re-started the transport service to check the result?

    Could you please add a smaller size attachment, such as 3MB to check the result?

    And please check if there is a transport rule restricting the attachment size.

    After you adjust the size to 40MB, do you receive the NDR with the same error: "This message wasn't delivered to anyone because it's too large. The limit is 9 MB. This message is 25 MB."?

    Best regards,

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Belinda Ma
    TechNet Community Support

    Monday, June 30, 2014 7:24 AM
  • As suggested by ZAZA, it appears like a single user with less maxsendsize..

    Please confirm whether this is a single user issue or global?

    Monday, June 30, 2014 7:31 AM
  • Hi Belinda,

           Did this issue occur if you send messages internally? 

    Yes it does happen internally and externally.

           Have you re-started the transport service to check the result? 

    I restarted the Transport service and got the same error.

         Could you please add a smaller size attachment, such as 3MB to check the result?

    The message goes through when under 9 MB.

         And please check if there is a transport rule restricting the attachment size.

    The customer has no transport rules other than a disclaimer message.

         After you adjust the size to 40MB, do you receive the NDR with the same error: "This message wasn't delivered to anyone because it's too large. The limit is 9 MB. This message is 25 MB."?       

    Yes I get the same error.

    Thanks,

    Lance

    Monday, June 30, 2014 12:16 PM
  • Hi Rajkumar,

               Please confirm whether this is a single user issue or global?

    The issue happens globally. I created a new user to test with and got the same error as others get.

    Get-mailbox | ft Name, MaxSendSize, MaxReceiveSize

    Name                                    MaxSendSize                             MaxReceiveSize
    ----                                        -----------                                    --------------
    Administrator                         unlimited                                   unlimited
    Journal Mailbox                      unlimited                                   unlimited
    Techs                                     unlimited                                   unlimited

    Lance Lingerfelt                     unlimited                                   unlimited

    Thanks,

    Lance

    Monday, June 30, 2014 12:25 PM
  • Hi Zaza,

          There are no transport rules other than a disclaimer message. This happens with either the OWA or Outlook application. I ran the cmdlet and nobody in question has a send or receive limit on their mailbox.

    Thanks,

    Lance

    Monday, June 30, 2014 12:45 PM
  • OK, try to check all of these things please:

    Scope of Limits

    Following are the basic categories for the scope of the limits available for individual messages:

    • Organizational limits   These limits apply to all Exchange 2010 and Exchange 2007 servers that exist in the organization. The specified message limits apply to all Exchange 2010 and Exchange 2007 servers that have the Hub Transport server role installed. On an Edge Transport server, the specified limits apply to the specific server.
    • Global limits   Global limits are used when  Exchange Server 2003 servers coexist with your Exchange 2010 deployment. The global limits are stored in a different location in Active Directory than the organizational limits and are primarily used by Exchange Server 2003 servers. In an environment where you have both Exchange 2010 and Exchange Server 2003 servers in the same organization, changes that you make to the organizational limits are automatically copied to the corresponding global limits. In Exchange 2010, you can modify the organizational limits by using the Set-TransportConfig cmdlet in the Exchange Management Shell, or by configuring the Hub Transport server organization configuration properties in the Exchange Management Console.
    • Connector limits   These limits apply to any messages that use the specified Send connector, Receive connector, Delivery Agent connector, or Foreign connector for message delivery. Connectors are defined on Hub Transport servers or Edge Transport servers.
    • Active Directory site links   Hub Transport servers use Active Directory sites and the costs that are assigned to the Active Directory IP site links to determine the least-cost routing path from each Hub Transport server in the organization to every other Hub Transport server in the organization. You can assign specific message size limits to the Active Directory site links in your organization. For example, you may want to apply a lower message size limit to an Active Directory site link that represents a connection to a remote office with a low-bandwidth connection. Any messages that exceed the maximum message size limit on any Active Directory site link included in the least-cost routing path won't be delivered and will generate a delivery status notification (DSN) with a value of 5.3.4. For more information about message routing in Exchange 2010, see Planning to Use Active Directory Sites for Routing Mail.
    • Routing group connectors   A routing group connector is used to send and receive messages between Exchange 2010 Hub Transport servers and Exchange Server 2003 bridgehead servers when the organization is running more than one version of Microsoft Exchange. Any messages that exceed the maximum message size limit on any routing group connector won't be delivered. They will generate a DSN with the value of 5.3.4. For more information about routing group connectors, see Upgrade from Exchange 2003 Transport.
    • Server limits   These limits apply to a specific Hub Transport server or Edge Transport server. You can set the specified message limits independently on each Hub Transport server or Edge Transport server.
      If you are using Outlook Web App, the maximum HTTP request size limit setting on the Client Access servers also controls the size of messages that Outlook Web App users can send. For more information, see Configure Maximum Message Size in Outlook Web App.
    • User limits   These limits apply to a specific user object, such as a mailbox, contact, distribution group, or public folder.

    Understanding Message Size Limits

    Monday, June 30, 2014 1:15 PM
  • Hi,

    Have you checked Zaza Abramov's suggestions?

    Is there any update?

    Best regards,

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Belinda Ma
    TechNet Community Support

    Wednesday, July 2, 2014 8:28 AM
  • Good morning,

                   I have checked all of those settings and I am still getting the same error.

    Lance

    Wednesday, July 2, 2014 12:13 PM
  • Hi again,

    Lance D. Lingerfelt, would you accept that there is no issue of your ISP?

    Please, confirm that Outlook clients are using TCP connection

    Have you checked a Web.config file? "Program Files\Microsoft\Exchange Server\V14\ClientAccess\Owa"

    Could you show us, please values of:

    1. RequestLimits maxAllowedContentLength ?
    2. httpRuntime maxRequestLength ?

    Make a copy of this file and then change those like

    RequestLimits maxAllowedContentLength="40000000"

    httpRuntime maxRequestLength="40000"

    Save and reset IIS.


    Wednesday, July 2, 2014 9:05 PM
  • Hi,

    In addition, please check the limit in the following location in the Registry.

    Here is an example for Outlook 2010:

    Key: HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Preferences
    Value name: MaximumAttachmentSize
    Value type: REG_DWORD

    The value that you need to use is in KB.

    Note: Increasing the limit in Outlook does not increase the limit set by your ISP or administrator on the mail server.

    If it still doesn't work, I recommend you contact your ISP to verify the size limit they set.

    Best regards,

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Belinda Ma
    TechNet Community Support

    Friday, July 4, 2014 2:03 AM
  • It would appear from the error message that the error is being generated by the recipients email system and not the sending system. Your error message reads an SMTP 550 error - that would be generated by the receiver.

    As the email is too big for the recipient, you will need to find another way to get it to to them.


    Brian Reid C7 Solutions Ltd (www.c7solutions.com)

    Sunday, July 6, 2014 7:01 PM
  • Hi,

    I have not heard back from you in a few days and wanted to check on the status of the problem. If there is any question, please feel free to let me know.

    Best regards,

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Belinda Ma
    TechNet Community Support

    Monday, July 7, 2014 1:24 AM
  • Hello,

    I will be checking on these settings today. I will let you know what I find.

    Thanks,

    Lance

    Monday, July 7, 2014 12:41 PM
  • I can confirm that there is no issue with the ISP.

    Outlook clients are using Outlook Anywhere to connect.

    Here are the values in the Web.Config file:

    <security>
                <requestFiltering>
                    <requestLimits maxAllowedContentLength="40000000" />
                </requestFiltering>
            </security>
        </system.webServer>
        <system.web>
            <httpRuntime maxRequestLength="40000" enableVersionHeader="false" />
            <authentication mode="Windows" />
            <sessionState mode="Off" />

    There was no need to reset IIS since the values were the ones you specified.

    Not sure what else to try at this point.

    Lance

    Monday, July 7, 2014 2:03 PM
  • Hello,

    I added this key to a group policy for the Outlook 2010 clients. Hopefully this might fix any client issues that are causing this problem.

    Thanks,

    Lance

    Monday, July 7, 2014 2:11 PM
  • Hi,

    I was sending the email to my own company's system and out transport settings are set to 100MB Send and Receive. I have tested with other accounts and I received the email. The server in question is the one generating the error.

    Lance

    Monday, July 7, 2014 2:12 PM
  • Hi,

    Based on the description, you can receive messages from Internet. And the generating server is your server, is it right?

    I am trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience.

    Best regards,

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Belinda Ma
    TechNet Community Support

    Tuesday, July 8, 2014 1:51 AM
  • Hi,

    I just read your thread and issue you are having at the moment. Can you please check if the customer does have any firewall from which your email traffic is going through and the maximum size limit on the device? I used to have similar kind of issue with my customer and after troubleshooting we found that it's because of policy set on their Anti-x appliance. Thanks.

    Kindly let me know if it works for you. Thanks.


    Regards, Riaz Javed Butt | Consultant Microsoft Professional Services MCITP, MCITP (Exchange), MCSE: Messaging, MCITP Office 365 | msexchgeek.wordpress.com

    Tuesday, July 8, 2014 2:32 AM
  • Hi,

    Yes, the customer can receive large messages from the internet, and the generating server is the customer's server.

    I have found out that they do have a blackberry enterprise server that some users do use, but I could not find any settings that mention the maximum size limit of 9MB on the blackberry server. Blackberry doesn't install anything on the exchange server correct?

    Lance

    Tuesday, July 8, 2014 2:49 PM
  • It depends,

    Blackberry has a Blackberry Enterprise Server for MS Exchange, and maybe there are settings that we need.

    Also, blackberry smartphone does not work without BIS (Blackberry Internet service )

    What is the maximum email message size when using a BlackBerry Internet Service account




    Tuesday, July 8, 2014 3:01 PM
  • It depends which version of black berry you are using.

    Regards, Riaz Javed Butt | Consultant Microsoft Professional Services MCITP, MCITP (Exchange), MCSE: Messaging, MCITP Office 365 | msexchgeek.wordpress.com

    Wednesday, July 9, 2014 2:07 AM
  • Blackberry Enterprise Server 5.0.

    Lance

    Thursday, July 10, 2014 6:39 PM
  • Lance hi,

    Log on to your BlackBerry Administration Service web console.

    Servers and components > BlackBerry Solution topology > Server view > <BES Name>  > BES Server Name_EMAIL > Click on the Messaging tab

    The settings for maximum attachments are defined here.

    Can you check if this is relevant to your case? If it is, scroll down and hit the Edit Instance hyper-link, and set the values appropriately.

    That said, I do not know why this should prevent them from sending large emails.

    Regards

    • Marked as answer by Richard Kuai Tuesday, August 5, 2014 4:26 AM
    Friday, July 11, 2014 10:05 AM
  • Hey,

    Has this issue resolved by changing the Blackberry server setting?

    Thursday, July 24, 2014 9:26 AM