locked
Service Request Completes without approval RRS feed

  • Question

  • Gentlemen, hope some of you have seen this odd behaviour with SCSM 2012 SP1.

    My Service Request workflow has three activities (there is actually four, but the first one is a stub activity, which is skipped, just to hold the portal user input):

    1-A Runbook that stages the whole workflow and, among other things, sets the approver of the request according to certain conditions

    2-A Review Activity, which has no approver set by default

    3-A final piece that actually executes the tasks, send certain notifications,etc.

    Two odd facts are happening:

    1 - Sometimes, not always, SCSM decides to kick-off the Review Activity (set it to In Progress) before the approver has been set. This will add the empty approver (and later, the runbook will add another one). Couldn't find a reason why it happens sometimes, not always.

    2 - Event with no approval, the Runbook that comes after the Review activity is executed and the service request completes, even when the Review Activity is still In Progress.

    The latter only happens when the first does. I have just submitted another request and it worked as expected, so, didn't find a way to reproduce it yet.

    Any ideas?


    MCITP, MCSE, MCTS

    Friday, June 7, 2013 12:58 PM

All replies

  • Do you have 'Update Rollup 2' installed? Service Requests showing symptoms like you are seeing are fixed in that UR.

    Thanks

    Mark


    Mark | http://syscen.blogspot.com/

    Monday, June 10, 2013 7:06 AM
  • Hi Mark, thank you for the reply. Yes, I do have UR2 installed. I believe you are reffering to the issue where all activities are in pending mode and the service request completes with nothing happenening. I'm aware of that, but doesn't seem to be the case. I run more tests las week and I could't finda a pattern. It works most of the times, but every once in a while, it will behave as such. Thank you.

    MCITP, MCSE, MCTS

    Monday, June 10, 2013 10:33 AM
  • Yet to be confirmed, but it seems that if I move my skipped activity to the end of the workflow, things work better. I don't think it should make a difference, but since it doesn't make a difference for me, I will go with that.

    I will try to confirm this as soon as possible.

    Thank you,


    MCITP, MCSE, MCTS

    Monday, June 24, 2013 5:36 PM
  • Hi Jose.

    There is actually a similar workflow 'race condition' bug in UR2 which sounds like it could be impacting you.  This issue relates to Service requests completing when there are no running (in progress) activities present when the 'Service Request Updated' workflow runs.  What you see in that the service request will complete, and other activities on the Service request will update as they should( therefore leaving you with an 'In Progress' activity even though the service request has completed.

    It has been flagged as a bug with PSS/PG and will be fixed, but may, or may not make it into UR3.

    HTH

    Cheers

    Shaun

    Tuesday, June 25, 2013 12:20 PM
  • Thanks for the reply, Shaun. I believe you are right. That issue, along with some fixed related to silverlight in UR3 will be a great relief. Thanks again,

    MCITP, MCSE, MCTS

    Tuesday, June 25, 2013 1:35 PM