locked
Office Web Apps - Services not present on all servers!? RRS feed

  • Question

  • Hello,

    I have been installing Office Web Apps on our SharePoint farm today and it has unfortunately not been quite plain sailing.

    The setup has been run on both our WFE Server and Application Server and after some issues with permissions when trying to run the Configuration Wizard we should now be ready to start the Services.

    Unfortunately the services are only available to start on our Application Server and not our WFE Server!?

    We have an additional farm where I am up to the same stage and the services are available on both servers so I'm rather confused by this. When I initially tried to run the configuration wizard on the troublesome WFE Server it complained about the product being missing from that server. Luckily this blog post and the command 'Get-SPProduct -Local' allowed the Configuration Wizard to run but alas there are no services to start!

    Anyone have any ideas?

    Wednesday, July 11, 2012 2:38 PM

All replies

  • Try running:

    Install-SPService


    http://sharepoint.nauplius.net

    Wednesday, July 11, 2012 4:04 PM
  • Just Install-SPSerivce or should I be including some parameters?

    If it is just to run 'Install-SPService' should I then see the services?

    Wednesday, July 11, 2012 4:45 PM
  • No parameters.  Run it on the server that is missing the services.  Once complete, you should see the services.

    http://sharepoint.nauplius.net

    Wednesday, July 11, 2012 4:45 PM
  • I ran the command on the troublesome server, in the SharePoint Management Shell and though it seemed to take a moment to process ther services are still unavailable to start:

    Thanks

    Thursday, July 12, 2012 11:19 AM
  • I have just looked at the Update status for the troublesome server and the Products are listed there as being applicable for updates...

    So it knows the products are there but it wont install the services...?

    Friday, July 13, 2012 11:01 AM
  • Does anyone have anything else I can try? or anymore digging into the server to see what is or isn't installed?

    Thanks

    Tuesday, July 17, 2012 8:07 AM
  • A shameless post bump!

    Monday, July 23, 2012 7:51 AM
  • I know this is old, but I am having this exact same issue. I can only see the owa services on 
    the application server. Has anybody found a solution to this?

    Thursday, June 20, 2013 9:10 PM
  • Nevermind! Running install-spservice on the servers worked for me :)
    Friday, June 21, 2013 12:03 AM
  • Hi,

    What is the SharePoint Edition that you are having.

    In the above screen even excel services also not listed.


    Regards, Pradeep

    Friday, June 21, 2013 5:45 AM