none
Add first WFE to create 3 tier Project Server 2010 Installation RRS feed

  • Question

  • Hi,

    I am trying to set up a 3 tier Project Server 2010 Farm (SQL Server, App Server, Web Server).

    I have two of the three machines running: The SQL Server and the App Server. The App server provides complete functionality ... Its got a working PWA.

    I have  successfully added the Web Server to the SharePoint Farm, but I cant find any documentation on how to get PWA running on that Web Server. What is the trick????

    Carl

    Thursday, March 15, 2012 9:08 PM

Answers

  • Hi Carl,

    Using a DNS Alias is not a requirement but is recommended as it will give you the flexibility for adding additional WFEs that are load balanced for example.

    So the issue is SharePoint doesnt know about the URL you are trying to use for accessing PWA from the WFE. SharePoint needs to know about the URLs, as you have found you do this by either creating an AAM or extending an existing web application and adding a host header.

    THanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com

    Friday, March 23, 2012 7:33 AM
    Moderator

All replies

  • Hi there,

    If you just want this server to handle the web requests for PWA, just point the DNS Alias for the site URL to the new web server.

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com

    Friday, March 16, 2012 8:57 AM
    Moderator
  • Hi,

    My problem is probably a little more nieve. I now have an AppServer and a WebServer in the farm. When I key in http://AppServer/PWA into the address field on the browser, I get PWA. When I key in http://WebServer/PWA, I get a "Page not found" error.

    Just to prove that the farm in working, when I key in http://AppServer, I get the same root site page as when I key in http://WebServer.

    Carl

    Friday, March 16, 2012 7:46 PM
  • Hi Carl,

    Have you installed Project Server on the new web server?

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com

    Friday, March 16, 2012 7:56 PM
    Moderator
  • Hi Paul,

    Yes we have installed Project Server. But we have not run "Create Project Web App Site" again because it looks like that will want to create a separate instance of Project Server linked to different databases - and that is not what we want. We just want a PWA WFE.

    Carl


    Monday, March 19, 2012 6:25 AM
  • Hi Carl,

    In that case i am not sure why you cannot access PWA from the WFE. You are corrrect, no need to create another PWA site! Quick check list:

    • Installed Project Server binaries on the WFE - YES
    • Have you installed correct farm patches for the Project server binaries on the WFE?
    • Have you run the SharePoint configuration wizard after installing the above?
    • Have you test accessing PWA directly from Internet Explorer 7, 8 or 9 on the WFE? From a client machine?

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com

    Monday, March 19, 2012 8:07 PM
    Moderator
  • Paul, I work with Carl, so will provide responses to your questions:

    • Confirmed SP and Project Server binaries are on WFE
    • Same level CU and patches on both, verified in Central Admin | Manage Patch Status
    • Ran SP config wizard on WFE and added it to the farm
    • From the WFE, I can browse to root site, which is just an empty shell farm.  But /PWA returns "webpage not found".  This is standard IE8 on Windows Server 2008.  Same for client machines
    Wednesday, March 21, 2012 5:37 PM
  • In System Settings --> Manage Servers in Farm

    APP SERVER

    SharePoint Products Installed

      Microsoft SharePoint Server 2010
      Microsoft® Project Server 2010

    Services Running

      Central Administration
      Excel Calculation Services
      Microsoft SharePoint Foundation Incoming E-Mail
      Microsoft SharePoint Foundation Web Application
      Microsoft SharePoint Foundation Workflow Timer Service
      PerformancePoint Service
      Project Application Service
      Secure Store Service

    ********

    WEB SERVER

    SharePoint Products Installed

      Microsoft SharePoint Server 2010
      Microsoft® Project Server 2010

    Services Running

      Excel Calculation Services
      Microsoft SharePoint Foundation Incoming E-Mail
      Microsoft SharePoint Foundation Web Application
      Microsoft SharePoint Foundation Workflow Timer Service
      PerformancePoint Service
      Project Application Service

    Wednesday, March 21, 2012 5:39 PM
  • Hi Howard,

    Can you access <WFE>/pwa/_layouts/pwa/admin/admin.aspx ?

    How was the Web Application that hosts PWA created, what URL does it use? Does it use the http://<applicationserver name> or a DNS Alias?

    Hopefully a DNS Alias then you can just repoint the DNS Alias to the WFE and also should work with web requests going to the WFE.

    If the Web Application URL is http://<applicationserver name> then to get users to access the sites via the WFE you will need to create a new DNS Alias, set up the SharePoint Alternate Access Mapping for that Web Application in Central Admin and then add in the IIS host header in INETMGR on the servers.

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com


    Wednesday, March 21, 2012 6:01 PM
    Moderator
  •  

    Hi Paul,

    This is Carl back on the case.

    We are fairly early in our deployment cycle, setting up the DEV environment for the first time. Haven't gotten around to thinking about DNS alias yet... particularly for the DEV environment ... Do you suppose this is a requirement?

    We want to set up a 3 tier architecture in the Dev environment using simple server names: http://WebServer and http://AppServer.

    So here is today’s progress:

    1. To summarize: After we set up the WFE, we can browse to http://AppServer/PWA but not http://WebServer/PWA. We get an 404 error: The webpage cannot be found.
    2. Browsing to your URL http://WebServer/PWA/_layouts/pwa/admin/admin.aspx results in a dramatic SharePoint internal Error. Looking up the error in the ULS, we get a wonderful cluster of information, ending with a full Dr. Watson, but more to the point, starting with:

    Alternate access mappings have not been configured.  Users or services are accessing the site http://sacappmpsd01 with the URL http://sacwebmpsd01.  This may cause incorrect links to be stored or returned to users.  If this is expected, add the URL http://sacwebmpsd01 as an AAM response URL.

    So what is a response URL? An internal URL or an external URL? My guess is the external URL…

    1. So we added an Alternate Access Mapping and the results were even stranger.
      • SharePoint Central Administration ->Alternate Access Mappings
      • Selected the SharePoint – 80 collection
      • Found existing mapping:
      • Added second Access Record
    2. Now everything sort of works – like we went down the rabbit hole on LSD. http://WebServer/PWA resolves, but all the internal references in the pages are to http://AppServer/PWA so, as soon as you start using the site, you wind up being redirected to the other server. You may start the dance with http://WebServer/PWA, but real soon you are dancing with http://AppServer/PWA.
    3. So we went back to SharePoint Central Administration ->Alternate Access Mappings -> Edit Public Zone URLs  and changed the Public URL for the Default Zone to http://WebServer
    4. Now it all works – I guess – Do you think that is the Solution?
    5. The only down side to this is that all use of all SharePoint:80 apps must now go through http://WebServer.  We were hoping us PWA admins could sneak into http://AppServer/PWA but perhaps that not to be.


    Thursday, March 22, 2012 10:43 PM
  • Hi Carl,

    Using a DNS Alias is not a requirement but is recommended as it will give you the flexibility for adding additional WFEs that are load balanced for example.

    So the issue is SharePoint doesnt know about the URL you are trying to use for accessing PWA from the WFE. SharePoint needs to know about the URLs, as you have found you do this by either creating an AAM or extending an existing web application and adding a host header.

    THanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com

    Friday, March 23, 2012 7:33 AM
    Moderator