locked
Multitude of issues with WSUS on Windows Server 2019 RRS feed

  • Question

  • I have installed Windows Server 2019 on a X299 system with a 7900X CPU, 32GB DDR4-3200 ram on a 970 Evo Plus 1TB SSD. The server has 11 HDDs totaling 115TB, running a GTX 1660 Ti GPU and an 850W PSU. The Server has an ASUS 10G NIC installed, and two gigabit NICs (Generally left disabled). The server is connected to a Netgear MS510-TX Multigig switch.

    I run IIS, WSUS, and Macrium Reflect. I would have thought these specs were way over the top for what the server is used for. It tends to get the hand me downs from other computers when they are upgraded.

    Since installing most things are considerably slower than the Windows Server 2012 system that preceded it. Clients load web pages much slower from the server. File transfers are extremely erratic, ranging from 0 bytes to 1.1GB/s. Writes to server from a client of a (eg) 20GB file will start @ 1.0GB/s then drop to 0bytes for 45 seconds, then speed up for 5 seconds. Remote Differential Compression is disabled (I've tried both).

    So, I'm not sure if the following are symptomatic of WSUS issues or more general server issues. But these are the specific issues I'm having with WSUS.

    1. Slow to load. WinSvr 2012 R2: < 10 Seconds. WinSvr 2019: 15 - 20 seconds.
    2. Does not retain settings. If I select columns, they revert original columns every time I run console, or change screens.
    3. Clicking on an update will take up to 20 seconds to highlight and the bottom pane update.
    4. If accidentally double click an update twice to view the report the console will crash to the desktop
    5. When I select "Any except declined" this is not retained between sessions, or even if I go to computers, or other areas of WSUS. When I come back, it reverts to Unapproved.
    6. The order of updates is not retained between sessions or when navigating to other areas of WSUS and back. (I normally like to look at the updates by Approval status, or sometimes by KB article.
    7. If I click an update and I want to click another update lower down, holding shift so I can select a group, the selection follows the mouse movement and scrolls very fast. I have to click on a different update then click the original again then move to the last update I want to select while holding shift.

    Server is patched to 2020-03. I generally wait a few weeks when CUs are released to let the problems sort themselves out.

    I started from scratch, formatted SSD and installed again. Same issues exactly.

    Are any of these known issues with WSUS? Are there any fixes? Could this be bigger than WSUS?

    thank you.

    Saturday, April 18, 2020 4:11 PM

All replies

  • Hi,
     
    Based on your description, I can't determine the specific cause of the failure for the time being. I suggest considering the following links for optimization.
    https://support.microsoft.com/en-us/help/4490414/windows-server-update-services-best-practices
     
    If you have any further questions, please contact me.
     
    Regards,
    Rita

    Please remember to mark as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Monday, April 20, 2020 8:11 AM
  • Yeah, good one. You linked directly back to this post
    Monday, April 20, 2020 10:43 AM
  • Hi TanyaC0205,


    I'm sorry to paste an incorrect link. I have corrected my mistake. I deeply apologize for my mistake.


    Regards,

    Rita


    Please remember to mark as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, April 21, 2020 2:47 AM
  • That doesn't look relevant.

    Whilst the console does seem to hang when clicking on an update, I don't think the recommendations on that link apply. I'm running 4993 total patches. I have 32GB of RAM. Worst case scenario, my memory has never gone over 19% total usage for all of Windows and the running applications.

    But WSUS not retaining settings between session or even between various areas of WSUS seems more like a bug then a performance tuning issue.

    Bandwidth is also not an issue.

    I also run clean up on a monthly basis.

    I have not messed with permissions either.


    • Edited by TanyaC0205 Tuesday, April 21, 2020 6:54 AM
    Tuesday, April 21, 2020 6:54 AM
  • Hi,
     
    You mentioned that you deployed 4993 patches at once. Too many patches at once may affect the use of WSUS. This may be why WSUS usage is not smooth.  
     
    When the number of simultaneous approval updates is large, two problems arise.
    1. WSUS's instantaneous download pressure is high
    2. The traffic between WSUS and a single client increases, and if there are more clients, the traffic is multiplied, and the pressure will eventually squeeze on the database.
     
    For such questions, you may consider the following actions:
    1. Before approval, optimize the approval list、decline the superseded updates、exclude expired updates、 and exclude non-essential products.
    2. If there are more devices in the environment, you can consider approving updates for different computer groups in batches to reduce transient pressure.
     
    Regards,
    Rita

    Please remember to mark as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, April 22, 2020 3:26 AM
  • What on earth?

    No I did NOT deploy 4993 patches at once. I said WSUS says there are 4993 patches TOTAL in the list. IIRC at the time there might have been 30 or so waiting for approval. That means 4963 of those were already applied, not applicable or superseded/declined etc. "I'm running 4993 patches" does not mean "deploying 4993 patches simultaneously".

    I can't stay on Win 2012 R2 for several reasons (not the least of which is that it's out of support). But I restored back to 2012 R2 from a backup. ALL problems disappear. WSUS works exactly as it should. It remembers my selections, columns etc. My file transfers are far more stable and consistent. EVERY SINGLE ISSUE I have is resolved by going back to 2012 R2.

    That means the problems are either related to the version of WSUS on Server 2019, or the issues are related to Server 2019 or both.

    So far, in 3 weeks, no one has said confirmed whether these are known issues in WSUS on S2019, or there are no known issues - in which case I just found a bunch! This is the WSUS forum, but I'm not seeing any responses related to my original post.


    • Edited by TanyaC0205 Friday, May 8, 2020 10:24 AM
    Friday, May 8, 2020 10:21 AM
  •          

    Hi TanyaC0205,

    Thanks for your posting. I understand that the issue brought some trouble to you. Sorry for all these inconvenience. 

    In order to better analyze and solve current issue, there is the following information you need to provide:
    1. Please consider providing current Windows Server 2019 version.
    2. Please consider confirming how to upgrade from Windows Server 2012R2 to Windows Server 2019.

    Please note that before upgrade from Windows Server 2012R2 to Windows Server 2019, you have to uninstall WSUS in advance.

    Reference link: https://docs.microsoft.com/en-us/windows-server/upgrade/upgrade-2012r2-to-2019


    If you have any updates, please keep us in touch. 

    Best regards,
    Rita


    Please remember to mark as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.





    Tuesday, May 12, 2020 7:22 AM
  • Have you retuned the IIS and WSUS configuration after you installed the WSUS on the Windows 2019 server?

    Pre Windows 2016 Clients, the default WSUS and IIS configuration was fine.  On the Windows 2016 and after clients, the Cumulative updates are so large and the client takes so long to process the update, if you have not extended the Timeout on the IIS server, the IIS Server would drop the connection before the client would report back.  Then the client would have to check again which would fail and you would get an endless loop of trying to check for updates which causes the WSUS server to become very busy. 

    32 GB's is enough memory but the IIS configuration must be changed to use it. We have 2600+ machines in our WSUS and have the IIS memory set to 20 GBs.

    The most important thing is the Timeout.

    Change \Program Files\Update Services\WebServices\ClientWebService\Web.Config.
    {Make backup of original before changing}

    Replace Line
    <httpRuntime maxRequestLength="4096" />

    by Line

    <httpRuntime maxRequestLength="4096"  executionTimeout="3600" />


    Website explaining why
    https://blogs.technet.microsoft.com/configurationmgr/2017/08/18/high-cpuhigh-memory-in-wsus-following-update-tuesdays/

     

    Friday, May 15, 2020 8:21 PM
  • Rita,

    As I said in my original post, it was a completely fresh install. Everything was wiped and a clean install from a freshly created USB from the official S2019 ISO.

    Windows server is currently updated to the 2020-04 patches, plus any others like flash and .net updates.

    Bruce,

    No, I have not done any tuning per se. Just configured the websites I use, otherwise it's at it's defaults. I need to get Coldfusion installed but I haven't done that as there are just too many issues with WSUS.

    I made the time out change, but I don't see how that relates to the issues I'm having with WSUS.

    I'm going back to Server 2012 R2. I had a reason for upgrading to 2019, but I don't recall what it was. But there are just too many problems with WSUS on S2019.

    Sunday, May 31, 2020 3:20 AM